summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-networking/recipes-filter/ipset/ipset_7.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-filter/ipset/ipset_7.9.bb')
-rw-r--r--meta-openembedded/meta-networking/recipes-filter/ipset/ipset_7.9.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-openembedded/meta-networking/recipes-filter/ipset/ipset_7.9.bb b/meta-openembedded/meta-networking/recipes-filter/ipset/ipset_7.9.bb
new file mode 100644
index 000000000..95e48f013
--- /dev/null
+++ b/meta-openembedded/meta-networking/recipes-filter/ipset/ipset_7.9.bb
@@ -0,0 +1,21 @@
+# Copyright (C) 2017 Aaron Brice <aaron.brice@datasoft.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Administration tool for IP sets"
+HOMEPAGE = "http://ipset.netfilter.org"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
+SECTION = "base"
+
+DEPENDS = "libtool libmnl"
+
+SRC_URI = "http://ftp.netfilter.org/pub/ipset/${BP}.tar.bz2"
+SRC_URI[sha256sum] = "b75c13689eddf1d95b396840a69dc04fd7ae4112b10b70594bc0405df7b9b30a"
+
+inherit autotools pkgconfig module-base
+
+EXTRA_OECONF += "-with-kbuild=${KBUILD_OUTPUT} --with-ksource=${STAGING_KERNEL_DIR}"
+
+RRCOMMENDS_${PN} = "\
+ kernel-module-ip-set \
+"