summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-networking/recipes-filter/nftables
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-filter/nftables')
-rw-r--r--meta-openembedded/meta-networking/recipes-filter/nftables/nftables_0.9.2.bb (renamed from meta-openembedded/meta-networking/recipes-filter/nftables/nftables_0.9.0.bb)16
1 files changed, 11 insertions, 5 deletions
diff --git a/meta-openembedded/meta-networking/recipes-filter/nftables/nftables_0.9.0.bb b/meta-openembedded/meta-networking/recipes-filter/nftables/nftables_0.9.2.bb
index 3ff9583fc..98e8050b8 100644
--- a/meta-openembedded/meta-networking/recipes-filter/nftables/nftables_0.9.0.bb
+++ b/meta-openembedded/meta-networking/recipes-filter/nftables/nftables_0.9.2.bb
@@ -7,16 +7,22 @@ DEPENDS = "libmnl libnftnl readline gmp bison-native"
UPSTREAM_CHECK_URI = "https://www.netfilter.org/projects/nftables/files/"
-SRC_URI = "http://www.netfilter.org/projects/nftables/files/${BP}.tar.bz2 \
- "
-SRC_URI[md5sum] = "d4dcb61df80aa544b2e142e91d937635"
-SRC_URI[sha256sum] = "ad8181b5fcb9ca572f444bed54018749588522ee97e4c21922648bb78d7e7e91"
+SRC_URI = "http://www.netfilter.org/projects/nftables/files/${BP}.tar.bz2"
+SRC_URI[md5sum] = "dfe130724d7c998eb26b56447e932899"
+SRC_URI[sha256sum] = "5cb66180143e6bfc774f4eb316206d40ac1cb6df269a90882404cbf7165513f5"
inherit autotools manpages pkgconfig
-PACKAGECONFIG ?= ""
+PACKAGECONFIG ?= "python"
PACKAGECONFIG[man] = "--enable--man-doc, --disable-man-doc"
+PACKAGECONFIG[python] = "--with-python-bin=${PYTHON}, --with-python-bin="", python3"
+
+inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
ASNEEDED = ""
RRECOMMENDS_${PN} += "kernel-module-nf-tables"
+
+PACKAGES =+ "${PN}-python"
+FILES_${PN}-python = "${libdir_native}/${PYTHON_DIR}"
+RDEPENDS_${PN}-python = "python3-core python3-json"