summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-networking/recipes-support/drbd
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-support/drbd')
-rw-r--r--meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils/0001-v84-Make-setup_options-definitions-as-extern.patch32
-rw-r--r--meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils_9.13.1.bb (renamed from meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils_9.12.0.bb)12
-rw-r--r--meta-openembedded/meta-networking/recipes-support/drbd/drbd_9.0.24-1.bb (renamed from meta-openembedded/meta-networking/recipes-support/drbd/drbd_9.0.19-1.bb)7
3 files changed, 43 insertions, 8 deletions
diff --git a/meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils/0001-v84-Make-setup_options-definitions-as-extern.patch b/meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils/0001-v84-Make-setup_options-definitions-as-extern.patch
new file mode 100644
index 000000000..6702f3bde
--- /dev/null
+++ b/meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils/0001-v84-Make-setup_options-definitions-as-extern.patch
@@ -0,0 +1,32 @@
+From d095caf6f8f77fe056fb90ccd5d89c207a7f346d Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 12 Aug 2020 12:59:38 -0700
+Subject: [PATCH] v84: Make setup_options definitions as extern
+
+This is already defined in drbdadm_main.c, therefore make this
+declaration to be extern for other modules
+
+Fixes compatibility with gcc-10 which uses -fno-common by default
+
+Upstream-Status: Submitted [https://github.com/LINBIT/drbd-utils/pull/7]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ user/v84/drbdadm.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/user/v84/drbdadm.h b/user/v84/drbdadm.h
+index ed63d78c..8469f1c4 100644
+--- a/user/v84/drbdadm.h
++++ b/user/v84/drbdadm.h
+@@ -251,7 +251,7 @@ struct setup_option {
+ bool explicit;
+ char *option;
+ };
+-struct setup_option *setup_options;
++extern struct setup_option *setup_options;
+
+ extern void add_setup_option(bool explicit, char *option);
+
+--
+2.28.0
+
diff --git a/meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils_9.12.0.bb b/meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils_9.13.1.bb
index b83f68f8c..5b0979f96 100644
--- a/meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils_9.12.0.bb
+++ b/meta-openembedded/meta-networking/recipes-support/drbd/drbd-utils_9.13.1.bb
@@ -8,13 +8,15 @@ SECTION = "admin"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
-SRC_URI = "git://github.com/LINBIT/drbd-utils;name=drbd-utils \
+SRC_URI = "git://github.com/LINBIT/drbd-utils;name=drbd-utils;branch=${PV} \
git://github.com/LINBIT/drbd-headers;name=drbd-headers;destsuffix=git/drbd-headers \
+ file://0001-v84-Make-setup_options-definitions-as-extern.patch \
${@bb.utils.contains('DISTRO_FEATURES','usrmerge','file://0001-drbd-utils-support-usrmerge.patch','',d)} \
"
-# v9.12.0
-SRCREV_drbd-utils = "91629a4cce49ca0d4f917fe0bffa25cfe8db3052"
-SRCREV_drbd-headers = "233006b4d26cf319638be0ef6d16ec7dee287b66"
+SRCREV_drbd-utils = "b24b0f7e42d500d3538d7eeffa017ec78d08f918"
+SRCREV_drbd-headers = "c757cf357edef67751b8f45a6ea894d287180087"
+
+SRCREV_FORMAT = "drbd-utils_drbd-headers"
S = "${WORKDIR}/git"
@@ -56,3 +58,5 @@ FILES_${PN} += "${nonarch_base_libdir}/drbd \
${nonarch_libdir}/drbd \
${nonarch_libdir}/tmpfiles.d"
FILES_${PN}-dbg += "${nonarch_base_libdir}/drbd/.debug"
+
+CLEANBROKEN = "1"
diff --git a/meta-openembedded/meta-networking/recipes-support/drbd/drbd_9.0.19-1.bb b/meta-openembedded/meta-networking/recipes-support/drbd/drbd_9.0.24-1.bb
index 23fe2021b..3ce63c457 100644
--- a/meta-openembedded/meta-networking/recipes-support/drbd/drbd_9.0.19-1.bb
+++ b/meta-openembedded/meta-networking/recipes-support/drbd/drbd_9.0.24-1.bb
@@ -11,15 +11,14 @@ DEPENDS = "virtual/kernel"
SRC_URI = "http://www.linbit.com/downloads/drbd/9.0/drbd-${PV}.tar.gz \
file://check_existence_of_modules_before_installing.patch \
"
-SRC_URI[md5sum] = "bd1202eaaf81641752d0c9b003b10f6c"
-SRC_URI[sha256sum] = "5b3d2bcb99542940e40af903dea783cf04524e9f41cc530e210d2c15ef84fa58"
+SRC_URI[sha256sum] = "14970459f55bc465503b88b24d1a266b2ace0d69fe3cb387005b8477cd6475ed"
inherit module
-EXTRA_OEMAKE += "KDIR='${STAGING_KERNEL_DIR}'"
+EXTRA_OEMAKE += "KDIR='${STAGING_KERNEL_DIR}' SPAAS=true"
do_install () {
oe_runmake install DESTDIR="${D}"
}
-PNBLACKLIST[drbd] = "Kernel module Needs forward porting to kernel 5.2+"
+PNBLACKLIST[drbd] ?= "Needs coccinelle to build with SPAAS"