summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-benchmark')
-rw-r--r--meta-openembedded/meta-oe/recipes-benchmark/iperf3/iperf3/0001-configure.ac-check-for-CPP-prog.patch31
-rw-r--r--meta-openembedded/meta-oe/recipes-benchmark/iperf3/iperf3_3.9.bb1
-rw-r--r--meta-openembedded/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-tests-makefile-Append-CPPFLAGS-rather-then-override.patch31
-rw-r--r--meta-openembedded/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb1
-rw-r--r--meta-openembedded/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-doc-Fix-typos-in-lat_unix_connect-manual-page.patch30
-rw-r--r--meta-openembedded/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb2
6 files changed, 96 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-benchmark/iperf3/iperf3/0001-configure.ac-check-for-CPP-prog.patch b/meta-openembedded/meta-oe/recipes-benchmark/iperf3/iperf3/0001-configure.ac-check-for-CPP-prog.patch
new file mode 100644
index 000000000..739fd20fc
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-benchmark/iperf3/iperf3/0001-configure.ac-check-for-CPP-prog.patch
@@ -0,0 +1,31 @@
+From cc4499cd4cfcb655fc44c3f3571eee20663dafde Mon Sep 17 00:00:00 2001
+From: Andrey Zhizhikin <andrey.z@gmail.com>
+Date: Wed, 3 Feb 2021 20:44:34 +0000
+Subject: [PATCH] configure.ac: check for CPP prog
+
+Absence of check for CPP_PROG causes following build errors:
+| checking TCP_CONGESTION socket option... ../git/configure: line 14427: CPP: command not found
+| ../git/configure: line 14553: ac_fn_c_try_cpp: command not found
+| ../git/configure: line 14553: ac_fn_c_try_cpp: command not found
+
+Upstream-Status: Pending
+Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
+---
+ configure.ac | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/configure.ac b/configure.ac
+index 939cf0a..f75b398 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -47,6 +47,7 @@ AC_CANONICAL_HOST
+ # Checks for tools: c compiler, ranlib (used for creating static libraries),
+ # symlinks and libtool
+ AC_PROG_CC
++AC_PROG_CPP
+ AC_PROG_RANLIB
+ AC_PROG_LN_S
+ AC_PROG_LIBTOOL
+--
+2.17.1
+
diff --git a/meta-openembedded/meta-oe/recipes-benchmark/iperf3/iperf3_3.9.bb b/meta-openembedded/meta-oe/recipes-benchmark/iperf3/iperf3_3.9.bb
index d969555c2..be75837be 100644
--- a/meta-openembedded/meta-oe/recipes-benchmark/iperf3/iperf3_3.9.bb
+++ b/meta-openembedded/meta-oe/recipes-benchmark/iperf3/iperf3_3.9.bb
@@ -13,6 +13,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=b7fb682e9941a49f1214dcd7441410d7"
SRC_URI = "git://github.com/esnet/iperf.git \
file://0002-Remove-pg-from-profile_CFLAGS.patch \
+ file://0001-configure.ac-check-for-CPP-prog.patch \
"
SRCREV = "1f8fb13297f3e3e40169ebcd12e171167e394473"
diff --git a/meta-openembedded/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-tests-makefile-Append-CPPFLAGS-rather-then-override.patch b/meta-openembedded/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-tests-makefile-Append-CPPFLAGS-rather-then-override.patch
new file mode 100644
index 000000000..78a4cb0fc
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-tests-makefile-Append-CPPFLAGS-rather-then-override.patch
@@ -0,0 +1,31 @@
+From b6dba773491bbb7b4664dacdd87a12af860f1bd8 Mon Sep 17 00:00:00 2001
+From: Oleksiy Obitotskyy <oobitots@cisco.com>
+Date: Thu, 28 Jan 2021 05:43:33 -0800
+Subject: [PATCH] tests/makefile: Append CPPFLAGS rather then override
+
+CPPFLAGS overrided and we could miss some options needed.
+
+Upstream-Status: Submitted
+Signed-off-by: Oleksiy Obitotskyy <oobitots@cisco.com>
+---
+ tests/Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tests/Makefile b/tests/Makefile
+index 0ca3716..d262932 100644
+--- a/tests/Makefile
++++ b/tests/Makefile
+@@ -33,8 +33,8 @@ HELPERS = get_hugetlbfs_path compare_kvers
+ HELPER_LIBS = libheapshrink.so
+ BADTOOLCHAIN = bad-toolchain.sh
+
+-CFLAGS = -O2 -Wall -g
+-CPPFLAGS = -I..
++CFLAGS += -O2 -Wall -g
++CPPFLAGS += -I..
+ STATIC_LIBHUGE = -Wl,--whole-archive -lhugetlbfs -Wl,--no-whole-archive
+ STATIC_LDLIBS = -Wl,--no-as-needed -lpthread
+ LDLIBS = $(STATIC_LDLIBS) -ldl -lhugetlbfs_privutils
+--
+2.26.2.Cisco
+
diff --git a/meta-openembedded/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-openembedded/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
index 2f07c938b..fa63316b0 100644
--- a/meta-openembedded/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
+++ b/meta-openembedded/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
@@ -26,6 +26,7 @@ SRC_URI = " \
file://0006-include-limits.h-for-PATH_MAX.patch \
file://0001-huge_page_setup_helper-use-python3-interpreter.patch \
file://0001-Revert-ld.hugetlbfs-fix-Ttext-segment-argument-on-AA.patch \
+ file://0001-tests-makefile-Append-CPPFLAGS-rather-then-override.patch \
"
UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
diff --git a/meta-openembedded/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-doc-Fix-typos-in-lat_unix_connect-manual-page.patch b/meta-openembedded/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-doc-Fix-typos-in-lat_unix_connect-manual-page.patch
new file mode 100644
index 000000000..d49dac5b2
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-doc-Fix-typos-in-lat_unix_connect-manual-page.patch
@@ -0,0 +1,30 @@
+From 9bf2b363c5173c03adecf366f116415dbc559017 Mon Sep 17 00:00:00 2001
+From: Yanfei Xu <yanfei.xu@windriver.com>
+Date: Tue, 23 Feb 2021 10:54:26 +0800
+Subject: [PATCH 1/2] doc: Fix typos in lat_unix_connect manual page
+
+Signed-off-by: Yanfei Xu <yanfei.xu@windriver.com>
+---
+ doc/lat_unix_connect.8 | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/doc/lat_unix_connect.8 b/doc/lat_unix_connect.8
+index b42e9a4..5ab1a51 100644
+--- a/doc/lat_unix_connect.8
++++ b/doc/lat_unix_connect.8
+@@ -25,9 +25,9 @@ is a client/server program that measures interprocess
+ connection latencies. The benchmark times the creation and connection of
+ an AF_UNIX socket to a local server.
+ .LP
+-.B lat_connect
+-has three forms of usage: as a server (-s), as a client (lat_connect),
+-and as a shutdown (lat_connect -S).
++.B lat_unix_connect
++has three forms of usage: as a server (-s), as a client (lat_unix_connect),
++and as a shutdown (lat_unix_connect -S).
+ .SH OUTPUT
+ The reported time is in microseconds per connection.
+ Output format is like so
+--
+2.27.0
+
diff --git a/meta-openembedded/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb b/meta-openembedded/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
index 21e81ecf2..e9d1067d4 100644
--- a/meta-openembedded/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
+++ b/meta-openembedded/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
@@ -29,6 +29,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/lmbench/lmbench-${PV}.tgz \
file://0001-lmbench-Point-webpage-lm-to-target-directory.patch \
file://0001-doc-Fix-typos-in-manual-pages.patch \
file://0001-lat_fifo-Fix-cleanup-sequence.patch \
+ file://0001-doc-Fix-typos-in-lat_unix_connect-manual-page.patch \
"
SRC_URI[md5sum] = "b3351a3294db66a72e2864a199d37cbf"
SRC_URI[sha256sum] = "cbd5777d15f44eab7666dcac418054c3c09df99826961a397d9acf43d8a2a551"
@@ -73,6 +74,7 @@ do_install () {
-C src install
mv ${D}${bindir}/line ${D}${bindir}/lm_line
install -m 0755 ${WORKDIR}/lmbench-run ${D}${bindir}/
+ install -m 0755 ${S}/bin/${TARGET_SYS}/cache ${D}${bindir}/
sed -i -e 's,^SHAREDIR=.*$,SHAREDIR=${datadir}/${BPN},;' \
-e 's,^CONFIG=.*$,CONFIG=`$SCRIPTSDIR/config`,;' \
${D}${bindir}/lmbench-run