summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-connectivity/iwd
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-connectivity/iwd')
-rw-r--r--meta-openembedded/meta-oe/recipes-connectivity/iwd/iwd/0001-build-Use-abs_top_srcdir-instead-of-abs_srcdir-for-e.patch37
-rw-r--r--meta-openembedded/meta-oe/recipes-connectivity/iwd/iwd_1.14.bb (renamed from meta-openembedded/meta-oe/recipes-connectivity/iwd/iwd_1.12.bb)6
2 files changed, 40 insertions, 3 deletions
diff --git a/meta-openembedded/meta-oe/recipes-connectivity/iwd/iwd/0001-build-Use-abs_top_srcdir-instead-of-abs_srcdir-for-e.patch b/meta-openembedded/meta-oe/recipes-connectivity/iwd/iwd/0001-build-Use-abs_top_srcdir-instead-of-abs_srcdir-for-e.patch
new file mode 100644
index 000000000..9ed73104e
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-connectivity/iwd/iwd/0001-build-Use-abs_top_srcdir-instead-of-abs_srcdir-for-e.patch
@@ -0,0 +1,37 @@
+From b0b51d762f45ff9d320b96bd0acb89313148a446 Mon Sep 17 00:00:00 2001
+From: Zang Ruochen <zangrc.fnst@fujitsu.com>
+Date: Wed, 12 May 2021 14:28:24 +0900
+Subject: [PATCH] build: Use abs_top_srcdir instead of abs_srcdir for ell sources
+
+this makes it build when build dir is outside of sources dir
+
+Upstream-Status: Submitted [https://lists.01.org/hyperkitty/list/iwd@lists.01.org/message/SYX6Z7SUQHU7UWM6ECZTTJ6SPODIS6KB/]
+---
+ Makefile.am | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 68035e4..e3f7990 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -628,7 +628,7 @@ ell/shared: Makefile
+ $(AM_V_at)$(MKDIR_P) ell
+ $(AM_V_GEN)for f in $(ell_shared) ; do \
+ if [ ! -f $$f ] ; then \
+- $(LN_S) -t ell -f $(abs_srcdir)/../ell/$$f ; \
++ $(LN_S) -t ell -f $(abs_top_srcdir)/ell/$$f ; \
+ fi \
+ done > $@
+
+@@ -636,7 +636,7 @@ ell/internal: Makefile
+ $(AM_V_at)$(MKDIR_P) ell
+ $(AM_V_GEN)for f in $(ell_headers) $(ell_sources) ; do \
+ if [ ! -f $$f ] ; then \
+- $(LN_S) -t ell -f $(abs_srcdir)/../ell/$$f ; \
++ $(LN_S) -t ell -f $(abs_top_srcdir)/ell/$$f ; \
+ fi \
+ done > $@
+
+--
+2.25.1
+
diff --git a/meta-openembedded/meta-oe/recipes-connectivity/iwd/iwd_1.12.bb b/meta-openembedded/meta-oe/recipes-connectivity/iwd/iwd_1.14.bb
index ccdc65ac6..dbcc319dc 100644
--- a/meta-openembedded/meta-oe/recipes-connectivity/iwd/iwd_1.12.bb
+++ b/meta-openembedded/meta-oe/recipes-connectivity/iwd/iwd_1.14.bb
@@ -5,10 +5,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
DEPENDS = "ell"
-SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git \
+SRC_URI = "https://www.kernel.org/pub/linux/network/wireless/${BP}.tar.xz \
+ file://0001-build-Use-abs_top_srcdir-instead-of-abs_srcdir-for-e.patch \
"
-SRCREV = "bde3e0f6e3364e9c884b6b93a944d8138345b8e5"
-S = "${WORKDIR}/git"
+SRC_URI[sha256sum] = "21be6ad59ba666ba1e50e01889d647472b9b2f96f4941123db036fd33c257f0b"
inherit autotools manpages pkgconfig python3native systemd