summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-connectivity')
-rw-r--r--meta-openembedded/meta-oe/recipes-connectivity/ace/ace_6.5.8.bb40
-rw-r--r--meta-openembedded/meta-oe/recipes-connectivity/ace/files/ace_config.patch12
-rw-r--r--meta-openembedded/meta-oe/recipes-connectivity/thrift/thrift_0.13.0.bb6
-rw-r--r--meta-openembedded/meta-oe/recipes-connectivity/transmission/transmission_git.bb2
4 files changed, 54 insertions, 6 deletions
diff --git a/meta-openembedded/meta-oe/recipes-connectivity/ace/ace_6.5.8.bb b/meta-openembedded/meta-oe/recipes-connectivity/ace/ace_6.5.8.bb
new file mode 100644
index 000000000..24315320e
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-connectivity/ace/ace_6.5.8.bb
@@ -0,0 +1,40 @@
+SUMMARY = "C++ framework for implementing distributed and networked applications"
+DESCRIPTION = "C++ network programming framework that implements many core \
+patterns for concurrent communication software"
+LICENSE = "ACE-TAO-CIAO"
+HOMEPAGE = "http://www.dre.vanderbilt.edu/~schmidt/ACE.html"
+LIC_FILES_CHKSUM = "file://COPYING;md5=96ef88a5529594698e8ceabdd47df92c"
+
+DEPENDS += "openssl gperf-native"
+
+SRC_URI = "https://github.com/DOCGroup/ACE_TAO/releases/download/ACE%2BTAO-6_5_8/ACE-${PV}.tar.bz2 \
+ file://ace_config.patch \
+ "
+
+SRC_URI[md5sum] = "a6ba6a944612fe0696c90cbb5c3078ee"
+SRC_URI[sha256sum] = "cda2a960dbb9970a907663627711b2e2b14b3484a2859ae936370bcad0b16923"
+
+COMPATIBLE_HOST_libc-musl = "null"
+
+S = "${WORKDIR}/ACE_wrappers"
+B = "${WORKDIR}/ACE_wrappers/ace"
+export ACE_ROOT="${WORKDIR}/ACE_wrappers"
+
+inherit pkgconfig
+
+CXXFLAGS_append = " -fpermissive -Wnodeprecated-declarations"
+
+do_install() {
+ export D="${D}"
+ oe_runmake install
+
+ for i in $(find ${D} -name "*.pc") ; do
+ sed -i -e s:${D}::g \
+ -e s:/${TARGET_SYS}::g \
+ $i
+ done
+
+ rm -r ${D}/usr/share
+}
+
+UPSTREAM_CHECK_URI = "https://github.com/DOCGroup/ACE_TAO/releases"
diff --git a/meta-openembedded/meta-oe/recipes-connectivity/ace/files/ace_config.patch b/meta-openembedded/meta-oe/recipes-connectivity/ace/files/ace_config.patch
new file mode 100644
index 000000000..207b85ab9
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-connectivity/ace/files/ace_config.patch
@@ -0,0 +1,12 @@
+diff -ruN ACE_wrappers1/ace/config.h ACE_wrappers/ace/config.h
+--- ACE_wrappers1/ace/config.h 1970-01-01 02:00:00.000000000 +0200
++++ ACE_wrappers/ace/config.h 2019-01-10 13:36:52.698012477 +0200
+@@ -0,0 +1,1 @@
++#include "ace/config-linux.h"
+diff -ruN ACE_wrappers1/include/makeinclude/platform_macros.GNU ACE_wrappers/include/makeinclude/platform_macros.GNU
+--- ACE_wrappers1/include/makeinclude/platform_macros.GNU 1970-01-01 02:00:00.000000000 +0200
++++ ACE_wrappers/include/makeinclude/platform_macros.GNU 2018-10-31 15:11:18.265392460 +0200
+@@ -0,0 +1,3 @@
++INSTALL_PREFIX = $(D)$(exec_prefix)
++INSTALL_LIB = $(base_libdir)
++include $(ACE_ROOT)/include/makeinclude/platform_linux.GNU
diff --git a/meta-openembedded/meta-oe/recipes-connectivity/thrift/thrift_0.13.0.bb b/meta-openembedded/meta-oe/recipes-connectivity/thrift/thrift_0.13.0.bb
index 92bcb21bf..e3880b357 100644
--- a/meta-openembedded/meta-oe/recipes-connectivity/thrift/thrift_0.13.0.bb
+++ b/meta-openembedded/meta-oe/recipes-connectivity/thrift/thrift_0.13.0.bb
@@ -24,7 +24,6 @@ export BUILD_SYS
export HOST_SYS
EXTRA_OECMAKE = " \
- -DENABLE_PRECOMPILED_HEADERS=OFF \
-DBUILD_LIBRARIES=ON \
-DBUILD_COMPILER=ON \
-DBUILD_TESTING=OFF \
@@ -36,15 +35,12 @@ EXTRA_OECMAKE = " \
-DWITH_STATIC_LIB=ON \
-DWITH_SHARED_LIB=ON \
-DWITH_OPENSSL=ON \
- -DWITH_QT4=OFF \
-DWITH_QT5=OFF \
- -DWITH_BOOST_FUNCTIONAL=OFF \
"
-PACKAGECONFIG ??= "libevent glib boost-smart-ptr"
+PACKAGECONFIG ??= "libevent glib"
PACKAGECONFIG[libevent] = "-DWITH_LIBEVENT=ON,-DWITH_LIBEVENT=OFF,libevent"
PACKAGECONFIG[glib] = "-DWITH_C_GLIB=ON,-DWITH_C_GLIB=OFF,glib-2.0"
-PACKAGECONFIG[boost-smart-ptr] = "-DWITH_BOOST_SMART_PTR=ON,-DWITH_BOOST_SMART_PTR=OFF,boost"
do_install_append () {
ln -sf thrift ${D}/${bindir}/thrift-compiler
diff --git a/meta-openembedded/meta-oe/recipes-connectivity/transmission/transmission_git.bb b/meta-openembedded/meta-oe/recipes-connectivity/transmission/transmission_git.bb
index ee5578f8b..412bd9d3f 100644
--- a/meta-openembedded/meta-oe/recipes-connectivity/transmission/transmission_git.bb
+++ b/meta-openembedded/meta-oe/recipes-connectivity/transmission/transmission_git.bb
@@ -19,7 +19,7 @@ PV = "2.94"
S = "${WORKDIR}/git"
-inherit autotools gettext update-rc.d systemd mime-xdg features_check
+inherit autotools gettext update-rc.d systemd mime-xdg
PACKAGECONFIG = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"