summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-crypto
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-crypto')
-rw-r--r--meta-openembedded/meta-oe/recipes-crypto/cryptsetup/cryptsetup_2.3.4.bb (renamed from meta-openembedded/meta-oe/recipes-crypto/cryptsetup/cryptsetup_2.3.2.bb)4
-rw-r--r--meta-openembedded/meta-oe/recipes-crypto/fsverity-utils/fsverity-utils_1.2.bb28
-rw-r--r--meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-Use-__builtin_bswap32-on-Clang-if-supported.patch39
-rw-r--r--meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-kcapi-kdf-Move-code-to-fix.patch73
-rw-r--r--meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi_1.2.0.bb (renamed from meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb)11
-rw-r--r--meta-openembedded/meta-oe/recipes-crypto/libmcrypt/libmcrypt_2.5.8.bb2
6 files changed, 35 insertions, 122 deletions
diff --git a/meta-openembedded/meta-oe/recipes-crypto/cryptsetup/cryptsetup_2.3.2.bb b/meta-openembedded/meta-oe/recipes-crypto/cryptsetup/cryptsetup_2.3.4.bb
index b9668eb09..b9a6b7179 100644
--- a/meta-openembedded/meta-oe/recipes-crypto/cryptsetup/cryptsetup_2.3.2.bb
+++ b/meta-openembedded/meta-oe/recipes-crypto/cryptsetup/cryptsetup_2.3.4.bb
@@ -21,8 +21,8 @@ RDEPENDS_${PN} = " \
"
SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/v${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}/${BP}.tar.xz"
-SRC_URI[md5sum] = "6e4ffb6d35a73f7539a5d0c1354654cd"
-SRC_URI[sha256sum] = "a89e13dff0798fd0280e801d5f0cc8cfdb2aa5b1929bec1b7322e13d3eca95fb"
+SRC_URI[md5sum] = "911272e73181fdc850bb4d25103a9f83"
+SRC_URI[sha256sum] = "9d16eebb96b53b514778e813019b8dd15fea9fec5aafde9fae5febf59df83773"
inherit autotools gettext pkgconfig
diff --git a/meta-openembedded/meta-oe/recipes-crypto/fsverity-utils/fsverity-utils_1.2.bb b/meta-openembedded/meta-oe/recipes-crypto/fsverity-utils/fsverity-utils_1.2.bb
new file mode 100644
index 000000000..4d5dbafb3
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-crypto/fsverity-utils/fsverity-utils_1.2.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Userspace utilities for fs-verity"
+DESCRIPTION = "fs-verity is a Linux kernel feature that does transparent \
+on-demand integrity/authenticity verification of the contents of read-only \
+files, using a hidden Merkle tree (hash tree) associated with the file. The \
+mechanism is similar to dm-verity, but implemented at the file level rather \
+than at the block device level."
+HOMEPAGE = "https://www.kernel.org/doc/html/latest/filesystems/fsverity.html"
+SECTION = "console"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=bc974d217b525ea216a336adb73e1220"
+
+SRCREV = "406187bb3a885e083b448b2c2aa42c22957ae629"
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/ebiggers/fsverity-utils.git"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "openssl"
+
+EXTRA_OEMAKE += "PREFIX=${prefix} USE_SHARED_LIB=1"
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+PACKAGES =+ "libfsverity"
+FILES_libfsverity = "${libdir}/libfsverity*${SOLIBS}"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-Use-__builtin_bswap32-on-Clang-if-supported.patch b/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-Use-__builtin_bswap32-on-Clang-if-supported.patch
deleted file mode 100644
index e713665ab..000000000
--- a/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-Use-__builtin_bswap32-on-Clang-if-supported.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 7b5dd67fee58f9f54c8a676abe2131776c0a3c52 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Wed, 20 Nov 2019 13:41:39 -0800
-Subject: [PATCH] Use __builtin_bswap32 on Clang if supported
-
-clang pretends to be gcc 4.2.1 so GCC_VERSION macro will decide that
-__builtin_bswap32 is not supported on clang, whereas in reality it might
-so its better to add a check for enquiring clang if it supports
-__builtin_bswap32 or not
-
-Upstream-Status: Submitted [https://github.com/smuellerDD/libkcapi/pull/83]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- lib/kcapi-kdf.c | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/lib/kcapi-kdf.c b/lib/kcapi-kdf.c
-index 9e53a0b..f32fbe9 100644
---- a/lib/kcapi-kdf.c
-+++ b/lib/kcapi-kdf.c
-@@ -54,10 +54,14 @@
- #include "kcapi.h"
- #include "internal.h"
-
-+#ifndef __has_builtin
-+# define __has_builtin(x) 0
-+#endif
-+
- #define GCC_VERSION (__GNUC__ * 10000 \
- + __GNUC_MINOR__ * 100 \
- + __GNUC_PATCHLEVEL__)
--#if GCC_VERSION >= 40400
-+#if GCC_VERSION >= 40400 || (defined(__clang__) && __has_builtin(__builtin_bswap32))
- # define __HAVE_BUILTIN_BSWAP32__
- #endif
-
---
-2.24.0
-
diff --git a/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-kcapi-kdf-Move-code-to-fix.patch b/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-kcapi-kdf-Move-code-to-fix.patch
deleted file mode 100644
index 7ed9caf09..000000000
--- a/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-kcapi-kdf-Move-code-to-fix.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-From 8f961521add49278b48c9721fc53e05ee3543b74 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sat, 16 Nov 2019 23:03:51 -0800
-Subject: [PATCH] kcapi-kdf: Move code to fix
-
-Fixes clang build
-unused function '_bswap32' [-Werror,-Wunused-function]
-
-Upstream-Status: Submitted [https://github.com/smuellerDD/libkcapi/pull/83]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- lib/kcapi-kdf.c | 37 +++++++++++++++++--------------------
- 1 file changed, 17 insertions(+), 20 deletions(-)
-
-diff --git a/lib/kcapi-kdf.c b/lib/kcapi-kdf.c
-index ea39846..9e53a0b 100644
---- a/lib/kcapi-kdf.c
-+++ b/lib/kcapi-kdf.c
-@@ -54,6 +54,20 @@
- #include "kcapi.h"
- #include "internal.h"
-
-+#define GCC_VERSION (__GNUC__ * 10000 \
-+ + __GNUC_MINOR__ * 100 \
-+ + __GNUC_PATCHLEVEL__)
-+#if GCC_VERSION >= 40400
-+# define __HAVE_BUILTIN_BSWAP32__
-+#endif
-+
-+/* Endian dependent byte swap operations. */
-+#if __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
-+# define be_bswap32(x) ((uint32_t)(x))
-+#elif __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
-+# ifdef __HAVE_BUILTIN_BSWAP32__
-+# define be_bswap32(x) (uint32_t)__builtin_bswap32((uint32_t)(x))
-+# else
- static inline uint32_t rol32(uint32_t x, int n)
- {
- return ( (x << (n&(32-1))) | (x >> ((32-n)&(32-1))) );
-@@ -68,27 +82,10 @@ static inline uint32_t _bswap32(uint32_t x)
- {
- return ((rol32(x, 8) & 0x00ff00ffL) | (ror32(x, 8) & 0xff00ff00L));
- }
--
--#define GCC_VERSION (__GNUC__ * 10000 \
-- + __GNUC_MINOR__ * 100 \
-- + __GNUC_PATCHLEVEL__)
--#if GCC_VERSION >= 40400
--# define __HAVE_BUILTIN_BSWAP32__
--#endif
--
--#ifdef __HAVE_BUILTIN_BSWAP32__
--# define _swap32(x) (uint32_t)__builtin_bswap32((uint32_t)(x))
--#else
--# define _swap32(x) _bswap32(x)
--#endif
--
--/* Endian dependent byte swap operations. */
--#if __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
--# define be_bswap32(x) ((uint32_t)(x))
--#elif __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
--# define be_bswap32(x) _swap32(x)
-+# define be_bswap32(x) _bswap32(x)
-+# endif
- #else
--#error "Endianess not defined"
-+# error "endianess not defined"
- #endif
-
- DSO_PUBLIC
---
-2.24.0
-
diff --git a/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb b/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi_1.2.0.bb
index 4e217a351..b478e4c58 100644
--- a/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb
+++ b/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi_1.2.0.bb
@@ -1,18 +1,13 @@
SUMMARY = "Linux Kernel Crypto API User Space Interface Library"
HOMEPAGE = "http://www.chronox.de/libkcapi.html"
LICENSE = "BSD | GPL-2.0"
-LIC_FILES_CHKSUM = "file://COPYING;md5=14d5a68b28755c04ebdba226e888b157"
+LIC_FILES_CHKSUM = "file://COPYING;md5=c78be93ed8d1637f2a3f4a83ff9d5f54"
DEPENDS = "libtool"
S = "${WORKDIR}/git"
-SRCREV = "5649050d201856bf06c8738b5d2aa1710c86ac2f"
-PV = "1.1.5"
-SRC_URI = " \
- git://github.com/smuellerDD/libkcapi.git \
- file://0001-kcapi-kdf-Move-code-to-fix.patch \
- file://0001-Use-__builtin_bswap32-on-Clang-if-supported.patch \
-"
+SRCREV = "8397f0f7c45264a3b9aff5a1f9119df25eeb4c60"
+SRC_URI = "git://github.com/smuellerDD/libkcapi.git"
inherit autotools
diff --git a/meta-openembedded/meta-oe/recipes-crypto/libmcrypt/libmcrypt_2.5.8.bb b/meta-openembedded/meta-oe/recipes-crypto/libmcrypt/libmcrypt_2.5.8.bb
index be413a1c7..46e694be4 100644
--- a/meta-openembedded/meta-oe/recipes-crypto/libmcrypt/libmcrypt_2.5.8.bb
+++ b/meta-openembedded/meta-oe/recipes-crypto/libmcrypt/libmcrypt_2.5.8.bb
@@ -13,3 +13,5 @@ UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/mcrypt/files/Libmcrypt/"
UPSTREAM_CHECK_REGEX = "Libmcrypt/(?P<pver>\d+(\.\d+)+)/"
inherit autotools-brokensep gettext binconfig
+
+CLEANBROKEN = "1"