summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-crypto
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-crypto')
-rw-r--r--meta-openembedded/meta-oe/recipes-crypto/botan/botan_2.14.0.bb2
-rw-r--r--meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-Disable-use-of-__NR_io_getevents-when-not-defined.patch36
-rw-r--r--meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi_1.2.1.bb (renamed from meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi_1.2.0.bb)6
-rw-r--r--meta-openembedded/meta-oe/recipes-crypto/pkcs11-helper/pkcs11-helper_1.27.bb (renamed from meta-openembedded/meta-oe/recipes-crypto/pkcs11-helper/pkcs11-helper_1.26.bb)4
4 files changed, 44 insertions, 4 deletions
diff --git a/meta-openembedded/meta-oe/recipes-crypto/botan/botan_2.14.0.bb b/meta-openembedded/meta-oe/recipes-crypto/botan/botan_2.14.0.bb
index 42e89f639..13b2c6649 100644
--- a/meta-openembedded/meta-oe/recipes-crypto/botan/botan_2.14.0.bb
+++ b/meta-openembedded/meta-oe/recipes-crypto/botan/botan_2.14.0.bb
@@ -49,3 +49,5 @@ PACKAGES += "${PN}-python3"
FILES_${PN}-python3 = "${libdir}/python3"
RDEPENDS_${PN}-python3 += "python3"
+
+COMPATIBLE_HOST_riscv32 = "null"
diff --git a/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-Disable-use-of-__NR_io_getevents-when-not-defined.patch b/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-Disable-use-of-__NR_io_getevents-when-not-defined.patch
new file mode 100644
index 000000000..9d9f63e34
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-Disable-use-of-__NR_io_getevents-when-not-defined.patch
@@ -0,0 +1,36 @@
+From 771dd6aa45dd0bbbb7d7c7a7b116e1b5666fbd7a Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 15 Nov 2020 18:05:48 -0800
+Subject: [PATCH] Disable use of __NR_io_getevents when not defined
+
+Architectures like riscv32 do not define this syscall, therefore return
+ENOSYS on such architectures
+
+Upstream-Status: Submitted [https://github.com/smuellerDD/libkcapi/pull/100]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ lib/internal.h | 12 ++++++++++++
+ 1 file changed, 12 insertions(+)
+
+--- a/lib/internal.h
++++ b/lib/internal.h
+@@ -325,10 +325,17 @@ static inline int io_submit(aio_context_
+ return syscall(__NR_io_submit, ctx, n, iocb);
+ }
+
+-static inline int io_getevents(aio_context_t ctx, long min, long max,
+- struct io_event *events, struct timespec *timeout)
++static inline int io_getevents(__attribute__((unused)) aio_context_t ctx,
++ __attribute__((unused)) long min,
++ __attribute__((unused)) long max,
++ __attribute__((unused)) struct io_event *events,
++ __attribute__((unused)) struct timespec *timeout)
+ {
++#ifdef __NR_io_getevents
+ return syscall(__NR_io_getevents, ctx, min, max, events, timeout);
++#else
++ return -ENOSYS;
++#endif
+ }
+
+ /************************************************************
diff --git a/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi_1.2.0.bb b/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi_1.2.1.bb
index b478e4c58..e76fba09c 100644
--- a/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi_1.2.0.bb
+++ b/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi_1.2.1.bb
@@ -6,8 +6,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=c78be93ed8d1637f2a3f4a83ff9d5f54"
DEPENDS = "libtool"
S = "${WORKDIR}/git"
-SRCREV = "8397f0f7c45264a3b9aff5a1f9119df25eeb4c60"
-SRC_URI = "git://github.com/smuellerDD/libkcapi.git"
+SRCREV = "d41284525ec8960e9a828979cfe269012b7df8db"
+SRC_URI = "git://github.com/smuellerDD/libkcapi.git \
+ file://0001-Disable-use-of-__NR_io_getevents-when-not-defined.patch \
+ "
inherit autotools
diff --git a/meta-openembedded/meta-oe/recipes-crypto/pkcs11-helper/pkcs11-helper_1.26.bb b/meta-openembedded/meta-oe/recipes-crypto/pkcs11-helper/pkcs11-helper_1.27.bb
index 9b6e7ccbe..a7365f193 100644
--- a/meta-openembedded/meta-oe/recipes-crypto/pkcs11-helper/pkcs11-helper_1.26.bb
+++ b/meta-openembedded/meta-oe/recipes-crypto/pkcs11-helper/pkcs11-helper_1.27.bb
@@ -18,8 +18,8 @@ LIC_FILES_CHKSUM = " \
SRC_URI = "git://github.com/OpenSC/${BPN}.git"
S = "${WORKDIR}/git"
-# v1.26
-SRCREV = "c7a0cfa08ddc75d963a835d3588170af0e5f1115"
+# v1.27
+SRCREV = "564a582d600c7eec7b8e303a22b575fd52622174"
UPSTREAM_CHECK_GITTAGREGEX = "pkcs11-helper-(?P<pver>\d+(\.\d+)+)"