summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-devtools/sip
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-devtools/sip')
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/sip/sip3_4.19.19.bb11
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/sip/sip3_4.19.23.bb (renamed from meta-openembedded/meta-oe/recipes-devtools/sip/sip.inc)17
2 files changed, 14 insertions, 14 deletions
diff --git a/meta-openembedded/meta-oe/recipes-devtools/sip/sip3_4.19.19.bb b/meta-openembedded/meta-oe/recipes-devtools/sip/sip3_4.19.19.bb
deleted file mode 100644
index 010fa30fe..000000000
--- a/meta-openembedded/meta-oe/recipes-devtools/sip/sip3_4.19.19.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-require sip.inc
-
-DEPENDS = "python3"
-
-inherit python3-dir python3native
-
-PACKAGES += "python3-sip3"
-
-FILES_python3-sip3 = "${libdir}/${PYTHON_DIR}/site-packages/"
-FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug"
-
diff --git a/meta-openembedded/meta-oe/recipes-devtools/sip/sip.inc b/meta-openembedded/meta-oe/recipes-devtools/sip/sip3_4.19.23.bb
index d8e32a768..320755b84 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/sip/sip.inc
+++ b/meta-openembedded/meta-oe/recipes-devtools/sip/sip3_4.19.23.bb
@@ -1,16 +1,22 @@
SUMMARY = "SIP is a C++/Python Wrapper Generator"
-HOMEPAGE = "http://www.riverbankcomputing.co.uk/sip"
+HOMEPAGE = "https://riverbankcomputing.com/software/sip/"
SECTION = "devel"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://LICENSE-GPL2;md5=e91355d8a6f8bd8f7c699d62863c7303"
SRC_URI = "https://www.riverbankcomputing.com/static/Downloads/sip/${PV}/sip-${PV}.tar.gz \
"
-SRC_URI[md5sum] = "98111479309dc472410f26080d6d4a88"
-SRC_URI[sha256sum] = "5436b61a78f48c7e8078e93a6b59453ad33780f80c644e5f3af39f94be1ede44"
+SRC_URI[md5sum] = "70adc0c9734e2d9dcd241d3f931dfc74"
+SRC_URI[sha256sum] = "22ca9bcec5388114e40d4aafd7ccd0c4fe072297b628d0c5cdfa2f010c0bc7e7"
+
+inherit python3-dir python3native
S = "${WORKDIR}/sip-${PV}"
+DEPENDS = "python3"
+
+PACKAGES += "python3-sip3"
+
BBCLASSEXTEND = "native"
do_configure_prepend_class-target() {
@@ -22,6 +28,7 @@ do_configure_prepend_class-target() {
echo "sip_sip_dir = ${D}/${datadir}/sip" >> sip.cfg
${PYTHON} configure.py --configuration sip.cfg --sip-module PyQt5.sip --sysroot ${STAGING_DIR_HOST} CC="${CC}" CXX="${CXX}" LINK="${CXX}" STRIP="" LINK_SHLIB="${CXX}" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LFLAGS="${LDFLAGS}"
}
+
do_configure_prepend_class-native() {
echo "py_platform = linux" > sip.cfg
echo "py_inc_dir = ${includedir}/python%(py_major).%(py_minor)${PYTHON_ABI}" >> sip.cfg
@@ -31,6 +38,10 @@ do_configure_prepend_class-native() {
echo "sip_sip_dir = ${D}/${datadir}/sip" >> sip.cfg
${PYTHON} configure.py --configuration sip.cfg --sip-module PyQt5.sip --sysroot=${STAGING_DIR_NATIVE}
}
+
do_install() {
oe_runmake install
}
+
+FILES_python3-sip3 = "${libdir}/${PYTHON_DIR}/site-packages/"
+FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug"