summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-devtools')
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/apitrace/apitrace_9.0.bb30
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/php/php/php-fpm.service2
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf_3.13.0.1.bb (renamed from meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf_3.13.0.bb)2
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/squashfs-tools-ng/squashfs-tools-ng_1.0.2.bb32
4 files changed, 64 insertions, 2 deletions
diff --git a/meta-openembedded/meta-oe/recipes-devtools/apitrace/apitrace_9.0.bb b/meta-openembedded/meta-oe/recipes-devtools/apitrace/apitrace_9.0.bb
new file mode 100644
index 000000000..826291a5e
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-devtools/apitrace/apitrace_9.0.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Tools for tracing OpenGL, Direct3D, and other graphics APIs"
+HOMEPAGE = "http://apitrace.github.io/"
+SECTION = "console/tools"
+LICENSE = "MIT & BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=aeb969185a143c3c25130bc2c3ef9a50 \
+ file://thirdparty/snappy/COPYING;md5=f62f3080324a97b3159a7a7e61812d0c"
+
+SRCREV = "cae55f54c53449fd07f8a917dcd0874db2c15032"
+SRC_URI = "git://github.com/${BPN}/${BPN}.git"
+
+S = "${WORKDIR}/git"
+
+DEPENDS += "zlib libpng python3-native"
+
+inherit cmake
+
+EXTRA_OECMAKE += "\
+ -DENABLE_GUI=OFF \
+ -DENABLE_X11=OFF \
+ -DENABLE_STATIC_LIBGCC=OFF \
+ -DENABLE_STATIC_LIBSTDCXX=OFF \
+ -DPython3_ROOT_DIR=/usr/bin/python3-native \
+"
+
+# Use the bundled snappy library
+EXTRA_OECMAKE += "\
+ -DENABLE_STATIC_SNAPPY=ON \
+"
+
+SECURITY_CFLAGS_toolchain-clang = ""
diff --git a/meta-openembedded/meta-oe/recipes-devtools/php/php/php-fpm.service b/meta-openembedded/meta-oe/recipes-devtools/php/php/php-fpm.service
index ac79dc931..eec76fb56 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/php/php/php-fpm.service
+++ b/meta-openembedded/meta-oe/recipes-devtools/php/php/php-fpm.service
@@ -3,7 +3,7 @@ Description=PHP-FPM
After=network.target
[Service]
Type=forking
-PIDFile=@LOCALSTATEDIR@/run/php-fpm.pid
+PIDFile=/run/php-fpm.pid
ExecStart=@SYSCONFDIR@/init.d/php-fpm start
ExecStop=@SYSCONFDIR@/init.d/php-fpm stop
[Install]
diff --git a/meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf_3.13.0.bb b/meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf_3.13.0.1.bb
index f2c5e2bee..8c349db4d 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf_3.13.0.bb
+++ b/meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf_3.13.0.1.bb
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=37b5762e07f0af8c74ce80a8bda4266b"
DEPENDS = "zlib"
DEPENDS_append_class-target = " protobuf-native"
-SRCREV = "fde7cf7358ec7cd69e8db9be4f1fa6a5c431386a"
+SRCREV = "d1eca4e4b421cd2997495c4b4e65cea6be4e9b8a"
SRC_URI = "git://github.com/protocolbuffers/protobuf.git \
file://run-ptest \
diff --git a/meta-openembedded/meta-oe/recipes-devtools/squashfs-tools-ng/squashfs-tools-ng_1.0.2.bb b/meta-openembedded/meta-oe/recipes-devtools/squashfs-tools-ng/squashfs-tools-ng_1.0.2.bb
new file mode 100644
index 000000000..6e2606be6
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-devtools/squashfs-tools-ng/squashfs-tools-ng_1.0.2.bb
@@ -0,0 +1,32 @@
+SUMMARY = "New set of tools for working with SquashFS images"
+SECTION = "base"
+LICENSE = "GPL-3.0+ & LGPL-3.0+ & MIT & BSD-2-Clause & Zlib"
+LIC_FILES_CHKSUM = "file://COPYING.md;md5=c0de2c0aca56349dab98e97992316f7e \
+ file://licenses/GPLv3.txt;md5=1ebbd3e34237af26da5dc08a4e440464 \
+ file://licenses/hash_table.txt;md5=874823605326caeaabaa95bfbd0f9fb0 \
+ file://licenses/LGPLv3.txt;md5=3000208d539ec061b899bce1d9ce9404 \
+ file://licenses/LZ4.txt;md5=ebc2ea4814a64de7708f1571904b32cc \
+ file://licenses/xxhash.txt;md5=f042a9be092bd6d7fe6f217d8d00f4ca \
+ file://licenses/xz.txt;md5=1c389b9610ccfdb25f7abaea6a0bb5a4 \
+ file://licenses/zlib.txt;md5=ae27c72096606131f760e5f59cf98b06 \
+ file://licenses/zstd.txt;md5=8df8137b630239cbdd4c0674124cb0c8"
+
+SRCREV = "b96f0fc154feef531be76034bf6e38925636146f"
+SRC_URI = "git://github.com/AgentD/squashfs-tools-ng.git;protocol=https"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+PACKAGECONFIG ??= "gzip xz lzo lz4 zstd ${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)}"
+PACKAGECONFIG[gzip] = "--with-gzip,--without-gzip,zlib"
+PACKAGECONFIG[xz] = "--with-xz,--without-xz,xz"
+PACKAGECONFIG[lzo] = "--with-lzo,--without-lzo,lzo"
+PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4"
+PACKAGECONFIG[zstd] = "--with-zstd,--without-zstd,zstd"
+PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux"
+
+PACKAGES =+ "libsquashfs"
+FILES_libsquashfs = "${libdir}/libsquashfs*${SOLIBS}"
+
+BBCLASSEXTEND = "native nativesdk"