summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb17
1 files changed, 12 insertions, 5 deletions
diff --git a/meta-openembedded/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb b/meta-openembedded/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb
index 9113fa67a..b3ea44c3c 100644
--- a/meta-openembedded/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb
+++ b/meta-openembedded/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb
@@ -7,7 +7,7 @@ SECTION = "console/network"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=f9534eb5f4ab800b573a37bffc62f3a7"
-DEPENDS = "virtual/crypt expat flex python3 bison-native libxml2"
+DEPENDS = "virtual/crypt expat flex python3 bison-native libxml2 nettle lz4"
RDEPENDS_${PN} = "python3-core"
SRCREV = "aa42957a2e227df41510047cece3cd606dc1cb6a"
@@ -27,6 +27,7 @@ SRC_URI = "git://github.com/apache/nifi-minifi-cpp.git \
file://0001-CMakeLists.txt-use-curl-local-source-tarball.patch \
file://0002-cmake-LibreSSL.cmake-use-libressl-local-source-tarba.patch \
file://0003-cmake-BundledOSSPUUID.cmake-use-ossp-uuid-local-sour.patch \
+ file://0001-civetweb-CMakeLists.txt-do-not-search-gcc-ar-and-gcc.patch \
file://minifi.service \
file://systemd-volatile.conf \
file://sysvinit-volatile.conf \
@@ -52,20 +53,26 @@ OECMAKE_FIND_ROOT_PATH_MODE_PROGRAM = "BOTH"
EXTRA_OECMAKE += " \
-DHOST_SYS=${HOST_SYS} -DBUILD_SYS=${BUILD_SYS} \
-DSKIP_TESTS=ON \
+ -DGCC_AR=${STAGING_BINDIR_TOOLCHAIN}/${AR} \
+ -DGCC_RANLIB=${STAGING_BINDIR_TOOLCHAIN}/${RANLIB} \
"
EXTRA_OECMAKE_append_toolchain-clang = " -DCMAKE_RANLIB=${STAGING_BINDIR_TOOLCHAIN}/${TARGET_PREFIX}llvm-ranlib"
LDFLAGS_append_toolchain-clang = " -fuse-ld=lld"
+
+# RV lld errors out:
+# riscv64-yoe-linux-ld.lld: error: init.c:(.text+0x0): relocation R_RISCV_ALIGN requires unimplemented linker relaxation; recompile with -mno-relax
LDFLAGS_remove_riscv32 = "-fuse-ld=lld"
+LDFLAGS_remove_riscv64 = "-fuse-ld=lld"
# There are endian issues when communicating with the x86 nifi on the the mips and the ppc machines.
COMPATIBLE_MACHINE_mips = "(!.*mips).*"
COMPATIBLE_MACHINE_mips64 = "(!.*mips64).*"
COMPATIBLE_MACHINE_powerpc = "(!.*ppc).*"
-TARGET_CFLAGS_append_riscv32 += "-fpic"
-TARGET_CXXFLAGS_append_riscv32 += "-fpic"
-TARGET_CFLAGS_append_riscv64 += "-fpic"
-TARGET_CXXFLAGS_append_riscv64 += "-fpic"
+TARGET_CFLAGS_append_riscv32 = " -fpic"
+TARGET_CXXFLAGS_append_riscv32 = " -fpic"
+TARGET_CFLAGS_append_riscv64 = " -fpic"
+TARGET_CXXFLAGS_append_riscv64 = " -fpic"
do_install[cleandirs] += "${WORKDIR}/minifi-install"