summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-extended')
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/beep/beep_1.2.2.bb25
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/beep/beep_1.4.9.bb32
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/beep/files/0001-Do-not-use-Werror-as-it-fails-with-newer-clang-11.patch63
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/bitwise/bitwise_0.41.bb24
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/bitwise/files/0001-makefile.am-Fix-build-when-build-dir-is-not-same-as-.patch29
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/dumb-init/dumb-init_1.2.5.bb (renamed from meta-openembedded/meta-oe/recipes-extended/dumb-init/dumb-init_1.2.2.bb)2
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/haveged/haveged_1.9.14.bb (renamed from meta-openembedded/meta-oe/recipes-extended/haveged/haveged_1.9.13.bb)4
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/linuxconsole/linuxconsole_1.7.0.bb37
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/redis/redis_6.0.9.bb (renamed from meta-openembedded/meta-oe/recipes-extended/redis/redis_6.0.8.bb)4
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/smartmontools/smartmontools_7.2.bb (renamed from meta-openembedded/meta-oe/recipes-extended/smartmontools/smartmontools_7.1.bb)4
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/socketcan/can-utils_git.bb4
11 files changed, 181 insertions, 47 deletions
diff --git a/meta-openembedded/meta-oe/recipes-extended/beep/beep_1.2.2.bb b/meta-openembedded/meta-oe/recipes-extended/beep/beep_1.2.2.bb
deleted file mode 100644
index cafc86964..000000000
--- a/meta-openembedded/meta-oe/recipes-extended/beep/beep_1.2.2.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION = "beep is a command line tool for linux that beeps the PC speaker"
-LICENSE = "GPL-2.0"
-LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
-
-SRC_URI = "\
- http://johnath.com/beep/beep-${PV}.tar.gz \
- file://linux-input.patch \
-"
-
-SRC_URI[sha256sum] = "5c0445dac43950b7c7c3f235c6fb21f620ab3fd2f3aafaf09896e5730fcf49a1"
-
-S = "${WORKDIR}/${BPN}-${PV}"
-
-EXTRA_OEMAKE += 'CC="${CC}"'
-EXTRA_OEMAKE += 'FLAGS="${CFLAGS} ${LDFLAGS}"'
-
-do_configure[noexec] = "1"
-
-do_compile() {
- oe_runmake
-}
-
-do_install() {
- install -Dm 0755 ${B}/${PN} ${D}${bindir}/${PN}
-}
diff --git a/meta-openembedded/meta-oe/recipes-extended/beep/beep_1.4.9.bb b/meta-openembedded/meta-oe/recipes-extended/beep/beep_1.4.9.bb
new file mode 100644
index 000000000..8d332b2fa
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-extended/beep/beep_1.4.9.bb
@@ -0,0 +1,32 @@
+SUMMARY = "beep allows you to have the PC speaker issue beeps and beep patterns"
+DESCRIPTION = "beep allows you to have the PC speaker issue beeps and beep \
+patterns with given frequencies, durations, and spacing."
+HOMEPAGE = "https://github.com/spkr-beep/beep"
+BUGTRACKER = "https://github.com/spkr-beep/beep/issues"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://github.com/spkr-beep/beep.git;protocol=https \
+ file://0001-Do-not-use-Werror-as-it-fails-with-newer-clang-11.patch \
+"
+SRCREV = "8b85ddd09f73b9fd7caa5679298781a57af194ac"
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = " \
+ COMPILER_gcc='${CC}' \
+ LINKER_gcc='${CC}' \
+ COMPILER_clang=no \
+ LINKER_clang=no \
+"
+
+EXTRA_OEMAKE_toolchain-clang = " \
+ COMPILER_clang='${CC}' \
+ LINKER_clang='${CC}' \
+ COMPILER_gcc=no \
+ LINKER_gcc=no \
+"
+
+do_install() {
+ oe_runmake install DESTDIR='${D}'
+}
diff --git a/meta-openembedded/meta-oe/recipes-extended/beep/files/0001-Do-not-use-Werror-as-it-fails-with-newer-clang-11.patch b/meta-openembedded/meta-oe/recipes-extended/beep/files/0001-Do-not-use-Werror-as-it-fails-with-newer-clang-11.patch
new file mode 100644
index 000000000..ba7681b98
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-extended/beep/files/0001-Do-not-use-Werror-as-it-fails-with-newer-clang-11.patch
@@ -0,0 +1,63 @@
+From 6b33adfa438e35b6a37cfb0364274370ef4f9fc1 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 23 Dec 2020 18:00:59 +0000
+Subject: [PATCH] Do not use -Werror as it fails with newer clang 11+
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ GNUmakefile | 1 -
+ 1 file changed, 1 deletion(-)
+
+--- a/GNUmakefile
++++ b/GNUmakefile
+@@ -91,12 +91,13 @@ comma := ,
+ # If supported by COMPILER_gcc, add given flags to CFLAGS_gcc.
+ # Example usage:
+ # $(eval $(call CHECK_CFLAGS_gcc,-fasynchronous-unwind-tables))
+-define CHECK_CFLAGS_gcc
+-CFLAGS_gcc += $$(if $$(shell if $$(COMPILER_gcc) $(1) -x c -o compile-check.gcc-o -c - < /dev/null > /dev/null 2>&1; then echo yes; else :; fi; rm -f compile-check.gcc-o > /dev/null 2>&1),$(1))
+-endef
+
+ COMPILER_gcc = gcc
+ LINKER_gcc = gcc
++ifneq ($(COMPILER_gcc),no)
++define CHECK_CFLAGS_gcc
++CFLAGS_gcc += $$(if $$(shell if $$(COMPILER_gcc) $(1) -x c -o compile-check.gcc-o -c - < /dev/null > /dev/null 2>&1; then echo yes; else :; fi; rm -f compile-check.gcc-o > /dev/null 2>&1),$(1))
++endef
+ CPPFLAGS_gcc =
+ CFLAGS_gcc =
+ CFLAGS_gcc += -std=gnu99 -pedantic
+@@ -113,30 +114,24 @@ CFLAGS_gcc += -save-temps=obj
+ LDFLAGS_gcc =
+ LIBS_gcc =
+
+-ifneq ($(call pathsearch,$(COMPILER_gcc)),)
+-ifneq ($(COMPILER_gcc)),no)
+ COMPILERS += gcc
+ endif
+-endif
+
+ COMPILER_clang = clang
+ LINKER_clang = clang
++
++ifneq ($(COMPILER_clang),no)
+ CPPFLAGS_clang =
+ CFLAGS_clang += -Wall -Wextra
+ CFLAGS_clang += -Weverything
+ CFLAGS_clang += -Wno-padded
+ CFLAGS_clang += -std=gnu99 -pedantic
+-CFLAGS_clang += -Werror
+-CFLAGS_clang += -fsanitize=undefined
+ CFLAGS_clang += -O -g
+ LDFLAGS_clang =
+ LIBS_clang =
+
+-ifneq ($(call pathsearch,$(COMPILER_clang)),)
+-ifneq ($(COMPILER_clang),no)
+ COMPILERS += clang
+ endif
+-endif
+
+
+ ########################################################################
diff --git a/meta-openembedded/meta-oe/recipes-extended/bitwise/bitwise_0.41.bb b/meta-openembedded/meta-oe/recipes-extended/bitwise/bitwise_0.41.bb
new file mode 100644
index 000000000..037822781
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-extended/bitwise/bitwise_0.41.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Bitwise terminal calculator"
+DESCRIPTION = "Bitwise is multi base interactive calculator \
+supporting dynamic base conversion and bit manipulation.\
+It's a handy tool for low level hackers, \
+kernel developers and device drivers developers."
+
+HOMEPAGE = "https://github.com/mellowcandle/bitwise"
+SECTION = "console/utils"
+
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
+
+SRC_URI = "https://github.com/mellowcandle/bitwise/releases/download/v${PV}/bitwise-v${PV}.tar.gz \
+ file://0001-makefile.am-Fix-build-when-build-dir-is-not-same-as-.patch \
+ "
+SRC_URI[sha256sum] = "33ce934fb99dadf7652224152cc135a0abf6a211adde53d96e9be7067567749c"
+
+UPSTREAM_CHECK_URI = "https://github.com/mellowcandle/bitwise/releases"
+
+S = "${WORKDIR}/${BPN}-v${PV}"
+
+DEPENDS = "ncurses readline"
+
+inherit autotools
diff --git a/meta-openembedded/meta-oe/recipes-extended/bitwise/files/0001-makefile.am-Fix-build-when-build-dir-is-not-same-as-.patch b/meta-openembedded/meta-oe/recipes-extended/bitwise/files/0001-makefile.am-Fix-build-when-build-dir-is-not-same-as-.patch
new file mode 100644
index 000000000..ad3f0bb1f
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-extended/bitwise/files/0001-makefile.am-Fix-build-when-build-dir-is-not-same-as-.patch
@@ -0,0 +1,29 @@
+From 2089b514045d2de64a5d9c54e241731e85d77df2 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 14 Dec 2020 22:11:59 -0800
+Subject: [PATCH] makefile.am: Fix build when build dir is not same as
+ sourcedir
+
+This ensures right include paths are added to compiler
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index eba85a1..da998ff 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -19,7 +19,7 @@ if COND_DEBUG
+ MAYBE_DEBUG=-g -O0
+ endif
+
+-AM_CFLAGS = $(MAYBE_COVERAGE) $(MAYBE_DEBUG) $(MAYBE_TRACE)
++AM_CFLAGS = $(MAYBE_COVERAGE) $(MAYBE_DEBUG) $(MAYBE_TRACE) -I$(srcdir)/inc
+
+ check_PROGRAMS = tests/test-shunting-yard
+ tests_test_shunting_yard_SOURCES = src/shunting-yard.c inc/shunting-yard.h \
+--
+2.29.2
+
diff --git a/meta-openembedded/meta-oe/recipes-extended/dumb-init/dumb-init_1.2.2.bb b/meta-openembedded/meta-oe/recipes-extended/dumb-init/dumb-init_1.2.5.bb
index 09eab9dcd..d88775f9d 100644
--- a/meta-openembedded/meta-oe/recipes-extended/dumb-init/dumb-init_1.2.2.bb
+++ b/meta-openembedded/meta-oe/recipes-extended/dumb-init/dumb-init_1.2.5.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "https://github.com/Yelp/dumb-init/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=5940d39995ea6857d01b8227109c2e9c"
-SRCREV = "b1e978e486114797347deefcc03ab12629a13cc3"
+SRCREV = "89c1502b9d40b5cb4a844498b14d74ba1dd559bf"
SRC_URI = "git://github.com/Yelp/dumb-init"
S = "${WORKDIR}/git"
diff --git a/meta-openembedded/meta-oe/recipes-extended/haveged/haveged_1.9.13.bb b/meta-openembedded/meta-oe/recipes-extended/haveged/haveged_1.9.14.bb
index 50326ea2f..b56b2271b 100644
--- a/meta-openembedded/meta-oe/recipes-extended/haveged/haveged_1.9.13.bb
+++ b/meta-openembedded/meta-oe/recipes-extended/haveged/haveged_1.9.14.bb
@@ -5,8 +5,8 @@ HOMEPAGE = "http://www.issihosts.com/haveged/index.html"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM="file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
-# v1.9.9
-SRCREV = "1283a65c541c4a83e152024a63faf7b267b9b1cd"
+# v1.9.14
+SRCREV = "4da3080ad4587860e5da73072d6ed54d0052938c"
SRC_URI = "git://github.com/jirka-h/haveged.git \
"
S = "${WORKDIR}/git"
diff --git a/meta-openembedded/meta-oe/recipes-extended/linuxconsole/linuxconsole_1.7.0.bb b/meta-openembedded/meta-oe/recipes-extended/linuxconsole/linuxconsole_1.7.0.bb
index c4cd1d609..fb161b658 100644
--- a/meta-openembedded/meta-oe/recipes-extended/linuxconsole/linuxconsole_1.7.0.bb
+++ b/meta-openembedded/meta-oe/recipes-extended/linuxconsole/linuxconsole_1.7.0.bb
@@ -8,8 +8,7 @@ HOMEPAGE = "https://sourceforge.net/projects/linuxconsole"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-DEPENDS = "libsdl2"
-DEPENDS += "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
+DEPENDS = "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
SRC_URI = "\
${SOURCEFORGE_MIRROR}/linuxconsole/linuxconsoletools-${PV}.tar.bz2 \
@@ -32,21 +31,32 @@ SYSTEMD_PACKAGES += "inputattach"
SYSTEMD_SERVICE_inputattach = "inputattach.service"
SYSTEMD_AUTO_ENABLE_inputattach = "enable"
+PROVIDES += "joystick"
+
+PACKAGECONFIG ??= "sdl"
+PACKAGECONFIG[sdl] = ",,libsdl2"
+
do_compile() {
+ if ! ${@bb.utils.contains('PACKAGECONFIG', 'sdl', 'true', 'false', d)}; then
+ # drop ffmvforce so that we don't need libsdl2
+ sed '/^PROGRAMS/s/ffmvforce *//g' -i ${S}/utils/Makefile
+ fi
+ # respect nonarch_base_libdir path to keep QA check happy
+ sed 's#DESTDIR)/lib/udev#DESTDIR)/${nonarch_base_libdir}/udev#g' -i ${S}/utils/Makefile
oe_runmake
}
do_install() {
oe_runmake install
- install -Dm 0644 ${WORKDIR}/51-these-are-not-joysticks-rm.rules ${D}${base_libdir}/udev/rules.d/51-these-are-not-joysticks-rm.rules
- install -Dm 0644 ${WORKDIR}/60-joystick.rules ${D}${base_libdir}/udev/rules.d/60-joystick.rules
+ install -Dm 0644 ${WORKDIR}/51-these-are-not-joysticks-rm.rules ${D}${nonarch_base_libdir}/udev/rules.d/51-these-are-not-joysticks-rm.rules
+ install -Dm 0644 ${WORKDIR}/60-joystick.rules ${D}${nonarch_base_libdir}/udev/rules.d/60-joystick.rules
install -Dm 0644 ${WORKDIR}/inputattach.service ${D}${systemd_system_unitdir}/inputattach.service
install -Dm 0755 ${WORKDIR}/inputattachctl ${D}${bindir}/inputattachctl
}
-PACKAGES += "inputattach joystick"
+PACKAGES += "inputattach joystick-jscal joystick"
# We won't package any file here as we are following the same packaging schema
# Debian does and we are splitting it in 'inputattach' and 'joystick' packages.
@@ -64,20 +74,23 @@ FILES_joystick += "\
${bindir}/ffmvforce \
${bindir}/ffset \
${bindir}/fftest \
+ ${bindir}/jstest \
+ ${nonarch_base_libdir}/udev/rules.d/51-these-are-not-joysticks-rm.rules \
+ ${nonarch_base_libdir}/udev/js-set-enum-leds \
+ ${nonarch_base_libdir}/udev/rules.d/60-joystick.rules \
+ ${nonarch_base_libdir}/udev/rules.d/80-stelladaptor-joystick.rules \
+"
+
+FILES_joystick-jscal = " \
+ ${datadir}/joystick \
${bindir}/jscal \
${bindir}/jscal-restore \
${bindir}/jscal-store \
- ${bindir}/jstest \
- ${datadir}/joystick \
- ${base_libdir}/udev/rules.d/51-these-are-not-joysticks-rm.rules \
- ${base_libdir}/udev/js-set-enum-leds \
- ${base_libdir}/udev/rules.d/60-joystick.rules \
- ${base_libdir}/udev/rules.d/80-stelladaptor-joystick.rules \
"
RDEPENDS_inputattach += "inputattach-config"
-RDEPENDS_joystick += "\
+RDEPENDS_joystick-jscal += "\
bash \
gawk \
"
diff --git a/meta-openembedded/meta-oe/recipes-extended/redis/redis_6.0.8.bb b/meta-openembedded/meta-oe/recipes-extended/redis/redis_6.0.9.bb
index 14091b565..50571ed55 100644
--- a/meta-openembedded/meta-oe/recipes-extended/redis/redis_6.0.8.bb
+++ b/meta-openembedded/meta-oe/recipes-extended/redis/redis_6.0.9.bb
@@ -18,9 +18,7 @@ SRC_URI = "http://download.redis.io/releases/${BP}.tar.gz \
file://riscv32.patch \
file://ilp32.patch \
"
-
-SRC_URI[md5sum] = "70113b4b8ea7ee4c7e148be62b5d1e0b"
-SRC_URI[sha256sum] = "04fa1fddc39bd1aecb6739dd5dd73858a3515b427acd1e2947a66dadce868d68"
+SRC_URI[sha256sum] = "dc2bdcf81c620e9f09cfd12e85d3bc631c897b2db7a55218fd8a65eaa37f86dd"
inherit autotools-brokensep update-rc.d systemd useradd
diff --git a/meta-openembedded/meta-oe/recipes-extended/smartmontools/smartmontools_7.1.bb b/meta-openembedded/meta-oe/recipes-extended/smartmontools/smartmontools_7.2.bb
index b401272d2..3c01e589c 100644
--- a/meta-openembedded/meta-oe/recipes-extended/smartmontools/smartmontools_7.1.bb
+++ b/meta-openembedded/meta-oe/recipes-extended/smartmontools/smartmontools_7.2.bb
@@ -22,8 +22,8 @@ PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'libcap-ng selinux', d)
PACKAGECONFIG[libcap-ng] = "--with-libcap-ng=yes,--with-libcap-ng=no,libcap-ng"
PACKAGECONFIG[selinux] = "--with-selinux=yes,--with-selinux=no,libselinux"
-SRC_URI[md5sum] = "430cd5f64caa4524018b536e5ecd9c29"
-SRC_URI[sha256sum] = "3f734d2c99deb1e4af62b25d944c6252de70ca64d766c4c7294545a2e659b846"
+SRC_URI[md5sum] = "e8d134c69ae4959a05cb56b31172ffb1"
+SRC_URI[sha256sum] = "5cd98a27e6393168bc6aaea070d9e1cd551b0f898c52f66b2ff2e5d274118cd6"
inherit autotools update-rc.d systemd
diff --git a/meta-openembedded/meta-oe/recipes-extended/socketcan/can-utils_git.bb b/meta-openembedded/meta-oe/recipes-extended/socketcan/can-utils_git.bb
index b44942303..bc930ac9d 100644
--- a/meta-openembedded/meta-oe/recipes-extended/socketcan/can-utils_git.bb
+++ b/meta-openembedded/meta-oe/recipes-extended/socketcan/can-utils_git.bb
@@ -6,9 +6,9 @@ DEPENDS = "libsocketcan"
SRC_URI = "git://github.com/linux-can/${BPN}.git;protocol=git"
-SRCREV = "856d0a662a02dd2dc0b83a7ad1de9fd120e82c4b"
+SRCREV = "eb66451df280f95a9a12e78b151b8d867e1b78ed"
-PV = "2020.11.0"
+PV = "2020.12.0"
S = "${WORKDIR}/git"