summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-gnome
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-gnome')
-rw-r--r--meta-openembedded/meta-oe/recipes-gnome/gcab/gcab/run-ptest3
-rw-r--r--meta-openembedded/meta-oe/recipes-gnome/gcab/gcab_1.4.bb24
-rw-r--r--meta-openembedded/meta-oe/recipes-gnome/libjcat/libjcat/run-ptest3
-rw-r--r--meta-openembedded/meta-oe/recipes-gnome/libjcat/libjcat_0.1.3.bb34
-rw-r--r--meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas/0001-Do-not-build-tests-when-introspection-is-disabled-mi.patch36
-rw-r--r--meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas/add_missing_locale_include.patch21
-rw-r--r--meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas_1.26.0.bb (renamed from meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas_1.25.3.bb)13
-rw-r--r--meta-openembedded/meta-oe/recipes-gnome/libxmlb/libxmlb/run-ptest3
-rw-r--r--meta-openembedded/meta-oe/recipes-gnome/libxmlb/libxmlb_0.1.15.bb19
9 files changed, 153 insertions, 3 deletions
diff --git a/meta-openembedded/meta-oe/recipes-gnome/gcab/gcab/run-ptest b/meta-openembedded/meta-oe/recipes-gnome/gcab/gcab/run-ptest
new file mode 100644
index 000000000..0cdb48ea3
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-gnome/gcab/gcab/run-ptest
@@ -0,0 +1,3 @@
+#! /bin/sh
+
+gnome-desktop-testing-runner libgcab
diff --git a/meta-openembedded/meta-oe/recipes-gnome/gcab/gcab_1.4.bb b/meta-openembedded/meta-oe/recipes-gnome/gcab/gcab_1.4.bb
new file mode 100644
index 000000000..68f52bf92
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-gnome/gcab/gcab_1.4.bb
@@ -0,0 +1,24 @@
+SUMMARY = "A GObject library to create cabinet files"
+HOMEPAGE = "https://gitlab.gnome.org/GNOME/gcab"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+DEPENDS = "glib-2.0"
+
+SRC_URI = "\
+ ${GNOME_MIRROR}/gcab/${PV}/gcab-${PV}.tar.xz \
+ file://run-ptest \
+"
+SRC_URI[sha256sum] = "67a5fa9be6c923fbc9197de6332f36f69a33dadc9016a2b207859246711c048f"
+
+inherit gobject-introspection gtk-doc manpages meson ptest-gnome vala
+
+PACKAGECONFIG ??= "\
+ ${@bb.utils.contains('USE_NLS', 'yes', 'nls', '', d)} \
+ ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
+"
+PACKAGECONFIG[manpages] = ""
+PACKAGECONFIG[nls] = "-Dnls=true,-Dnls=false"
+PACKAGECONFIG[tests] = "-Dtests=true -Dinstalled_tests=true,-Dtests=false -Dinstalled_tests=false"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-openembedded/meta-oe/recipes-gnome/libjcat/libjcat/run-ptest b/meta-openembedded/meta-oe/recipes-gnome/libjcat/libjcat/run-ptest
new file mode 100644
index 000000000..14980a7d0
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-gnome/libjcat/libjcat/run-ptest
@@ -0,0 +1,3 @@
+#! /bin/sh
+
+gnome-desktop-testing-runner libjcat
diff --git a/meta-openembedded/meta-oe/recipes-gnome/libjcat/libjcat_0.1.3.bb b/meta-openembedded/meta-oe/recipes-gnome/libjcat/libjcat_0.1.3.bb
new file mode 100644
index 000000000..7ef2e5305
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-gnome/libjcat/libjcat_0.1.3.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Library for reading and writing Jcat files"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1803fa9c2c3ce8cb06b4861d75310742"
+
+DEPENDS = "\
+ glib-2.0 \
+ json-glib \
+"
+
+SRC_URI = "\
+ git://github.com/hughsie/libjcat.git \
+ file://run-ptest \
+"
+SRCREV = "3c120a9132a36b100366cfe3d658ae31e6f4b7e9"
+S = "${WORKDIR}/git"
+
+inherit gobject-introspection gtk-doc meson ptest-gnome vala
+
+PACKAGECONFIG ??= "\
+ gpg \
+ pkcs7 \
+ ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
+"
+PACKAGECONFIG[gpg] = "-Dgpg=true,-Dgpg=false,gpgme"
+PACKAGECONFIG[pkcs7] = "-Dpkcs7=true,-Dpkcs7=false,gnutls gnutls-native"
+PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false"
+
+# manpage generation is broken because help2man needs to run the target binary on the host...
+EXTRA_OEMESON = "-Dman=false"
+GTKDOC_MESON_OPTION = "gtkdoc"
+
+RDEPENDS_${PN}_class-target = "\
+ ${@bb.utils.contains('PACKAGECONFIG', 'gpg', 'gnupg', '', d)} \
+"
diff --git a/meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas/0001-Do-not-build-tests-when-introspection-is-disabled-mi.patch b/meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas/0001-Do-not-build-tests-when-introspection-is-disabled-mi.patch
new file mode 100644
index 000000000..86586fe71
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas/0001-Do-not-build-tests-when-introspection-is-disabled-mi.patch
@@ -0,0 +1,36 @@
+From 53a4f19887d9ae4e77f32dd6d71c8a7b516b4d5d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+Date: Mon, 10 Aug 2020 21:53:33 +0200
+Subject: [PATCH] Do not build tests when introspection is disabled/missing
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Fixes:
+| ../libpeas-1.26.0/tests/libpeas/introspection/meson.build:47:0: ERROR: Unknown variable "libpeas_gir".
+
+Upstrem-Status: Submitted[https://gitlab.gnome.org/GNOME/libpeas/-/merge_requests/28]
+
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+---
+ meson.build | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 8322fea..43fb062 100644
+--- a/meson.build
++++ b/meson.build
+@@ -254,7 +254,9 @@ subdir('loaders')
+ if build_demos == true
+ subdir('peas-demo')
+ endif
+-subdir('tests')
++if generate_gir == true
++ subdir('tests')
++endif
+
+ summary = [
+ '',
+--
+2.26.2
+
diff --git a/meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas/add_missing_locale_include.patch b/meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas/add_missing_locale_include.patch
new file mode 100644
index 000000000..664693128
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas/add_missing_locale_include.patch
@@ -0,0 +1,21 @@
+From 3cc69f1eaa86163c3816265fa64cb660f4def364 Mon Sep 17 00:00:00 2001
+From: Christian Hergert <chergert@redhat.com>
+Date: Fri, 13 Mar 2020 10:32:21 -0700
+Subject: [PATCH] demo: add missing locale.h include
+
+Fixes #39
+
+Upstream-Status: backport
+
+diff --git a/peas-demo/peas-demo.c b/peas-demo/peas-demo.c
+index 47ac005..466a392 100644
+--- a/peas-demo/peas-demo.c
++++ b/peas-demo/peas-demo.c
+@@ -26,6 +26,7 @@
+ #include <girepository.h>
+ #include <glib/gi18n.h>
+ #include <gtk/gtk.h>
++#include <locale.h>
+
+ #include <libpeas/peas.h>
+ #include <libpeas-gtk/peas-gtk.h>
diff --git a/meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas_1.25.3.bb b/meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas_1.26.0.bb
index 57419a427..fd4ce7de5 100644
--- a/meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas_1.25.3.bb
+++ b/meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas_1.26.0.bb
@@ -8,10 +8,17 @@ DEPENDS = "gtk+3"
GNOMEBASEBUILDCLASS = "meson"
GTKDOC_MESON_OPTION = "gtk_doc"
-inherit gnomebase gobject-introspection gtk-doc gtk-icon-cache
+inherit gnomebase gobject-introspection gtk-doc gtk-icon-cache features_check
-SRC_URI[archive.md5sum] = "08bfff8f9688cf630dcb0f950617661f"
-SRC_URI[archive.sha256sum] = "1c9bbb29740c29cd6e1dd0c9964722ff08cd5e6f68f1b5c135bc391a6ce97639"
+ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
+
+SRC_URI += " \
+ file://add_missing_locale_include.patch \
+ file://0001-Do-not-build-tests-when-introspection-is-disabled-mi.patch \
+"
+
+SRC_URI[archive.md5sum] = "f7723bf8433b7984121157e1e9a629b5"
+SRC_URI[archive.sha256sum] = "a976d77e20496479a8e955e6a38fb0e5c5de89cf64d9f44e75c2213ee14f7376"
PACKAGECONFIG[python3] = "-Dpython3=true,-Dpython3=false,python3-pygobject"
diff --git a/meta-openembedded/meta-oe/recipes-gnome/libxmlb/libxmlb/run-ptest b/meta-openembedded/meta-oe/recipes-gnome/libxmlb/libxmlb/run-ptest
new file mode 100644
index 000000000..6d0bb95d3
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-gnome/libxmlb/libxmlb/run-ptest
@@ -0,0 +1,3 @@
+#! /bin/sh
+
+gnome-desktop-testing-runner libxmlb
diff --git a/meta-openembedded/meta-oe/recipes-gnome/libxmlb/libxmlb_0.1.15.bb b/meta-openembedded/meta-oe/recipes-gnome/libxmlb/libxmlb_0.1.15.bb
new file mode 100644
index 000000000..c54599317
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-gnome/libxmlb/libxmlb_0.1.15.bb
@@ -0,0 +1,19 @@
+SUMMARY = "A library to help create and query binary XML blobs"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1803fa9c2c3ce8cb06b4861d75310742"
+
+SRC_URI = "\
+ git://github.com/hughsie/libxmlb.git \
+ file://run-ptest \
+"
+SRCREV = "ee4aafdd97844f1c73021a4978a43460f0835d5c"
+S = "${WORKDIR}/git"
+
+inherit gobject-introspection gtk-doc meson ptest-gnome
+
+PACKAGECONFIG ??= "\
+ ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
+"
+PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false"
+
+GTKDOC_MESON_OPTION = "gtkdoc"