summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-graphics/fbida/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-graphics/fbida/files')
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/fbida/files/cairo-weak-detect.patch17
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/fbida/files/fbida-gcc10.patch61
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/fbida/files/fix-preprocessor.patch20
3 files changed, 84 insertions, 14 deletions
diff --git a/meta-openembedded/meta-oe/recipes-graphics/fbida/files/cairo-weak-detect.patch b/meta-openembedded/meta-oe/recipes-graphics/fbida/files/cairo-weak-detect.patch
new file mode 100644
index 000000000..c7c579cc4
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-graphics/fbida/files/cairo-weak-detect.patch
@@ -0,0 +1,17 @@
+OE configures cairo to disable EGL support, however fbida expects cairo with egl support
+this patch therefore makes it possible to set HAVE_CAIRO_GL via recipe
+
+Upstream-Status: Inappropriate [OE-Specific]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+--- a/GNUmakefile
++++ b/GNUmakefile
+@@ -67,7 +67,7 @@ define make-config
+ LIB := $(LIB)
+ RESDIR := $(call ac_resdir)
+ HAVE_LINUX_FB_H := $(call ac_header,linux/fb.h)
+-HAVE_CAIRO_GL := $(call ac_pkg_config,cairo-gl)
++HAVE_CAIRO_GL ?= $(call ac_pkg_config,cairo-gl)
+ HAVE_LIBPCD := $(call ac_lib,pcd_open,pcd)
+ HAVE_LIBGIF := $(call ac_lib,DGifOpenFileName,gif)
+ HAVE_LIBWEBP := $(call ac_pkg_config,libwebp)
diff --git a/meta-openembedded/meta-oe/recipes-graphics/fbida/files/fbida-gcc10.patch b/meta-openembedded/meta-oe/recipes-graphics/fbida/files/fbida-gcc10.patch
new file mode 100644
index 000000000..1104289f3
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-graphics/fbida/files/fbida-gcc10.patch
@@ -0,0 +1,61 @@
+Fix build with gcc10
+
+Patch from https://src.fedoraproject.org/rpms/fbida/raw/master/f/fbida.gcc10.patch
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+--- fbida-2.14/fbi.c.org 2020-03-15 17:02:17.944189632 +0100
++++ fbida-2.14/fbi.c 2020-03-15 17:02:21.880223224 +0100
+@@ -100,7 +100,6 @@
+
+ /* graphics interface */
+ gfxstate *gfx;
+-int debug;
+
+ /* framebuffer */
+ char *fbdev = NULL;
+--- fbida-2.14/filter.c 2020-03-15 16:44:17.159855150 +0100
++++ fbida-2.14/filter.c 2020-03-15 16:44:27.017941447 +0100
+@@ -6,8 +6,6 @@
+ #include "readers.h"
+ #include "filter.h"
+
+-int debug = 0;
+-
+ /* ----------------------------------------------------------------------- */
+
+ static void
+--- fbida-2.14/readers.c.org 2020-03-15 17:01:18.692683597 +0100
++++ fbida-2.14/readers.c 2020-03-15 16:57:19.141632384 +0100
+@@ -6,6 +6,8 @@
+
+ #include "readers.h"
+
++int debug=0;
++
+ /* ----------------------------------------------------------------------- */
+
+ void load_bits_lsb(unsigned char *dst, unsigned char *src, int width,
+
+--- fbida-2.14/viewer.c.org 2020-03-15 17:05:02.991595832 +0100
++++ fbida-2.14/viewer.c 2020-03-15 17:04:55.424531467 +0100
+@@ -40,7 +40,6 @@
+ #define PROCESS_LINES 16
+
+-int debug;
+ Cursor ptrs[POINTER_COUNT];
+
+ /* ----------------------------------------------------------------------- */
+
+--- fbida-2.14/idaconfig.h.org 2020-03-15 17:07:09.239668196 +0100
++++ fbida-2.14/idaconfig.h 2020-03-15 17:07:21.248770061 +0100
+@@ -17,7 +17,7 @@
+
+ /* -------------------------------------------------------------------------- */
+
+-char *ida_lists;
++extern char *ida_lists;
+
+ void ida_init_config(void);
+ void ida_read_config(void);
diff --git a/meta-openembedded/meta-oe/recipes-graphics/fbida/files/fix-preprocessor.patch b/meta-openembedded/meta-oe/recipes-graphics/fbida/files/fix-preprocessor.patch
index 909a0a6c0..cdeac996a 100644
--- a/meta-openembedded/meta-oe/recipes-graphics/fbida/files/fix-preprocessor.patch
+++ b/meta-openembedded/meta-oe/recipes-graphics/fbida/files/fix-preprocessor.patch
@@ -1,14 +1,6 @@
-Index: fbida-2.13/GNUmakefile
-===================================================================
---- fbida-2.13.orig/GNUmakefile
-+++ fbida-2.13/GNUmakefile
-@@ -53,8 +53,7 @@ include $(srcdir)/mk/Autoconf.mk
-
- ac_jpeg_ver = $(shell \
- $(call ac_init,for libjpeg version);\
-- $(call ac_s_cmd,echo JPEG_LIB_VERSION \
-- | cpp -include jpeglib.h | tail -n 1);\
-+ $(call ac_s_cmd,cpp -include jpeglib.h -dM -E -x c /dev/null | grep 'define JPEG_LIB_VERSION' | cut -f 3 -d' ');\
- $(call ac_fini))
-
- define make-config
+--- a/scripts/jpeg-version.sh
++++ b/scripts/jpeg-version.sh
+@@ -1,2 +1,2 @@
+ #!/bin/sh
+-echo JPEG_LIB_VERSION | cpp $CFLAGS -include jpeglib.h | tail -1
++${CPP} -include jpeglib.h -dM -E -x c /dev/null | grep 'define JPEG_LIB_VERSION' | cut -f 3 -d' '