summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/meta-openembedded/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb b/meta-openembedded/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
index b84806fd6..1863f95f0 100644
--- a/meta-openembedded/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
+++ b/meta-openembedded/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
@@ -6,10 +6,10 @@ LIC_FILES_CHKSUM = " \
file://LICENSE;md5=d042f3d2a8fd7208b704a499168e3c89 \
"
-DEPENDS = "glib-2.0 pango giflib tiff libxml2 jpeg libtool uthash gettext-native"
+DEPENDS = "python3 glib-2.0 pango giflib tiff libxml2 jpeg libtool uthash gettext-native"
DEPENDS_append_class-target = " libxi"
-inherit autotools pkgconfig python3native features_check gettext gtk-icon-cache mime
+inherit autotools pkgconfig python3native features_check gettext gtk-icon-cache mime mime-xdg
REQUIRED_DISTRO_FEATURES_append_class-target = " x11"
@@ -20,9 +20,12 @@ SRC_URI = "git://github.com/${BPN}/${BPN}.git \
"
S = "${WORKDIR}/git"
-EXTRA_OECONF += "--without-libuninameslist"
+EXTRA_OECONF += "--without-libuninameslist --enable-python-scripting --enable-python-extension"
EXTRA_OECONF_append_class-native = " with_x=no"
+LDFLAGS += "-lpython${PYTHON_BASEVERSION}${PYTHON_ABI}"
+BUILD_LDFLAGS += "-lpython${PYTHON_BASEVERSION}${PYTHON_ABI}"
+
#do_configure_prepend() {
# uthash sources are expected in uthash/src
# mkdir -p ${S}/uthash/src