summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb24
1 files changed, 23 insertions, 1 deletions
diff --git a/meta-openembedded/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb b/meta-openembedded/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb
index 12ecb9909..aa5c0c820 100644
--- a/meta-openembedded/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb
+++ b/meta-openembedded/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb
@@ -16,6 +16,7 @@ DEPENDS = " \
freetype \
"
DEPENDS_append_class-target = " ${BPN}-native"
+DEPENDS_append_class-nativesdk = " ${BPN}-native"
inherit autotools-brokensep pkgconfig gettext
@@ -33,6 +34,10 @@ SRC_URI_append_class-target = "\
file://0001-Use-native-mkdefs.patch \
file://0001-Set-use_tcl-to-be-empty-string-if-tcl-is-disabled.patch \
"
+SRC_URI_append_class-nativesdk = "\
+ file://0001-Use-native-mkdefs.patch \
+ file://graphviz-setup.sh \
+"
SRC_URI[md5sum] = "2acf30ca8e6cc8b001b0334db65fd072"
SRC_URI[sha256sum] = "e6c3f8dbfde1c4523055403927bef29f97f9fc12715c1042b5dcf648a2c1c62a"
@@ -47,7 +52,17 @@ EXTRA_OECONF_class-target = "\
--disable-r \
--disable-sharp \
"
+EXTRA_OECONF_class-nativesdk = "\
+ --with-expatincludedir=${STAGING_INCDIR} \
+ --with-expatlibdir=${STAGING_LIBDIR} \
+ --without-included-ltdl \
+ --disable-java \
+ --disable-tcl \
+ --disable-r \
+ --disable-sharp \
+ "
CFLAGS_append_class-target = " -D_typ_ssize_t=1 -D_long_double=1"
+CFLAGS_append_class-nativesdk = " -D_typ_ssize_t=1 -D_long_double=1"
do_configure_prepend() {
cd ${S}
# create version.m4 and ignore libtoolize errors
@@ -59,6 +74,13 @@ do_install_append_class-native() {
install -m755 ${B}/lib/gvpr/mkdefs ${D}${bindir}
}
+do_install_append_class-nativesdk() {
+ # graphviz-setup.sh must be executed at SDK installation
+ install -d ${D}${SDKPATHNATIVE}/post-relocate-setup.d
+ install -m 0755 ${WORKDIR}/graphviz-setup.sh ${D}${SDKPATHNATIVE}/post-relocate-setup.d
+}
+FILES_${PN}_class-nativesdk += "${SDKPATHNATIVE}"
+
PACKAGES =+ "${PN}-python ${PN}-perl ${PN}-demo"
FILES_${PN}-python += "${libdir}/python*/site-packages/ ${libdir}/graphviz/python/"
@@ -74,4 +96,4 @@ INSANE_SKIP_${PN}-python = "dev-so"
FILES_SOLIBSDEV_append = " ${libdir}/graphviz/lib*${SOLIBSDEV}"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"