summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-graphics/vk-gl-cts/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-graphics/vk-gl-cts/files')
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/vk-gl-cts/files/fix-clang-private-operator.patch15
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/vk-gl-cts/files/fix-musl.patch24
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-graphics/vk-gl-cts/files/fix-clang-private-operator.patch b/meta-openembedded/meta-oe/recipes-graphics/vk-gl-cts/files/fix-clang-private-operator.patch
new file mode 100644
index 000000000..b4573b38b
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-graphics/vk-gl-cts/files/fix-clang-private-operator.patch
@@ -0,0 +1,15 @@
+Index: git/external/glslang/src/glslang/Include/PoolAlloc.h
+===================================================================
+--- git.orig/external/glslang/src/glslang/Include/PoolAlloc.h
++++ git/external/glslang/src/glslang/Include/PoolAlloc.h
+@@ -240,8 +240,9 @@ protected:
+
+ int numCalls; // just an interesting statistic
+ size_t totalBytes; // just an interesting statistic
+-private:
++public:
+ TPoolAllocator& operator=(const TPoolAllocator&); // don't allow assignment operator
++private:
+ TPoolAllocator(const TPoolAllocator&); // don't allow default copy constructor
+ };
+
diff --git a/meta-openembedded/meta-oe/recipes-graphics/vk-gl-cts/files/fix-musl.patch b/meta-openembedded/meta-oe/recipes-graphics/vk-gl-cts/files/fix-musl.patch
new file mode 100644
index 000000000..4116ae7d1
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-graphics/vk-gl-cts/files/fix-musl.patch
@@ -0,0 +1,24 @@
+Index: git/framework/delibs/dethread/CMakeLists.txt
+===================================================================
+--- git.orig/framework/delibs/dethread/CMakeLists.txt
++++ git/framework/delibs/dethread/CMakeLists.txt
+@@ -39,6 +39,7 @@ include_directories(
+
+ if (DE_OS_IS_UNIX)
+ add_definitions(-D_GNU_SOURCE)
++ add_definitions(-D_XOPEN_SOURCE=600)
+ set(DETHREAD_LIBS ${DETHREAD_LIBS} pthread)
+ endif ()
+
+Index: git/framework/qphelper/CMakeLists.txt
+===================================================================
+--- git.orig/framework/qphelper/CMakeLists.txt
++++ git/framework/qphelper/CMakeLists.txt
+@@ -28,6 +28,7 @@ set(QPHELPER_LIBS
+ if (DE_OS_IS_UNIX OR DE_OS_IS_QNX)
+ # For vsnprintf()
+ add_definitions(-D_XOPEN_SOURCE=600)
++ set(QPHELPER_LIBS ${QPHELPER_LIBS} execinfo)
+ endif ()
+
+ if (DE_OS_IS_WIN32 AND DE_COMPILER_IS_MSC)