summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-graphics')
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/glm/glm/0001-Silence-clang-warnings.patch131
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/imlib2/imlib2_git.bb2
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/pango/pangomm_2.46.1.bb (renamed from meta-openembedded/meta-oe/recipes-graphics/pango/pangomm_2.42.1.bb)10
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/ttf-fonts/ttf-noto-emoji_20200916.bb (renamed from meta-openembedded/meta-oe/recipes-graphics/ttf-fonts/ttf-noto-emoji_20190815.bb)4
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/xscreensaver/files/0001-build-Do-not-build-po-files.patch44
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/xscreensaver/files/fix-buildscripts.patch100
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/xscreensaver/files/tweak-app-defaults.patch18
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/xscreensaver/xscreensaver_5.44.bb36
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/xscreensaver/xscreensaver_6.01.bb53
9 files changed, 237 insertions, 161 deletions
diff --git a/meta-openembedded/meta-oe/recipes-graphics/glm/glm/0001-Silence-clang-warnings.patch b/meta-openembedded/meta-oe/recipes-graphics/glm/glm/0001-Silence-clang-warnings.patch
index 25e851883..3a62fffe3 100644
--- a/meta-openembedded/meta-oe/recipes-graphics/glm/glm/0001-Silence-clang-warnings.patch
+++ b/meta-openembedded/meta-oe/recipes-graphics/glm/glm/0001-Silence-clang-warnings.patch
@@ -1,6 +1,6 @@
-From 5b83983b246cff440de4421696b6b5dd9072ed2d Mon Sep 17 00:00:00 2001
+From bd9b5060bc3b9581090d44f15b4e236566ea86a6 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
-Date: Sat, 6 Feb 2021 11:36:23 -0800
+Date: Fri, 4 Jun 2021 12:57:57 -0700
Subject: [PATCH] Silence clang warnings
Fixes
@@ -12,15 +12,22 @@ glm/gtc/../ext/quaternion_common.inl:76:87: error: unused parameter 'k' [-Werror
GLM_FUNC_QUALIFIER qua<T, Q> slerp(qua<T, Q> const& x, qua<T, Q> const& y, T a, S k)
^
+and
+
+test/gtx/gtx_fast_trigonometry.cpp:135:9: error: variable 'result' set but not used [-Werror,-Wunused-but-set-variable]
+| float result = 0.f;
+| ^
+
Upstream-Status: Submitted [https://github.com/g-truc/glm/pull/1055]
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
- glm/ext/quaternion_common.inl | 2 +-
- glm/gtc/random.inl | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
+ glm/ext/quaternion_common.inl | 2 +-
+ glm/gtc/random.inl | 2 +-
+ test/gtx/gtx_fast_trigonometry.cpp | 30 ++++++++++++------------------
+ 3 files changed, 14 insertions(+), 20 deletions(-)
diff --git a/glm/ext/quaternion_common.inl b/glm/ext/quaternion_common.inl
-index 0e4a3bb2..8f9dccef 100644
+index 0e4a3bb2..6f99f52d 100644
--- a/glm/ext/quaternion_common.inl
+++ b/glm/ext/quaternion_common.inl
@@ -104,7 +104,7 @@ namespace glm
@@ -28,7 +35,7 @@ index 0e4a3bb2..8f9dccef 100644
// Graphics Gems III, page 96
T angle = acos(cosTheta);
- T phi = angle + k * glm::pi<T>();
-+ T phi = angle + static_cast<float>(k) * glm::pi<T>();
++ T phi = angle + static_cast<T>(k) * glm::pi<T>();
return (sin(angle - a * phi)* x + sin(a * phi) * z) / sin(angle);
}
}
@@ -45,6 +52,114 @@ index 70485098..a4af2a06 100644
}
};
+diff --git a/test/gtx/gtx_fast_trigonometry.cpp b/test/gtx/gtx_fast_trigonometry.cpp
+index 8bf86ba0..ddaa708b 100644
+--- a/test/gtx/gtx_fast_trigonometry.cpp
++++ b/test/gtx/gtx_fast_trigonometry.cpp
+@@ -19,15 +19,14 @@ namespace fastCos
+ {
+ const float begin = -glm::pi<float>();
+ const float end = glm::pi<float>();
+- float result = 0.f;
+
+ const std::clock_t timestamp1 = std::clock();
+ for(float i = begin; i < end; i = NextFloat ? glm::nextFloat(i) : i += 0.1f)
+- result = glm::fastCos(i);
++ glm::fastCos(i);
+
+ const std::clock_t timestamp2 = std::clock();
+ for(float i = begin; i < end; i = NextFloat ? glm::nextFloat(i) : i += 0.1f)
+- result = glm::cos(i);
++ glm::cos(i);
+
+ const std::clock_t timestamp3 = std::clock();
+ const std::clock_t time_fast = timestamp2 - timestamp1;
+@@ -53,15 +52,14 @@ namespace fastSin
+ {
+ const float begin = -glm::pi<float>();
+ const float end = glm::pi<float>();
+- float result = 0.f;
+
+ const std::clock_t timestamp1 = std::clock();
+ for(float i = begin; i < end; i = NextFloat ? glm::nextFloat(i) : i += 0.1f)
+- result = glm::fastSin(i);
++ glm::fastSin(i);
+
+ const std::clock_t timestamp2 = std::clock();
+ for(float i = begin; i < end; i = NextFloat ? glm::nextFloat(i) : i += 0.1f)
+- result = glm::sin(i);
++ glm::sin(i);
+
+ const std::clock_t timestamp3 = std::clock();
+ const std::clock_t time_fast = timestamp2 - timestamp1;
+@@ -79,15 +77,14 @@ namespace fastTan
+ {
+ const float begin = -glm::pi<float>();
+ const float end = glm::pi<float>();
+- float result = 0.f;
+
+ const std::clock_t timestamp1 = std::clock();
+ for(float i = begin; i < end; i = NextFloat ? glm::nextFloat(i) : i += 0.1f)
+- result = glm::fastTan(i);
++ glm::fastTan(i);
+
+ const std::clock_t timestamp2 = std::clock();
+ for (float i = begin; i < end; i = NextFloat ? glm::nextFloat(i) : i += 0.1f)
+- result = glm::tan(i);
++ glm::tan(i);
+
+ const std::clock_t timestamp3 = std::clock();
+ const std::clock_t time_fast = timestamp2 - timestamp1;
+@@ -105,15 +102,14 @@ namespace fastAcos
+ {
+ const float begin = -glm::pi<float>();
+ const float end = glm::pi<float>();
+- float result = 0.f;
+
+ const std::clock_t timestamp1 = std::clock();
+ for(float i = begin; i < end; i = NextFloat ? glm::nextFloat(i) : i += 0.1f)
+- result = glm::fastAcos(i);
++ glm::fastAcos(i);
+
+ const std::clock_t timestamp2 = std::clock();
+ for(float i = begin; i < end; i = NextFloat ? glm::nextFloat(i) : i += 0.1f)
+- result = glm::acos(i);
++ glm::acos(i);
+
+ const std::clock_t timestamp3 = std::clock();
+ const std::clock_t time_fast = timestamp2 - timestamp1;
+@@ -132,13 +128,12 @@ namespace fastAsin
+ {
+ const float begin = -glm::pi<float>();
+ const float end = glm::pi<float>();
+- float result = 0.f;
+ const std::clock_t timestamp1 = std::clock();
+ for(float i = begin; i < end; i = NextFloat ? glm::nextFloat(i) : i += 0.1f)
+- result = glm::fastAsin(i);
++ glm::fastAsin(i);
+ const std::clock_t timestamp2 = std::clock();
+ for(float i = begin; i < end; i = NextFloat ? glm::nextFloat(i) : i += 0.1f)
+- result = glm::asin(i);
++ glm::asin(i);
+ const std::clock_t timestamp3 = std::clock();
+ const std::clock_t time_fast = timestamp2 - timestamp1;
+ const std::clock_t time_default = timestamp3 - timestamp2;
+@@ -155,13 +150,12 @@ namespace fastAtan
+ {
+ const float begin = -glm::pi<float>();
+ const float end = glm::pi<float>();
+- float result = 0.f;
+ const std::clock_t timestamp1 = std::clock();
+ for(float i = begin; i < end; i = NextFloat ? glm::nextFloat(i) : i += 0.1f)
+- result = glm::fastAtan(i);
++ glm::fastAtan(i);
+ const std::clock_t timestamp2 = std::clock();
+ for(float i = begin; i < end; i = NextFloat ? glm::nextFloat(i) : i += 0.1f)
+- result = glm::atan(i);
++ glm::atan(i);
+ const std::clock_t timestamp3 = std::clock();
+ const std::clock_t time_fast = timestamp2 - timestamp1;
+ const std::clock_t time_default = timestamp3 - timestamp2;
--
-2.30.0
+2.31.1
diff --git a/meta-openembedded/meta-oe/recipes-graphics/imlib2/imlib2_git.bb b/meta-openembedded/meta-oe/recipes-graphics/imlib2/imlib2_git.bb
index b44b03ce8..085aaae12 100644
--- a/meta-openembedded/meta-oe/recipes-graphics/imlib2/imlib2_git.bb
+++ b/meta-openembedded/meta-oe/recipes-graphics/imlib2/imlib2_git.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=344895f253c32f38e182dcaf30fe8a35"
DEPENDS = "freetype "
PROVIDES = "virtual/imlib2"
PV = "1.7.1"
-SRCREV = "v1.7.1"
+SRCREV = "01424487e360383a039dc123bc2a345fe7ea2535"
inherit autotools pkgconfig lib_package
diff --git a/meta-openembedded/meta-oe/recipes-graphics/pango/pangomm_2.42.1.bb b/meta-openembedded/meta-oe/recipes-graphics/pango/pangomm_2.46.1.bb
index 57d9ff982..f7e126e95 100644
--- a/meta-openembedded/meta-oe/recipes-graphics/pango/pangomm_2.42.1.bb
+++ b/meta-openembedded/meta-oe/recipes-graphics/pango/pangomm_2.46.1.bb
@@ -6,18 +6,14 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d8045f3b8f929c1cb29a1e3fd737b499 \
DEPENDS = "mm-common cairomm glibmm pango"
-SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
+GNOMEBASEBUILDCLASS = "meson"
-SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/pangomm/${SHRT_VER}/pangomm-${PV}.tar.xz"
-SRC_URI[md5sum] = "339c48dd92ebd3a9911b231708f7a819"
-SRC_URI[sha256sum] = "14bf04939930870d5cfa96860ed953ad2ce07c3fd8713add4a1bfe585589f40f"
+inherit gnomebase features_check
-inherit features_check autotools pkgconfig
+SRC_URI[archive.sha256sum] = "c885013fe61a4c5117fda395770d507563411c63e49f4a3aced4c9efe34d9975"
REQUIRED_DISTRO_FEATURES = "x11"
-EXTRA_OECONF = " --disable-documentation "
-
FILES_${PN} = "${libdir}/lib*.so.*"
FILES_${PN}-dev += "${libdir}/*/include/ ${libdir}/pangomm-*/"
diff --git a/meta-openembedded/meta-oe/recipes-graphics/ttf-fonts/ttf-noto-emoji_20190815.bb b/meta-openembedded/meta-oe/recipes-graphics/ttf-fonts/ttf-noto-emoji_20200916.bb
index e74f7a7f6..6dc39b17b 100644
--- a/meta-openembedded/meta-oe/recipes-graphics/ttf-fonts/ttf-noto-emoji_20190815.bb
+++ b/meta-openembedded/meta-oe/recipes-graphics/ttf-fonts/ttf-noto-emoji_20200916.bb
@@ -5,8 +5,8 @@ HOMEPAGE = "https://github.com/googlefonts/noto-emoji"
LICENSE = "OFL-1.1"
LIC_FILES_CHKSUM = "file://fonts/LICENSE;md5=55719faa0112708e946b820b24b14097"
-SRC_URI = "git://github.com/googlefonts/noto-emoji;protocol=https"
-SRCREV = "833a43d03246a9325e748a2d783006454d76ff66"
+SRC_URI = "git://github.com/googlefonts/noto-emoji;branch=main;protocol=https"
+SRCREV = "aac7ccaa4d1dea4543453b96f7d6fc47066a57ff"
PACKAGES = "${PN}-color ${PN}-regular"
FONT_PACKAGES = "${PN}-color ${PN}-regular"
diff --git a/meta-openembedded/meta-oe/recipes-graphics/xscreensaver/files/0001-build-Do-not-build-po-files.patch b/meta-openembedded/meta-oe/recipes-graphics/xscreensaver/files/0001-build-Do-not-build-po-files.patch
new file mode 100644
index 000000000..7703a4320
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-graphics/xscreensaver/files/0001-build-Do-not-build-po-files.patch
@@ -0,0 +1,44 @@
+From 19bd0a979677a81d7399d5b567998398ec81f38b Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 8 Jul 2021 15:40:10 -0700
+Subject: [PATCH] build: Do not build po files
+
+Fixes
+| make[1]: Entering directory '/mnt/b/yoe/master/build/tmp/work/cortexa57-yoe-linux/xscreensaver/6.01-r0/xscreensaver-6.01/po'
+| make[1]: *** No rule to make target 'default'. Stop.
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Makefile.in | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -6,8 +6,8 @@ srcdir = @srcdir@
+ VPATH = @srcdir@
+
+ SHELL = /bin/sh
+-SUBDIRS = utils jwxyz hacks/images hacks hacks/glx hacks/fonts \
+- driver po
++SUBDIRS = utils jwxyz hacks/images hacks hacks/fonts \
++ driver
+ SUBDIRS2 = $(SUBDIRS) OSX android
+ TARFILES = README README.hacking INSTALL \
+ configure configure.ac Makefile.in config.h.in \
+@@ -451,4 +451,3 @@ cerebrum::
+ --include 'configure*' \
+ --include '*/' \
+ --exclude '*'
+-
+--- a/driver/Makefile.in
++++ b/driver/Makefile.in
+@@ -212,7 +212,7 @@ TEST_EXES = test-passwd test-uid
+ xdpyinfo test-screens test-yarandom test-xinput \
+ test-xkb
+
+-EXES = xscreensaver xscreensaver-command xscreensaver-settings
++EXES = xscreensaver xscreensaver-command
+ UTIL_EXES = xscreensaver-gfx @EXES_SYSTEMD@
+ SETUID_EXES = xscreensaver-auth
+ DEMO_EXES = @ALL_DEMO_PROGRAMS@
diff --git a/meta-openembedded/meta-oe/recipes-graphics/xscreensaver/files/fix-buildscripts.patch b/meta-openembedded/meta-oe/recipes-graphics/xscreensaver/files/fix-buildscripts.patch
deleted file mode 100644
index afc8bc8e7..000000000
--- a/meta-openembedded/meta-oe/recipes-graphics/xscreensaver/files/fix-buildscripts.patch
+++ /dev/null
@@ -1,100 +0,0 @@
---- xscreensaver-5.44.orig/configure.in 2020-06-16 12:49:55.384675395 +0000
-+++ xscreensaver-5.44/configure.in 2020-06-16 12:51:49.451826729 +0000
-@@ -14,6 +14,9 @@
- #
- ###############################################################################
-
-+includedir=''
-+libdir=''
-+
- AH_TOP([
- /* config.h.in --- xscreensaver, Copyright (c) 1991-2014 Jamie Zawinski.
- *
-diff -Naur xscreensaver-5.44.orig/driver/Makefile.in xscreensaver-5.44/driver/Makefile.in
---- xscreensaver-5.44.orig/driver/Makefile.in 2020-06-16 12:49:55.388675365 +0000
-+++ xscreensaver-5.44/driver/Makefile.in 2020-06-16 12:53:36.331038333 +0000
-@@ -10,7 +10,7 @@
- top_srcdir = @top_srcdir@
- top_builddir = ..
-
--install_prefix =
-+install_prefix = ${DESTDIR}
- prefix = @prefix@
- exec_prefix = @exec_prefix@
- bindir = @bindir@
-@@ -228,7 +228,7 @@
- SCRIPTS_1 = xscreensaver-getimage-file xscreensaver-getimage-video \
- xscreensaver-text
- SCRIPTS_OSX = xscreensaver-getimage-desktop
--SCRIPTS = $(SCRIPTS_1) @SCRIPTS_OSX@
-+#SCRIPTS = $(SCRIPTS_1) @SCRIPTS_OSX@
-
- HDRS = XScreenSaver_ad.h XScreenSaver_Xm_ad.h \
- xscreensaver.h prefs.h remote.h exec.h \
-diff -Naur xscreensaver-5.44.orig/hacks/Makefile.in xscreensaver-5.44/hacks/Makefile.in
---- xscreensaver-5.44.orig/hacks/Makefile.in 2020-06-16 12:49:55.532674285 +0000
-+++ xscreensaver-5.44/hacks/Makefile.in 2020-06-16 12:58:54.364719996 +0000
-@@ -10,7 +10,7 @@
- top_srcdir = @top_srcdir@
- top_builddir = ..
-
--install_prefix =
-+install_prefix = ${DESTDIR}
- prefix = @prefix@
- exec_prefix = @exec_prefix@
- bindir = @bindir@
-@@ -124,7 +124,7 @@
- tessellimage.c delaunay.c recanim.c binaryring.c \
- glitchpeg.c vfeedback.c scooter.c webcollage-cocoa.m \
- webcollage-helper-cocoa.m testx11.c
--SCRIPTS = vidwhacker webcollage ljlatest
-+#SCRIPTS = vidwhacker webcollage ljlatest
-
- # Programs that are mentioned in XScreenSaver.ad, and that have XML files,
- # but that are not shipped with xscreensaver itself.
-@@ -166,7 +166,13 @@
- tessellimage.o delaunay.o recanim.o binaryring.o \
- glitchpeg.o vfeedback.o scooter.o testx11.o
-
--EXES = attraction blitspin bouboule braid decayscreen deco \
-+EXES = fontglide
-+JPEG_EXES = webcollage-helper
-+
-+RETIRED_EXES = ant bubbles critical flag forest hyperball hypercube laser \
-+ lightning lisa lissie lmorph rotor sphere spiral t3d vines \
-+ whirlygig worm xsublim juggle testx11 \
-+ attraction blitspin bouboule braid decayscreen deco \
- drift flame galaxy grav greynetic halo \
- helix hopalong ifs imsmap julia kaleidescope \
- maze moire noseguy pedal \
-@@ -182,17 +188,12 @@
- speedmine vermiculate twang apollonian euler2d \
- polyominoes thornbird fluidballs anemone halftone \
- metaballs eruption popsquares barcode piecewise cloudlife \
-- fontglide apple2 xanalogtv pong filmleader wormhole \
-+ apple2 xanalogtv pong filmleader wormhole \
- pacman fuzzyflakes anemotaxis memscroller substrate \
- intermomentary fireworkx fiberlamp boxfit interaggregate \
- celtic cwaves m6502 abstractile lcdscrub hexadrop \
- tessellimage binaryring glitchpeg vfeedback scooter \
- @JPEG_EXES@
--JPEG_EXES = webcollage-helper
--
--RETIRED_EXES = ant bubbles critical flag forest hyperball hypercube laser \
-- lightning lisa lissie lmorph rotor sphere spiral t3d vines \
-- whirlygig worm xsublim juggle testx11
-
- HACK_OBJS_1 = fps.o $(UTILS_BIN)/resources.o $(UTILS_BIN)/visual.o \
- $(UTILS_BIN)/usleep.o $(UTILS_BIN)/yarandom.o \
-diff -Naur xscreensaver-5.44.orig/Makefile.in xscreensaver-5.44/Makefile.in
---- xscreensaver-5.44.orig/Makefile.in 2020-06-16 12:49:55.384675395 +0000
-+++ xscreensaver-5.44/Makefile.in 2020-06-16 12:52:49.395383836 +0000
-@@ -6,7 +6,7 @@
- VPATH = @srcdir@
-
- SHELL = /bin/sh
--SUBDIRS = utils jwxyz hacks/images hacks hacks/glx driver po
-+SUBDIRS = utils jwxyz hacks/images hacks driver
- SUBDIRS2 = $(SUBDIRS) OSX android
- TARFILES = README README.hacking README.VMS INSTALL \
- configure configure.in Makefile.in config.h.in \
diff --git a/meta-openembedded/meta-oe/recipes-graphics/xscreensaver/files/tweak-app-defaults.patch b/meta-openembedded/meta-oe/recipes-graphics/xscreensaver/files/tweak-app-defaults.patch
index 0f2e09aec..4ce2faed5 100644
--- a/meta-openembedded/meta-oe/recipes-graphics/xscreensaver/files/tweak-app-defaults.patch
+++ b/meta-openembedded/meta-oe/recipes-graphics/xscreensaver/files/tweak-app-defaults.patch
@@ -1,5 +1,5 @@
---- xscreensaver-5.44.orig/driver/XScreenSaver.ad.in 2020-06-16 13:13:14.950970569 +0000
-+++ xscreensaver-5.44/driver/XScreenSaver.ad.in 2020-06-16 13:19:35.777000937 +0000
+--- a/driver/XScreenSaver.ad.in
++++ b/driver/XScreenSaver.ad.in
@@ -29,7 +29,7 @@
! /* (xrdb prevention kludge: whole file)
@@ -18,13 +18,13 @@
*grabVideoFrames: False
*chooseRandomImages: @DEFAULT_IMAGES_P@
! This can be a local directory name, or the URL of an RSS or Atom feed.
-@@ -48,11 +48,11 @@
+@@ -47,11 +47,11 @@
+ *memoryLimit: 0
*lock: False
*verbose: False
- *timestamp: True
-*fade: True
+*fade: False
- *unfade: False
+ *unfade: True
*fadeSeconds: 0:00:03
*fadeTicks: 20
-*splash: True
@@ -32,7 +32,7 @@
*splashDuration: 0:00:05
*visualID: default
*installColormap: True
-@@ -343,246 +343,8 @@
+@@ -324,250 +324,8 @@ XScreenSaver.bourneShell: /bin/sh
!=============================================================================
*programs: \
@@ -272,8 +272,12 @@
- vfeedback -root \n\
-@GL_KLUDGE@ GL: deepstars -root \n\
-@GL_KLUDGE@ GL: gravitywell -root \n\
+-@GL_KLUDGE@ GL: beats -root \n\
+-@GL_KLUDGE@ GL: covid19 -root \n\
-@GL_KLUDGE@ GL: etruscanvenus -root \n\
--@GL_KLUDGE@ GL: gibson -root \n
+-@GL_KLUDGE@ GL: gibson -root \n\
+-@GL_KLUDGE@ GL: headroom -root \n\
+-@GL_KLUDGE@ GL: sphereeversion -root \n
-
-
+- fontglide -root -program "date +'%F %H:%M %z'"
diff --git a/meta-openembedded/meta-oe/recipes-graphics/xscreensaver/xscreensaver_5.44.bb b/meta-openembedded/meta-oe/recipes-graphics/xscreensaver/xscreensaver_5.44.bb
deleted file mode 100644
index 9131c754d..000000000
--- a/meta-openembedded/meta-oe/recipes-graphics/xscreensaver/xscreensaver_5.44.bb
+++ /dev/null
@@ -1,36 +0,0 @@
-SUMMARY = "X screen saver and locker"
-HOMEPAGE = "https://www.jwz.org/xscreensaver/"
-LICENSE = "BSD-0-Clause"
-LIC_FILES_CHKSUM = "file://driver/xscreensaver.h;endline=10;md5=2b97002f72fbfc9329b4336e798f2463"
-
-SRC_URI = "https://www.jwz.org/${BPN}/${BP}.tar.gz"
-SRC_URI[md5sum] = "9f764e561f9939f8684a66ec98b27cba"
-SRC_URI[sha256sum] = "73d8089cfc7d7363b5dac99b5b01dffb3429d0a855e6af16ce9a4b7777017b95"
-
-SRC_URI += " \
- file://xscreensaver.service \
- file://fix-buildscripts.patch \
- file://tweak-app-defaults.patch \
-"
-
-DEPENDS = "intltool-native libx11 libxext libxt libxft glib-2.0-native bc-native"
-# These are only needed as part of the stopgap screensaver implementation:
-RDEPENDS_${PN} = " \
- liberation-fonts \
- xuser-account \
-"
-
-inherit systemd perlnative pkgconfig gettext autotools-brokensep features_check
-
-EXTRA_OECONF += "--with-x-app-defaults=${datadir}/X11/app-defaults"
-
-REQUIRED_DISTRO_FEATURES = "x11"
-
-do_install_append() {
- install -D ${WORKDIR}/xscreensaver.service ${D}${systemd_unitdir}/system/xscreensaver.service
-}
-
-FILES_${PN} += "${datadir}/X11/app-defaults/XScreenSaver"
-SYSTEMD_SERVICE_${PN} = "xscreensaver.service"
-
-CLEANBROKEN = "1"
diff --git a/meta-openembedded/meta-oe/recipes-graphics/xscreensaver/xscreensaver_6.01.bb b/meta-openembedded/meta-oe/recipes-graphics/xscreensaver/xscreensaver_6.01.bb
new file mode 100644
index 000000000..d67e05844
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-graphics/xscreensaver/xscreensaver_6.01.bb
@@ -0,0 +1,53 @@
+SUMMARY = "X screen saver and locker"
+HOMEPAGE = "https://www.jwz.org/xscreensaver/"
+LICENSE = "BSD-0-Clause"
+LIC_FILES_CHKSUM = "file://driver/xscreensaver.h;endline=10;md5=c3ce41cdff745eb1dc9d4fcfbffb4d51"
+
+SRC_URI = "https://www.jwz.org/${BPN}/${BP}.tar.gz"
+SRC_URI[sha256sum] = "085484665d91f60b4a1dedacd94bcf9b74b0fb096bcedc89ff1c245168e5473b"
+
+SRC_URI += " \
+ file://xscreensaver.service \
+ file://0001-build-Do-not-build-po-files.patch \
+ file://tweak-app-defaults.patch \
+"
+
+DEPENDS = "intltool-native libx11 libxext libxt libxft libxi glib-2.0-native bc-native libpam"
+# These are only needed as part of the stopgap screensaver implementation:
+RDEPENDS_${PN} = " \
+ liberation-fonts \
+ xuser-account \
+"
+
+inherit systemd perlnative pkgconfig gettext autotools-brokensep features_check
+
+
+EXTRA_OECONF += "--with-app-defaults=${datadir}/X11/app-defaults --libdir=${STAGING_LIBDIR} \
+ --includedir=${STAGING_INCDIR} --with-pam --with-login-manager"
+
+EXTRA_OEMAKE += "install_prefix=${D}"
+REQUIRED_DISTRO_FEATURES = "x11 pam"
+
+do_install_append() {
+ install -D ${WORKDIR}/xscreensaver.service ${D}${systemd_unitdir}/system/xscreensaver.service
+ for f in xscreensaver-getimage-file xscreensaver-getimage-video webcollage xscreensaver-text vidwhacker
+ do
+ sed -i -e "s|${STAGING_BINDIR_NATIVE}/perl-native/perl|/usr/bin/perl|g" ${D}/${libexecdir}/${PN}/$f
+ done
+}
+
+PACKAGES =+ "${PN}-perl"
+
+FILES_${PN}-perl = "\
+ ${libexecdir}/${PN}/xscreensaver-getimage-file \
+ ${libexecdir}/${PN}/xscreensaver-getimage-video \
+ ${libexecdir}/${PN}/webcollage \
+ ${libexecdir}/${PN}/xscreensaver-text \
+ ${libexecdir}/${PN}/vidwhacker \
+ "
+FILES_${PN} += "${datadir}/X11/app-defaults/XScreenSaver ${datadir}/fonts"
+SYSTEMD_SERVICE_${PN} = "xscreensaver.service"
+
+RDEPENDS_${PN}-perl = "perl"
+
+CLEANBROKEN = "1"