summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-graphics')
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.5.25.bb6
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/jasper/jasper_2.0.22.bb (renamed from meta-openembedded/meta-oe/recipes-graphics/jasper/jasper_2.0.20.bb)4
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/suckless/st_0.8.4.bb10
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/ttf-fonts/ttf-hunkyfonts_0.3.1.bb2
4 files changed, 19 insertions, 3 deletions
diff --git a/meta-openembedded/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.5.25.bb b/meta-openembedded/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.5.25.bb
index 8daf737a5..fe7657f54 100644
--- a/meta-openembedded/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.5.25.bb
+++ b/meta-openembedded/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.5.25.bb
@@ -29,6 +29,12 @@ do_configure_append() {
cp ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/libgphoto2_port/po/
cd ${S}/libgphoto2_port/
autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths
+
+ # remove WORKDIR information from config to improve reproducibility
+ # libgphoto2_port recheck config will set the WORKDIR info again, so dont do that
+ sed -i 's/'$(echo ${WORKDIR} | sed 's_/_\\/_g')'/../g' ${B}/config.h
+ sed -i 's/'$(echo ${WORKDIR} | sed 's_/_\\/_g')'/../g' ${B}/libgphoto2_port/config.status
+ sed -i '/config\.status/ s/\-\-recheck//' ${B}/libgphoto2_port/Makefile
cd ${S}
}
diff --git a/meta-openembedded/meta-oe/recipes-graphics/jasper/jasper_2.0.20.bb b/meta-openembedded/meta-oe/recipes-graphics/jasper/jasper_2.0.22.bb
index 356c78c0d..b2b053a28 100644
--- a/meta-openembedded/meta-oe/recipes-graphics/jasper/jasper_2.0.20.bb
+++ b/meta-openembedded/meta-oe/recipes-graphics/jasper/jasper_2.0.22.bb
@@ -1,10 +1,10 @@
SUMMARY = "Jpeg 2000 implementation"
-HOMEPAGE = "https://github.com/jasper-software/jasper"
+HOMEPAGE = "https://jasper-software.github.io/jasper/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=a80440d1d8f17d041c71c7271d6e06eb"
SRC_URI = "git://github.com/jasper-software/jasper.git;protocol=https"
-SRCREV = "d10a710f31da3d079a984d35ff6cc82a853d25d7"
+SRCREV = "95b2f0583a71c92cddefb54b522efe717b7a5adc"
S = "${WORKDIR}/git"
diff --git a/meta-openembedded/meta-oe/recipes-graphics/suckless/st_0.8.4.bb b/meta-openembedded/meta-oe/recipes-graphics/suckless/st_0.8.4.bb
index 906179501..1f0f2f7f2 100644
--- a/meta-openembedded/meta-oe/recipes-graphics/suckless/st_0.8.4.bb
+++ b/meta-openembedded/meta-oe/recipes-graphics/suckless/st_0.8.4.bb
@@ -23,3 +23,13 @@ do_install() {
FILES_${PN} += " \
${datadir}/terminfo \
"
+
+inherit update-alternatives
+
+ALTERNATIVE_PRIORITY = "50"
+
+ALTERNATIVE_${PN} = "st st-256color"
+
+ALTERNATIVE_LINK_NAME[st] = "${datadir}/terminfo/s/st"
+
+ALTERNATIVE_LINK_NAME[st-256color] = "${datadir}/terminfo/s/st-256color"
diff --git a/meta-openembedded/meta-oe/recipes-graphics/ttf-fonts/ttf-hunkyfonts_0.3.1.bb b/meta-openembedded/meta-oe/recipes-graphics/ttf-fonts/ttf-hunkyfonts_0.3.1.bb
index 4df0c3afb..9c89f97f3 100644
--- a/meta-openembedded/meta-oe/recipes-graphics/ttf-fonts/ttf-hunkyfonts_0.3.1.bb
+++ b/meta-openembedded/meta-oe/recipes-graphics/ttf-fonts/ttf-hunkyfonts_0.3.1.bb
@@ -8,7 +8,7 @@ PR = "r7"
SRC_URI = "${SOURCEFORGE_MIRROR}/hunkyfonts/hunkyfonts-${PV}.tar.bz2"
-S = "${WORKDIR}/hunkyfonts-${PV}/TTF/"
+S = "${WORKDIR}/hunkyfonts-${PV}/TTF"
PACKAGES = "ttf-hunky-sans ttf-hunky-serif"
FONT_PACKAGES = "ttf-hunky-sans ttf-hunky-serif"