summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb23
1 files changed, 19 insertions, 4 deletions
diff --git a/meta-openembedded/meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb b/meta-openembedded/meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb
index 5f6588de5..48c72140c 100644
--- a/meta-openembedded/meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb
+++ b/meta-openembedded/meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb
@@ -21,7 +21,7 @@ SRC_URI += "\
"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-DEPENDS = "virtual/kernel"
+DEPENDS = "libcap"
# This looks in S, so we better make sure there's
# something in the directory.
@@ -30,25 +30,40 @@ do_populate_lic[depends] = "${PN}:do_configure"
EXTRA_OEMAKE = '\
- CC="${CC}" \
- 'CFLAGS=-Wall -I${STAGING_KERNEL_DIR}/arch/x86/include/uapi ${LDFLAGS}' \
+ CC="${CC}" 'CFLAGS=-Wall ${LDFLAGS}' \
'
# If we build under STAGING_KERNEL_DIR, source will not be put
# into the dbg rpm. STAGING_KERNEL_DIR will exist by the time
# do_configure() is invoked so we can safely copy from it.
#
+do_configure[depends] += "virtual/kernel:do_shared_workdir"
do_configure_prepend() {
mkdir -p ${S}
cp -r ${STAGING_KERNEL_DIR}/arch/x86/include/asm/msr-index.h ${S}
cp -r ${STAGING_KERNEL_DIR}/arch/x86/include/asm/intel-family.h ${S}
- cp -r ${STAGING_KERNEL_DIR}/include/linux/bits.h ${S}
+ if [ -f "${STAGING_KERNEL_DIR}/include/vdso/bits.h" ]; then
+ cp -r ${STAGING_KERNEL_DIR}/include/vdso/bits.h ${S}
+ cp -r ${STAGING_KERNEL_DIR}/include/vdso/const.h ${S}
+ else
+ cp -r ${STAGING_KERNEL_DIR}/include/linux/bits.h ${S}
+ cp -r ${STAGING_KERNEL_DIR}/include/linux/const.h ${S}
+ fi
cp -r ${STAGING_KERNEL_DIR}/tools/power/x86/turbostat/* ${S}
cp -r ${WORKDIR}/COPYING ${S}
}
+
do_compile() {
sed -i 's#<linux/bits.h>#"bits.h"#' msr-index.h
+ 'TMPCHECK='grep "<vdso/const.h>" bits.h'' || true
+ if [ -n $TMPCHECK ]; then
+ sed -i 's#<vdso/const.h>#"const.h"#' bits.h
+ sed -i 's#<uapi/linux/const.h>#<linux/const.h>#' const.h
+ else
+ sed -i 's#<linux/const.h>#"const.h"#' bits.h
+ sed -i -e 's#<uapi/linux/const.h>#<linux/const.h>#' -e 's#_LINUX_CONST_H#_LINUX_CONST_H_KERNEL#' const.h
+ fi
sed -i 's#MSRHEADER#"msr-index.h"#' turbostat.c
sed -i 's#INTEL_FAMILY_HEADER#"intel-family.h"#' turbostat.c
sed -i 's#\$(CC) \$(CFLAGS) \$< -o \$(BUILD_OUTPUT)/\$@#\$(CC) \$(CFLAGS) \$(LDFLAGS) \$< -o \$(BUILD_OUTPUT)/\$@#' Makefile