summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-shells
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-shells')
-rw-r--r--meta-openembedded/meta-oe/recipes-shells/dash/dash_0.5.11.3.bb6
-rw-r--r--meta-openembedded/meta-oe/recipes-shells/mksh/mksh_59.bb4
-rw-r--r--meta-openembedded/meta-oe/recipes-shells/tcsh/tcsh_6.22.04.bb8
-rw-r--r--meta-openembedded/meta-oe/recipes-shells/zsh/zsh_5.8.bb8
4 files changed, 13 insertions, 13 deletions
diff --git a/meta-openembedded/meta-oe/recipes-shells/dash/dash_0.5.11.3.bb b/meta-openembedded/meta-oe/recipes-shells/dash/dash_0.5.11.3.bb
index 92d9bc83d..53d018358 100644
--- a/meta-openembedded/meta-oe/recipes-shells/dash/dash_0.5.11.3.bb
+++ b/meta-openembedded/meta-oe/recipes-shells/dash/dash_0.5.11.3.bb
@@ -13,15 +13,15 @@ SRC_URI[sha256sum] = "62b9f1676ba6a7e8eaec541a39ea037b325253240d1f378c72360baa1c
EXTRA_OECONF += "--bindir=${base_bindir}"
-ALTERNATIVE_${PN} = "sh"
+ALTERNATIVE:${PN} = "sh"
ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
ALTERNATIVE_TARGET[sh] = "${base_bindir}/dash"
ALTERNATIVE_PRIORITY = "10"
-pkg_postinst_${PN} () {
+pkg_postinst:${PN} () {
grep -q "^${base_bindir}/dash$" $D${sysconfdir}/shells || echo ${base_bindir}/dash >> $D${sysconfdir}/shells
}
-pkg_postrm_${PN} () {
+pkg_postrm:${PN} () {
printf "$(grep -v "^${base_bindir}/dash$" $D${sysconfdir}/shells)\n" > $D${sysconfdir}/shells
}
diff --git a/meta-openembedded/meta-oe/recipes-shells/mksh/mksh_59.bb b/meta-openembedded/meta-oe/recipes-shells/mksh/mksh_59.bb
index 110e793b0..9cd0fbc25 100644
--- a/meta-openembedded/meta-oe/recipes-shells/mksh/mksh_59.bb
+++ b/meta-openembedded/meta-oe/recipes-shells/mksh/mksh_59.bb
@@ -16,7 +16,7 @@ inherit update-alternatives
S = "${WORKDIR}/${BPN}"
-ALTERNATIVE_${PN} = "sh"
+ALTERNATIVE:${PN} = "sh"
ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
ALTERNATIVE_TARGET[sh] = "${base_bindir}/${BPN}"
ALTERNATIVE_PRIORITY = "100"
@@ -33,4 +33,4 @@ do_install() {
install -m 0644 ${S}/dot.mkshrc ${D}${sysconfdir}/skel/.mkshrc
}
-RPROVIDES_${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge', '/bin/sh', '', d)}"
+RPROVIDES:${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge', '/bin/sh', '', d)}"
diff --git a/meta-openembedded/meta-oe/recipes-shells/tcsh/tcsh_6.22.04.bb b/meta-openembedded/meta-oe/recipes-shells/tcsh/tcsh_6.22.04.bb
index f74f582e3..ac6c6db81 100644
--- a/meta-openembedded/meta-oe/recipes-shells/tcsh/tcsh_6.22.04.bb
+++ b/meta-openembedded/meta-oe/recipes-shells/tcsh/tcsh_6.22.04.bb
@@ -19,11 +19,11 @@ SRC_URI[sha256sum] = "eb16356243218c32f39e07258d72bf8b21e62ce94bb0e8a95e318b1513
EXTRA_OEMAKE += "CC_FOR_GETHOST='${BUILD_CC}'"
inherit autotools
-do_compile_prepend() {
+do_compile:prepend() {
oe_runmake CC_FOR_GETHOST='${BUILD_CC}' CFLAGS='${BUILD_CFLAGS}' gethost
}
-do_install_append () {
+do_install:append () {
oe_runmake install.man DESTDIR=${D}
install -d ${D}${base_bindir}
@@ -34,10 +34,10 @@ do_install_append () {
install -D -m 0644 ${S}/csh-mode.el ${D}${datadir}/emacs/site-lisp/csh-mode.el
}
-FILES_${PN} += "${datadir}/emacs/site-lisp/csh-mode.el"
+FILES:${PN} += "${datadir}/emacs/site-lisp/csh-mode.el"
-pkg_postinst_${PN} () {
+pkg_postinst:${PN} () {
#!/bin/sh -e
echo /usr/bin/tcsh >> $D/etc/shells
echo /usr/bin/csh >> $D/etc/shells
diff --git a/meta-openembedded/meta-oe/recipes-shells/zsh/zsh_5.8.bb b/meta-openembedded/meta-oe/recipes-shells/zsh/zsh_5.8.bb
index f87231db2..0429cb9cc 100644
--- a/meta-openembedded/meta-oe/recipes-shells/zsh/zsh_5.8.bb
+++ b/meta-openembedded/meta-oe/recipes-shells/zsh/zsh_5.8.bb
@@ -34,7 +34,7 @@ export bindir="${base_bindir}"
EXTRA_OEMAKE = "-e MAKEFLAGS="
-ALTERNATIVE_${PN} = "sh"
+ALTERNATIVE:${PN} = "sh"
ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
ALTERNATIVE_TARGET[sh] = "${base_bindir}/${BPN}"
ALTERNATIVE_PRIORITY = "90"
@@ -46,13 +46,13 @@ do_configure () {
oe_runconf
}
-pkg_postinst_${PN} () {
+pkg_postinst:${PN} () {
touch $D${sysconfdir}/shells
grep -q "bin/zsh" $D${sysconfdir}/shells || echo /bin/zsh >> $D${sysconfdir}/shells
grep -q "bin/sh" $D${sysconfdir}/shells || echo /bin/sh >> $D${sysconfdir}/shells
}
# work around QA failures with usrmerge installing zsh in /usr/bin/zsh instead of /bin/zsh
-# ERROR: QA Issue: /usr/share/zsh/5.8/functions/zed contained in package zsh requires /bin/zsh, but no providers found in RDEPENDS_zsh? [file-rdeps]
+# ERROR: QA Issue: /usr/share/zsh/5.8/functions/zed contained in package zsh requires /bin/zsh, but no providers found in RDEPENDS:zsh? [file-rdeps]
# like bash does since https://git.openembedded.org/openembedded-core/commit/?id=4759408677a4e60c5fa7131afcb5bc184cf2f90a
-RPROVIDES_${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge', '/bin/zsh', '', d)}"
+RPROVIDES:${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge', '/bin/zsh', '', d)}"