summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/cli11/cli11_1.9.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/cli11/cli11_1.9.0.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/cli11/cli11_1.9.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/cli11/cli11_1.9.0.bb b/meta-openembedded/meta-oe/recipes-support/cli11/cli11_1.9.0.bb
new file mode 100644
index 000000000..151653b22
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/cli11/cli11_1.9.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "C++11 command line parser"
+DESCRIPTION = "A command line parser for C++11 and beyond that provides a rich feature set with a simple and intuitive interface."
+HOMEPAGE = "https://github.com/CLIUtils/CLI11"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b73927b18d5c6cd8d2ed28a6ad539733"
+SRCREV = "13becaddb657eacd090537719a669d66d393b8b2"
+PV .= "+git${SRCPV}"
+
+SRC_URI += "gitsm://github.com/CLIUtils/CLI11"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+inherit ptest
+
+# cli11 is a header only C++ library, so the main package will be empty.
+RDEPENDS_${PN}-dev = ""