summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/cpprest
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/cpprest')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch20
-rw-r--r--meta-openembedded/meta-oe/recipes-support/cpprest/cpprest_2.10.16.bb (renamed from meta-openembedded/meta-oe/recipes-support/cpprest/cpprest_2.10.15.bb)4
2 files changed, 22 insertions, 2 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch b/meta-openembedded/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch
index e108e0279..5f1f8a9f9 100644
--- a/meta-openembedded/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch
+++ b/meta-openembedded/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch
@@ -105,3 +105,23 @@ Index: cpprest/Release/tests/functional/http/client/connections_and_errors.cpp
} // SUITE(connections_and_errors)
+--- cpprest-2.10.16.orig/Release/tests/functional/http/client/redirect_tests.cpp
++++ cpprest-2.10.16/Release/tests/functional/http/client/redirect_tests.cpp
+@@ -159,7 +159,7 @@ SUITE(redirect_tests)
+ VERIFY_NO_THROWS(reply.get());
+ }
+ }
+-
++/*
+ TEST(does_not_follow_https_to_http_by_default)
+ {
+ handle_timeout([] {
+@@ -182,7 +182,7 @@ SUITE(redirect_tests)
+ );
+ });
+ }
+-
++*/
+ TEST_FIXTURE(uri_address, follows_permanent_redirect)
+ {
+ #if USING_WINHTTP
diff --git a/meta-openembedded/meta-oe/recipes-support/cpprest/cpprest_2.10.15.bb b/meta-openembedded/meta-oe/recipes-support/cpprest/cpprest_2.10.16.bb
index dee5ae256..5d7dbd8bd 100644
--- a/meta-openembedded/meta-oe/recipes-support/cpprest/cpprest_2.10.15.bb
+++ b/meta-openembedded/meta-oe/recipes-support/cpprest/cpprest_2.10.16.bb
@@ -11,8 +11,8 @@ SRC_URI = "git://github.com/Microsoft/cpprestsdk.git;protocol=https;branch=maste
file://disable-float-tests.patch \
file://disable-outside-tests.patch "
-# tag 2.10.15
-SRCREV= "b94bc32ff84e815ba44c567f6fe4af5f5f6b3048"
+# tag 2.10.16
+SRCREV= "18212a2a7967e12d740bfb957e500892b3463c88"
S = "${WORKDIR}/git"