summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/libssh
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/libssh')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/libssh/libssh_0.8.4.bb (renamed from meta-openembedded/meta-oe/recipes-support/libssh/libssh_0.7.3.bb)21
1 files changed, 11 insertions, 10 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/libssh/libssh_0.7.3.bb b/meta-openembedded/meta-oe/recipes-support/libssh/libssh_0.8.4.bb
index 79e7dc599..6040ec959 100644
--- a/meta-openembedded/meta-oe/recipes-support/libssh/libssh_0.7.3.bb
+++ b/meta-openembedded/meta-oe/recipes-support/libssh/libssh_0.8.4.bb
@@ -1,16 +1,23 @@
SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
HOMEPAGE = "http://www.libssh.org"
SECTION = "libs"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=388a4fb1dea8ceae0be78ba9b01fc139"
DEPENDS = "zlib openssl libgcrypt"
-LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://COPYING;md5=388a4fb1dea8ceae0be78ba9b01fc139"
+SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=stable-0.8"
+SRCREV = "789df0b7d0c7abd6b85db9fc5247e146e3d4ddba"
-SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=v0-7"
-SRCREV = "cdf7690e038230623cbbf6b024ece62f41efa98d"
S = "${WORKDIR}/git"
+inherit cmake
+
+PACKAGECONFIG ??=""
+PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
+
+ARM_INSTRUCTION_SET_armv5 = "arm"
+
EXTRA_OECMAKE = " \
-DWITH_GCRYPT=1 \
-DWITH_PCAP=1 \
@@ -19,16 +26,10 @@ EXTRA_OECMAKE = " \
-DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
"
-PACKAGECONFIG ??=""
-PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
-
-inherit cmake
-
do_configure_prepend () {
# Disable building of examples
sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \
|| bbfatal "Failed to disable examples"
}
-FILES_${PN}-dev += "${libdir}/cmake"
TOOLCHAIN = "gcc"