summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/lvm2
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/lvm2')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/lvm2/files/reproducible-build.patch28
-rw-r--r--meta-openembedded/meta-oe/recipes-support/lvm2/lvm2.inc2
-rw-r--r--meta-openembedded/meta-oe/recipes-support/lvm2/lvm2_2.03.06.bb8
3 files changed, 36 insertions, 2 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/lvm2/files/reproducible-build.patch b/meta-openembedded/meta-oe/recipes-support/lvm2/files/reproducible-build.patch
new file mode 100644
index 000000000..3f53db9e5
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/lvm2/files/reproducible-build.patch
@@ -0,0 +1,28 @@
+configure.ac: override CONFIGURE_LINE
+
+For reproducible binaries, we need to report a constant CONFIGURE_LINE.
+
+Upstream-Status: Pending
+
+Signed-off-by: Joe Slater <joe.slater@windriver.com>
+
+
+--- git.orig/configure.ac
++++ git/configure.ac
+@@ -15,7 +15,15 @@ AC_PREREQ(2.69)
+ ################################################################################
+ dnl -- Process this file with autoconf to produce a configure script.
+ AC_INIT
+-CONFIGURE_LINE="$0 $@"
++
++dnl per reproducible-builds.org check SOURCE_DATE_EPOCH
++dnl
++if test -z "${SOURCE_DATE_EPOCH+set}" ; then
++ CONFIGURE_LINE="$0 $@"
++else
++ CONFIGURE_LINE="configure options are not available for reproducible builds"
++fi
++
+ AC_CONFIG_SRCDIR([lib/device/dev-cache.h])
+ AC_CONFIG_HEADERS([include/configure.h])
+
diff --git a/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2.inc b/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2.inc
index 01c9df45c..3c6c7edfc 100644
--- a/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2.inc
+++ b/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2.inc
@@ -15,7 +15,9 @@ SRC_URI = "git://sourceware.org/git/lvm2.git \
file://0001-Avoid-bashisms-in-init-scripts.patch \
file://0005-do-not-build-manual.patch \
file://0006-start-lvm2-monitor.service-after-tmp.mount.patch \
+ file://reproducible-build.patch \
"
+
SRCREV = "b9391b1b9f0b73303fa21f8f92574d17ce4c2b02"
S = "${WORKDIR}/git"
diff --git a/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2_2.03.06.bb b/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2_2.03.06.bb
index e2b551bbc..bc86810ec 100644
--- a/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2_2.03.06.bb
+++ b/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2_2.03.06.bb
@@ -32,7 +32,7 @@ PACKAGE_BEFORE_PN = "${PN}-scripts ${PN}-udevrules"
SYSTEMD_PACKAGES = "${PN}"
SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'dmeventd', 'lvm2-monitor.service dm-event.socket dm-event.service', '', d)} \
- blk-availability.service lvm2-pvscan@.service"
+ blk-availability.service"
SYSTEMD_AUTO_ENABLE = "disable"
TARGET_CC_ARCH += "${LDFLAGS}"
@@ -52,7 +52,11 @@ FILES_libdevmapper = " \
${sbindir}/dmstats \
"
-FILES_${PN} += "${libdir}/device-mapper/*.so"
+FILES_${PN} += " \
+ ${libdir}/device-mapper/*.so \
+ ${systemd_system_unitdir}/lvm2-pvscan@.service \
+"
+
FILES_${PN}-scripts = " \
${sbindir}/blkdeactivate \
${sbindir}/fsadm \