summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/multipath-tools/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/multipath-tools/files')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/multipath-tools/files/0001-add-explicit-dependency-on-libraries.patch40
-rw-r--r--meta-openembedded/meta-oe/recipes-support/multipath-tools/files/0001-fix-boolean-value-with-json-c-0.14.patch42
-rw-r--r--meta-openembedded/meta-oe/recipes-support/multipath-tools/files/0032-libdmmp-Makefile-replace-perl-with-sed-in-install-ta.patch40
3 files changed, 122 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/multipath-tools/files/0001-add-explicit-dependency-on-libraries.patch b/meta-openembedded/meta-oe/recipes-support/multipath-tools/files/0001-add-explicit-dependency-on-libraries.patch
new file mode 100644
index 000000000..2827bb874
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/multipath-tools/files/0001-add-explicit-dependency-on-libraries.patch
@@ -0,0 +1,40 @@
+From 04884263d1de8c427a7a15bd1cf6466ea65d3a0b Mon Sep 17 00:00:00 2001
+From: Hongxu Jia <hongxu.jia@windriver.com>
+Date: Mon, 25 May 2020 23:22:55 -0700
+Subject: [PATCH] add explicit dependency on libraries
+
+[snip]
+gcc/i686-overc-linux/10.1.0/ld: cannot find -lmpathpersist
+collect2: error: ld returned 1 exit status
+Makefile:36: recipe for target 'multipathd' failed
+make[1]: *** [multipathd] Error 1
+make[1]: Leaving directory 'git/multipathd'
+Makefile:29: recipe for target 'multipathd' failed
+make: *** [multipathd] Error 2
+ln -sf libmpathpersist.so.0 libmpathpersist.so
+[snip]
+
+Upstream-Status: Pending
+
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+---
+ Makefile | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index bea0a0b2..37a77129 100644
+--- a/Makefile
++++ b/Makefile
+@@ -29,7 +29,8 @@ $(BUILDDIRS):
+ $(MAKE) -C $@
+
+ multipath multipathd mpathpersist libmpathpersist : libmultipath
+-mpathpersist: libmpathpersist
++mpathpersist multipathd: libmpathpersist
++libdmmp libmultipath mpathpersist multipath multipathd: libmpathcmd
+
+ DEPS_ON_MULTIPATH := \
+ multipath \
+--
+2.21.0
+
diff --git a/meta-openembedded/meta-oe/recipes-support/multipath-tools/files/0001-fix-boolean-value-with-json-c-0.14.patch b/meta-openembedded/meta-oe/recipes-support/multipath-tools/files/0001-fix-boolean-value-with-json-c-0.14.patch
new file mode 100644
index 000000000..cf97b491e
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/multipath-tools/files/0001-fix-boolean-value-with-json-c-0.14.patch
@@ -0,0 +1,42 @@
+From 5ae81386a8cfea4180738c261cd3f7944a631199 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 3 Jun 2020 16:03:56 -0700
+Subject: [PATCH] fix boolean value with json-c 0.14
+
+Patch from Christian Hesse posted here
+https://www.spinics.net/lists/dm-devel/msg40646.html
+
+Upstream json-c 0.14+ removed the TRUE and FALSE defines in commit
+0992aac61f8b087efd7094e9ac2b84fa9c040fcd.
+
+Upstream-Status: Submitted [https://www.spinics.net/lists/dm-devel/msg40646.html]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ libdmmp/libdmmp_private.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/libdmmp/libdmmp_private.h b/libdmmp/libdmmp_private.h
+index ac85b63f..29400826 100644
+--- a/libdmmp/libdmmp_private.h
++++ b/libdmmp/libdmmp_private.h
+@@ -82,7 +82,7 @@ static out_type func_name(struct dmmp_context *ctx, const char *var_name) { \
+ do { \
+ json_type j_type = json_type_null; \
+ json_object *j_obj_tmp = NULL; \
+- if (json_object_object_get_ex(j_obj, key, &j_obj_tmp) != TRUE) { \
++ if (json_object_object_get_ex(j_obj, key, &j_obj_tmp) != 1) { \
+ _error(ctx, "Invalid JSON output from multipathd IPC: " \
+ "key '%s' not found", key); \
+ rc = DMMP_ERR_IPC_ERROR; \
+@@ -90,7 +90,7 @@ do { \
+ } \
+ if (j_obj_tmp == NULL) { \
+ _error(ctx, "BUG: Got NULL j_obj_tmp from " \
+- "json_object_object_get_ex() while it return TRUE"); \
++ "json_object_object_get_ex() while it return 1"); \
+ rc = DMMP_ERR_BUG; \
+ goto out; \
+ } \
+--
+2.27.0
+
diff --git a/meta-openembedded/meta-oe/recipes-support/multipath-tools/files/0032-libdmmp-Makefile-replace-perl-with-sed-in-install-ta.patch b/meta-openembedded/meta-oe/recipes-support/multipath-tools/files/0032-libdmmp-Makefile-replace-perl-with-sed-in-install-ta.patch
new file mode 100644
index 000000000..b35d67cf5
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/multipath-tools/files/0032-libdmmp-Makefile-replace-perl-with-sed-in-install-ta.patch
@@ -0,0 +1,40 @@
+From 35421d03898ac1b38f97a76241e6a29086d0c9f1 Mon Sep 17 00:00:00 2001
+From: Geoff Parker <geoffrey.parker@arthrex.com>
+Date: Fri, 9 Oct 2020 17:48:47 +0000
+Subject: [PATCH] libdmmp/Makefile: replace perl with sed in install target to
+ work with pseudo
+
+The multipath-tools libdmmp/Makefile install target uses 'perl -i' instead
+of 'sed -i' for string substitutions. The perl method creates a temporary file
+and overwrites the original which changes the inodes and corrupts the pseudo
+db. Changes to pseduo cause a build abort rather than allow possible bad
+ownership or permissions settings on the files. 'sed -i' is compatible
+with pseudo.
+
+Signed-off-by: Geoff Parker <geoffrey.parker@arthrex.com>
+---
+ libdmmp/Makefile | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/libdmmp/Makefile b/libdmmp/Makefile
+index 1dd3f340..8166075c 100644
+--- a/libdmmp/Makefile
++++ b/libdmmp/Makefile
+@@ -34,11 +34,11 @@ install:
+ $(LN) $(LIBS) $(DESTDIR)$(usrlibdir)/$(DEVLIB)
+ $(INSTALL_PROGRAM) -m 644 -D \
+ $(PKGFILE).in $(DESTDIR)$(pkgconfdir)/$(PKGFILE)
+- perl -i -pe 's|__VERSION__|$(LIBDMMP_VERSION)|g' \
++ sed -i 's|__VERSION__|$(LIBDMMP_VERSION)|g' \
+ $(DESTDIR)$(pkgconfdir)/$(PKGFILE)
+- perl -i -pe 's|__LIBDIR__|$(usrlibdir)|g' \
++ sed -i 's|__LIBDIR__|$(usrlibdir)|g' \
+ $(DESTDIR)$(pkgconfdir)/$(PKGFILE)
+- perl -i -pe 's|__INCLUDEDIR__|$(includedir)|g' \
++ sed -i 's|__INCLUDEDIR__|$(includedir)|g' \
+ $(DESTDIR)$(pkgconfdir)/$(PKGFILE)
+ @for file in docs/man/*.3.gz; do \
+ $(INSTALL_PROGRAM) -m 644 -D \
+--
+2.20.1
+