summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Correct-clang-compiler-flags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Correct-clang-compiler-flags.patch')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Correct-clang-compiler-flags.patch32
1 files changed, 0 insertions, 32 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Correct-clang-compiler-flags.patch b/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Correct-clang-compiler-flags.patch
deleted file mode 100644
index f1d037fae..000000000
--- a/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Correct-clang-compiler-flags.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 5ccaff351297bca0e254bbfd66e3f03fef9d9c75 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 10 Jan 2020 21:54:39 -0800
-Subject: [PATCH] Correct clang compiler flags
-
-Fix misplaced quotes, this was leading to spurious ; in compiler cmdline
-Remove demanding libc++, clang can link with both libc++ and libstdc++
-and platforms have their own defaults, user can demand non defaults via
-adding it to cmake flags
-
-Upstream-Status: Submitted [https://github.com/zaphoyd/websocketpp/pull/859]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 2d13117..c17354a 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -150,7 +150,7 @@ if (BUILD_TESTS OR BUILD_EXAMPLES)
- endif()
- set (WEBSOCKETPP_PLATFORM_TLS_LIBS ssl crypto)
- set (WEBSOCKETPP_BOOST_LIBS system thread)
-- set (CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS} "-std=c++0x -stdlib=libc++") # todo: is libc++ really needed here?
-+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
- if (NOT APPLE)
- add_definitions (-DNDEBUG -Wall -Wno-padded) # todo: should we use CMAKE_C_FLAGS for these?
- endif ()
---
-2.24.1
-