summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Correct-clang-compiler-flags.patch32
-rw-r--r--meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Replace-make_shared-with-new-in-some-cases.patch78
-rw-r--r--meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-cmake-Use-GNUInstallDirs.patch35
-rw-r--r--meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0002-Fix-missed-entries-fix-testing.patch66
-rw-r--r--meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/771.patch22
-rw-r--r--meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/842.patch30
-rw-r--r--meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/855.patch23
-rw-r--r--meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/857.patch132
8 files changed, 0 insertions, 418 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Correct-clang-compiler-flags.patch b/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Correct-clang-compiler-flags.patch
deleted file mode 100644
index f1d037fae..000000000
--- a/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Correct-clang-compiler-flags.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 5ccaff351297bca0e254bbfd66e3f03fef9d9c75 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 10 Jan 2020 21:54:39 -0800
-Subject: [PATCH] Correct clang compiler flags
-
-Fix misplaced quotes, this was leading to spurious ; in compiler cmdline
-Remove demanding libc++, clang can link with both libc++ and libstdc++
-and platforms have their own defaults, user can demand non defaults via
-adding it to cmake flags
-
-Upstream-Status: Submitted [https://github.com/zaphoyd/websocketpp/pull/859]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 2d13117..c17354a 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -150,7 +150,7 @@ if (BUILD_TESTS OR BUILD_EXAMPLES)
- endif()
- set (WEBSOCKETPP_PLATFORM_TLS_LIBS ssl crypto)
- set (WEBSOCKETPP_BOOST_LIBS system thread)
-- set (CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS} "-std=c++0x -stdlib=libc++") # todo: is libc++ really needed here?
-+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
- if (NOT APPLE)
- add_definitions (-DNDEBUG -Wall -Wno-padded) # todo: should we use CMAKE_C_FLAGS for these?
- endif ()
---
-2.24.1
-
diff --git a/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Replace-make_shared-with-new-in-some-cases.patch b/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Replace-make_shared-with-new-in-some-cases.patch
deleted file mode 100644
index 0c8285df9..000000000
--- a/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-Replace-make_shared-with-new-in-some-cases.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-From 080fc37949114184d4832f7acffe2613745833f3 Mon Sep 17 00:00:00 2001
-From: Stefan Floeren <42731906+stefan-floeren@users.noreply.github.com>
-Date: Tue, 16 Apr 2019 08:38:01 +0200
-Subject: [PATCH 1/2] Replace make_shared with new in some cases
-
-Replace make_shared for asio types that take a lib::ref as a parameter.
-This should fix the ASIO change (boostorg/asio@59066d8) for 1.70,
-while keeping it backwards compatible to older boost versions.
----
- websocketpp/transport/asio/connection.hpp | 7 ++++---
- websocketpp/transport/asio/endpoint.hpp | 3 +--
- websocketpp/transport/asio/security/none.hpp | 3 +--
- websocketpp/transport/asio/security/tls.hpp | 3 +--
- 4 files changed, 7 insertions(+), 9 deletions(-)
-
-diff --git a/websocketpp/transport/asio/connection.hpp b/websocketpp/transport/asio/connection.hpp
-index 60f88a7..1ccda8f 100644
---- a/websocketpp/transport/asio/connection.hpp
-+++ b/websocketpp/transport/asio/connection.hpp
-@@ -311,9 +311,10 @@ public:
- * needed.
- */
- timer_ptr set_timer(long duration, timer_handler callback) {
-- timer_ptr new_timer = lib::make_shared<lib::asio::steady_timer>(
-- lib::ref(*m_io_service),
-- lib::asio::milliseconds(duration)
-+ timer_ptr new_timer(
-+ new lib::asio::steady_timer(
-+ *m_io_service,
-+ lib::asio::milliseconds(duration))
- );
-
- if (config::enable_multithreading) {
-diff --git a/websocketpp/transport/asio/endpoint.hpp b/websocketpp/transport/asio/endpoint.hpp
-index ddab2c7..4b719a9 100644
---- a/websocketpp/transport/asio/endpoint.hpp
-+++ b/websocketpp/transport/asio/endpoint.hpp
-@@ -195,8 +195,7 @@ public:
-
- m_io_service = ptr;
- m_external_io_service = true;
-- m_acceptor = lib::make_shared<lib::asio::ip::tcp::acceptor>(
-- lib::ref(*m_io_service));
-+ m_acceptor.reset(new lib::asio::ip::tcp::acceptor(*m_io_service));
-
- m_state = READY;
- ec = lib::error_code();
-diff --git a/websocketpp/transport/asio/security/none.hpp b/websocketpp/transport/asio/security/none.hpp
-index 5c8293d..6c7d352 100644
---- a/websocketpp/transport/asio/security/none.hpp
-+++ b/websocketpp/transport/asio/security/none.hpp
-@@ -168,8 +168,7 @@ protected:
- return socket::make_error_code(socket::error::invalid_state);
- }
-
-- m_socket = lib::make_shared<lib::asio::ip::tcp::socket>(
-- lib::ref(*service));
-+ m_socket.reset(new lib::asio::ip::tcp::socket(*service));
-
- if (m_socket_init_handler) {
- m_socket_init_handler(m_hdl, *m_socket);
-diff --git a/websocketpp/transport/asio/security/tls.hpp b/websocketpp/transport/asio/security/tls.hpp
-index c76fd9a..04ac379 100644
---- a/websocketpp/transport/asio/security/tls.hpp
-+++ b/websocketpp/transport/asio/security/tls.hpp
-@@ -193,8 +193,7 @@ protected:
- if (!m_context) {
- return socket::make_error_code(socket::error::invalid_tls_context);
- }
-- m_socket = lib::make_shared<socket_type>(
-- _WEBSOCKETPP_REF(*service),lib::ref(*m_context));
-+ m_socket.reset(new socket_type(*service, *m_context));
-
- if (m_socket_init_handler) {
- m_socket_init_handler(m_hdl, get_socket());
---
-2.23.0
-
diff --git a/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-cmake-Use-GNUInstallDirs.patch b/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-cmake-Use-GNUInstallDirs.patch
deleted file mode 100644
index 0ef2e1237..000000000
--- a/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0001-cmake-Use-GNUInstallDirs.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 771d79eeb0ac5079482a4b3a131bbda744793e7d Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 19 Dec 2019 20:07:11 -0800
-Subject: [PATCH] cmake: Use GNUInstallDirs
-
-Helps install cmakefiles in right libdir
-
-Upstream-Status: Submitted [https://github.com/zaphoyd/websocketpp/pull/854]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- CMakeLists.txt | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 2786aba..080be3e 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -39,11 +39,13 @@ endif()
-
- set_property(GLOBAL PROPERTY USE_FOLDERS ON)
-
-+include(GNUInstallDirs)
-+
- set(INSTALL_INCLUDE_DIR include CACHE PATH "Installation directory for header files")
- if (WIN32 AND NOT CYGWIN)
- set (DEF_INSTALL_CMAKE_DIR cmake)
- else ()
-- set (DEF_INSTALL_CMAKE_DIR lib/cmake/websocketpp)
-+ set (DEF_INSTALL_CMAKE_DIR ${CMAKE_INSTALL_LIBDIR}/cmake/websocketpp)
- endif ()
- set (INSTALL_CMAKE_DIR ${DEF_INSTALL_CMAKE_DIR} CACHE PATH "Installation directory for CMake files")
-
---
-2.24.1
-
diff --git a/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0002-Fix-missed-entries-fix-testing.patch b/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0002-Fix-missed-entries-fix-testing.patch
deleted file mode 100644
index 962d08967..000000000
--- a/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/0002-Fix-missed-entries-fix-testing.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-From 12ab603ca962e83591985a585451d33544d75d56 Mon Sep 17 00:00:00 2001
-From: Stefan Floeren <42731906+stefan-floeren@users.noreply.github.com>
-Date: Wed, 17 Apr 2019 10:06:18 +0000
-Subject: [PATCH 2/2] Fix missed entries; fix testing
-
----
- CMakeLists.txt | 2 +-
- websocketpp/transport/asio/connection.hpp | 3 +--
- websocketpp/transport/asio/endpoint.hpp | 7 ++-----
- 3 files changed, 4 insertions(+), 8 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 2786aba..951de97 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -202,7 +202,7 @@ if (BUILD_TESTS OR BUILD_EXAMPLES)
- endif ()
-
- if (NOT Boost_USE_STATIC_LIBS)
-- add_definitions (/DBOOST_TEST_DYN_LINK)
-+ add_definitions (-DBOOST_TEST_DYN_LINK)
- endif ()
-
- set (Boost_FIND_REQUIRED TRUE)
-diff --git a/websocketpp/transport/asio/connection.hpp b/websocketpp/transport/asio/connection.hpp
-index 1ccda8f..57dda74 100644
---- a/websocketpp/transport/asio/connection.hpp
-+++ b/websocketpp/transport/asio/connection.hpp
-@@ -462,8 +462,7 @@ protected:
- m_io_service = io_service;
-
- if (config::enable_multithreading) {
-- m_strand = lib::make_shared<lib::asio::io_service::strand>(
-- lib::ref(*io_service));
-+ m_strand.reset(new lib::asio::io_service::strand(*io_service));
- }
-
- lib::error_code ec = socket_con_type::init_asio(io_service, m_strand,
-diff --git a/websocketpp/transport/asio/endpoint.hpp b/websocketpp/transport/asio/endpoint.hpp
-index 4b719a9..94509ad 100644
---- a/websocketpp/transport/asio/endpoint.hpp
-+++ b/websocketpp/transport/asio/endpoint.hpp
-@@ -687,9 +687,7 @@ public:
- * @since 0.3.0
- */
- void start_perpetual() {
-- m_work = lib::make_shared<lib::asio::io_service::work>(
-- lib::ref(*m_io_service)
-- );
-+ m_work.reset(new lib::asio::io_service::work(*m_io_service));
- }
-
- /// Clears the endpoint's perpetual flag, allowing it to exit when empty
-@@ -853,8 +851,7 @@ protected:
-
- // Create a resolver
- if (!m_resolver) {
-- m_resolver = lib::make_shared<lib::asio::ip::tcp::resolver>(
-- lib::ref(*m_io_service));
-+ m_resolver.reset(new lib::asio::ip::tcp::resolver(*m_io_service));
- }
-
- tcon->set_uri(u);
---
-2.23.0
-
diff --git a/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/771.patch b/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/771.patch
deleted file mode 100644
index bc65efb7d..000000000
--- a/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/771.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 4bccfb04a264704ec9b80ba332ee1cf113ce7f1b Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Wolfgang=20St=C3=B6ggl?= <c72578@yahoo.de>
-Date: Thu, 1 Nov 2018 20:58:10 +0100
-Subject: [PATCH] Update version number in CMakeLists.txt to 0.8.1
-
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 2786aba9..2d13117b 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -24,7 +24,7 @@ endif ()
- ############ Project name and version
- set (WEBSOCKETPP_MAJOR_VERSION 0)
- set (WEBSOCKETPP_MINOR_VERSION 8)
--set (WEBSOCKETPP_PATCH_VERSION 0)
-+set (WEBSOCKETPP_PATCH_VERSION 1)
- set (WEBSOCKETPP_VERSION ${WEBSOCKETPP_MAJOR_VERSION}.${WEBSOCKETPP_MINOR_VERSION}.${WEBSOCKETPP_PATCH_VERSION})
-
- if(POLICY CMP0048)
diff --git a/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/842.patch b/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/842.patch
deleted file mode 100644
index c3651e94a..000000000
--- a/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/842.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 7f7e2be01b4fa6580ce27f668e61adf37853ad67 Mon Sep 17 00:00:00 2001
-From: Schrijvers Luc <begasus@gmail.com>
-Date: Wed, 18 Sep 2019 11:35:43 +0200
-Subject: [PATCH] Fix "include" directory installation. the variable
- INSTALL_INCLUDE_DIR already exists, and defaults to include if not
- specificied otherwise. Using it allows people to customize the installation
- from outside, fixing issues with other OS like Haiku
-
-Signed-off-by: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
-Signed-off-by: Gianfranco Costamagna <locutusofborg@debian.org>
----
- cmake/CMakeHelpers.cmake | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/cmake/CMakeHelpers.cmake b/cmake/CMakeHelpers.cmake
-index 1478f4b..f603632 100644
---- a/cmake/CMakeHelpers.cmake
-+++ b/cmake/CMakeHelpers.cmake
-@@ -80,7 +80,7 @@ macro (final_target)
- endif ()
-
- install (DIRECTORY ${CMAKE_SOURCE_DIR}/${TARGET_NAME}
-- DESTINATION include/
-+ DESTINATION ${INSTALL_INCLUDE_DIR}/
- FILES_MATCHING PATTERN "*.hpp*")
- endmacro ()
-
---
-2.17.1
-
diff --git a/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/855.patch b/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/855.patch
deleted file mode 100644
index a1ee627b3..000000000
--- a/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/855.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 3590d77bb9753fbbf076028e2395182ced6466ba Mon Sep 17 00:00:00 2001
-From: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
-Date: Wed, 8 Jan 2020 17:59:48 +0100
-Subject: [PATCH] Fix cmake find boost with version >= 1.71
-
-For some reasons "system;thread;random;unit_test_framework" was seen as a single module, because of the quotes.
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 2d13117b..9a46bc10 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -213,7 +213,7 @@ if (BUILD_TESTS OR BUILD_EXAMPLES)
- set (Boost_USE_MULTITHREADED TRUE)
- set (Boost_ADDITIONAL_VERSIONS "1.39.0" "1.40.0" "1.41.0" "1.42.0" "1.43.0" "1.44.0" "1.46.1") # todo: someone who knows better spesify these!
-
-- find_package (Boost 1.39.0 COMPONENTS "${WEBSOCKETPP_BOOST_LIBS}")
-+ find_package (Boost 1.39.0 COMPONENTS ${WEBSOCKETPP_BOOST_LIBS})
-
- if (Boost_FOUND)
- # Boost is a project wide global dependency.
diff --git a/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/857.patch b/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/857.patch
deleted file mode 100644
index f221cd699..000000000
--- a/meta-openembedded/meta-oe/recipes-support/websocketpp/websocketpp-0.8.1/857.patch
+++ /dev/null
@@ -1,132 +0,0 @@
-From 931a55347a322f38eb82d5f387b2924e6c7a1746 Mon Sep 17 00:00:00 2001
-From: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
-Date: Thu, 9 Jan 2020 10:07:20 +0100
-Subject: [PATCH] Update SConstruct with new Python3 syntax: - new raise
- keyword syntax - has_key deprecated method is now removed - commands
- deprecated library is replaced by subprocess - print function fixes
-
-This should fix FTBFS against new scons 3.1.2
-https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=947584
----
- SConstruct | 45 +++++++++++++++++++++++----------------------
- 1 file changed, 23 insertions(+), 22 deletions(-)
-
-diff --git a/SConstruct b/SConstruct
-index ae3df10b..9d1c8914 100644
---- a/SConstruct
-+++ b/SConstruct
-@@ -1,18 +1,19 @@
--import os, sys, commands
-+import os, sys
-+from subprocess import check_output
- env = Environment(ENV = os.environ)
-
- # figure out a better way to configure this
--if os.environ.has_key('CXX'):
-+if 'CXX' in os.environ:
- env['CXX'] = os.environ['CXX']
-
--if os.environ.has_key('DEBUG'):
-+if 'DEBUG' in os.environ:
- env['DEBUG'] = os.environ['DEBUG']
-
--if os.environ.has_key('CXXFLAGS'):
-+if 'CXXFLAGS' in os.environ:
- #env['CXXFLAGS'] = os.environ['CXXFLAGS']
- env.Append(CXXFLAGS = os.environ['CXXFLAGS'])
-
--if os.environ.has_key('LINKFLAGS'):
-+if 'LINKFLAGS' in os.environ:
- #env['LDFLAGS'] = os.environ['LDFLAGS']
- env.Append(LINKFLAGS = os.environ['LINKFLAGS'])
-
-@@ -22,24 +23,24 @@ if os.environ.has_key('LINKFLAGS'):
- ## or set BOOST_INCLUDES and BOOST_LIBS if Boost comes with your OS distro e.g. and
- ## needs BOOST_INCLUDES=/usr/include/boost and BOOST_LIBS=/usr/lib like Ubuntu.
- ##
--if os.environ.has_key('BOOSTROOT'):
-+if 'BOOSTROOT' in os.environ:
- os.environ['BOOST_ROOT'] = os.environ['BOOSTROOT']
-
--if os.environ.has_key('BOOST_ROOT'):
-+if 'BOOST_ROOT' in os.environ:
- env['BOOST_INCLUDES'] = os.environ['BOOST_ROOT']
- env['BOOST_LIBS'] = os.path.join(os.environ['BOOST_ROOT'], 'stage', 'lib')
--elif os.environ.has_key('BOOST_INCLUDES') and os.environ.has_key('BOOST_LIBS'):
-+elif 'BOOST_INCLUDES' in os.environ and 'BOOST_LIBS' in os.environ:
- env['BOOST_INCLUDES'] = os.environ['BOOST_INCLUDES']
- env['BOOST_LIBS'] = os.environ['BOOST_LIBS']
- else:
-- raise SCons.Errors.UserError, "Neither BOOST_ROOT, nor BOOST_INCLUDES + BOOST_LIBS was set!"
-+ raise SCons.Errors.UserError("Neither BOOST_ROOT, nor BOOST_INCLUDES + BOOST_LIBS were set!")
-
- ## Custom OpenSSL
--if os.environ.has_key('OPENSSL_PATH'):
-+if 'OPENSSL_PATH' in os.environ:
- env.Append(CPPPATH = os.path.join(os.environ['OPENSSL_PATH'], 'include'))
- env.Append(LIBPATH = os.environ['OPENSSL_PATH'])
-
--if os.environ.has_key('WSPP_ENABLE_CPP11'):
-+if 'WSPP_ENABLE_CPP11' in os.environ:
- env['WSPP_ENABLE_CPP11'] = True
- else:
- env['WSPP_ENABLE_CPP11'] = False
-@@ -76,7 +77,7 @@ if env['PLATFORM'].startswith('win'):
- env['CCFLAGS'] = '%s /EHsc /GR /GS- /MD /nologo %s %s' % (warn_flags, arch_flags, opt_flags)
- env['LINKFLAGS'] = '/INCREMENTAL:NO /MANIFEST /NOLOGO /OPT:REF /OPT:ICF /MACHINE:X86'
- elif env['PLATFORM'] == 'posix':
-- if env.has_key('DEBUG'):
-+ if 'DEBUG' in env:
- env.Append(CCFLAGS = ['-g', '-O0'])
- else:
- env.Append(CPPDEFINES = ['NDEBUG'])
-@@ -84,9 +85,9 @@ elif env['PLATFORM'] == 'posix':
- env.Append(CCFLAGS = ['-Wall'])
- #env['LINKFLAGS'] = ''
- elif env['PLATFORM'] == 'darwin':
-- if not os.environ.has_key('CXX'):
-+ if not 'CXX' in os.environ:
- env['CXX'] = "clang++"
-- if env.has_key('DEBUG'):
-+ if 'DEBUG' in env:
- env.Append(CCFLAGS = ['-g', '-O0'])
- else:
- env.Append(CPPDEFINES = ['NDEBUG'])
-@@ -157,29 +158,29 @@ env_cpp11 = env.Clone ()
-
- if env_cpp11['CXX'].startswith('g++'):
- # TODO: check g++ version
-- GCC_VERSION = commands.getoutput(env_cpp11['CXX'] + ' -dumpversion')
-+ GCC_VERSION = check_output([env_cpp11['CXX'], '-dumpversion'])
-
-- if GCC_VERSION > "4.4.0":
-- print "C++11 build environment partially enabled"
-+ if GCC_VERSION.decode('utf-8') > "4.4.0":
-+ print("C++11 build environment partially enabled")
- env_cpp11.Append(WSPP_CPP11_ENABLED = "true",CXXFLAGS = ['-std=c++0x'],TOOLSET = ['g++'],CPPDEFINES = ['_WEBSOCKETPP_CPP11_STL_'])
- else:
-- print "C++11 build environment is not supported on this version of G++"
-+ print("C++11 build environment is not supported on this version of G++")
- elif env_cpp11['CXX'].startswith('clang++'):
-- print "C++11 build environment enabled"
-+ print("C++11 build environment enabled")
- env.Append(CXXFLANGS = ['-stdlib=libc++'],LINKFLAGS=['-stdlib=libc++'])
- env_cpp11.Append(WSPP_CPP11_ENABLED = "true",CXXFLAGS = ['-std=c++0x','-stdlib=libc++'],LINKFLAGS = ['-stdlib=libc++'],TOOLSET = ['clang++'],CPPDEFINES = ['_WEBSOCKETPP_CPP11_STL_'])
-
- # look for optional second boostroot compiled with clang's libc++ STL library
- # this prevents warnings/errors when linking code built with two different
- # incompatible STL libraries.
-- if os.environ.has_key('BOOST_ROOT_CPP11'):
-+ if 'BOOST_ROOT_CPP11' in os.environ:
- env_cpp11['BOOST_INCLUDES'] = os.environ['BOOST_ROOT_CPP11']
- env_cpp11['BOOST_LIBS'] = os.path.join(os.environ['BOOST_ROOT_CPP11'], 'stage', 'lib')
-- elif os.environ.has_key('BOOST_INCLUDES_CPP11') and os.environ.has_key('BOOST_LIBS_CPP11'):
-+ elif 'BOOST_INCLUDES_CPP11' in os.environ and 'BOOST_LIBS_CPP11' in os.environ:
- env_cpp11['BOOST_INCLUDES'] = os.environ['BOOST_INCLUDES_CPP11']
- env_cpp11['BOOST_LIBS'] = os.environ['BOOST_LIBS_CPP11']
- else:
-- print "C++11 build environment disabled"
-+ print("C++11 build environment disabled")
-
- # if the build system is known to allow the isystem modifier for library include
- # values then use it for the boost libraries. Otherwise just add them to the