summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/c-periphery/c-periphery_2.2.1.bb21
-rw-r--r--meta-openembedded/meta-oe/recipes-support/gd/gd_2.3.0.bb4
-rw-r--r--meta-openembedded/meta-oe/recipes-support/hwdata/hwdata_git.bb4
-rw-r--r--meta-openembedded/meta-oe/recipes-support/libgusb/libgusb/0001-generate-version-script-Don-t-hard-code-the-path-of-.patch53
-rw-r--r--meta-openembedded/meta-oe/recipes-support/libgusb/libgusb_0.3.4.bb (renamed from meta-openembedded/meta-oe/recipes-support/libgusb/libgusb_git.bb)7
-rw-r--r--meta-openembedded/meta-oe/recipes-support/libiio/libiio_git.bb4
-rw-r--r--meta-openembedded/meta-oe/recipes-support/lvm2/lvm2_2.03.06.bb8
-rw-r--r--meta-openembedded/meta-oe/recipes-support/mscgen/mscgen_0.20.bb2
-rw-r--r--meta-openembedded/meta-oe/recipes-support/multipath-tools/files/0001-fix-boolean-value-with-json-c-0.14.patch42
-rw-r--r--meta-openembedded/meta-oe/recipes-support/multipath-tools/multipath-tools_0.8.4.bb1
-rw-r--r--meta-openembedded/meta-oe/recipes-support/poppler/poppler_0.89.0.bb (renamed from meta-openembedded/meta-oe/recipes-support/poppler/poppler_0.88.0.bb)4
-rw-r--r--meta-openembedded/meta-oe/recipes-support/uchardet/uchardet_0.0.7.bb9
-rw-r--r--meta-openembedded/meta-oe/recipes-support/upower/upower_0.99.11.bb2
-rw-r--r--meta-openembedded/meta-oe/recipes-support/uriparser/uriparser_0.9.4.bb (renamed from meta-openembedded/meta-oe/recipes-support/uriparser/uriparser_0.9.3.bb)5
-rw-r--r--meta-openembedded/meta-oe/recipes-support/zchunk/zchunk/0001-zck.h-fix-build-on-musl.patch39
-rw-r--r--meta-openembedded/meta-oe/recipes-support/zchunk/zchunk/0002-unzck-fix-build-with-musl-libc.patch61
-rw-r--r--meta-openembedded/meta-oe/recipes-support/zchunk/zchunk_1.1.6.bb (renamed from meta-openembedded/meta-oe/recipes-support/zchunk/zchunk_1.1.5.bb)8
-rw-r--r--meta-openembedded/meta-oe/recipes-support/zile/zile_2.4.14.bb2
18 files changed, 153 insertions, 123 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/c-periphery/c-periphery_2.2.1.bb b/meta-openembedded/meta-oe/recipes-support/c-periphery/c-periphery_2.2.1.bb
new file mode 100644
index 000000000..b53cd6b19
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/c-periphery/c-periphery_2.2.1.bb
@@ -0,0 +1,21 @@
+SUMMURY = "C-Periphery lib used to access GPIO, LED, PWM, SPI, I2C, MMIO, Serial"
+DESCRIPTION = "A C library for peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO, Serial) in Linux"
+
+HOMEPAGE = "https://github.com/vsergeev/c-periphery"
+
+SECTION = "libs"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4097ec544cf01e9c7cfc4bdf8e4ed887"
+
+SRC_URI = "git://github.com/vsergeev/c-periphery;protocol=https"
+SRCREV = "c2aa7d164f87b807077daeeb3443a56b89e1d1c9"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON"
+
+BBCLASSEXTEND = "native nativesdk"
+
diff --git a/meta-openembedded/meta-oe/recipes-support/gd/gd_2.3.0.bb b/meta-openembedded/meta-oe/recipes-support/gd/gd_2.3.0.bb
index eec8a05ae..554e07fd3 100644
--- a/meta-openembedded/meta-oe/recipes-support/gd/gd_2.3.0.bb
+++ b/meta-openembedded/meta-oe/recipes-support/gd/gd_2.3.0.bb
@@ -35,7 +35,7 @@ EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
DEBUG_OPTIMIZATION_append = " -Wno-error=maybe-uninitialized"
-do_install_append() {
+do_install_append_class-target() {
# cleanup buildpaths from gdlib.pc
sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc
}
@@ -50,3 +50,5 @@ RPROVIDES_${PN}-tools = "${PN}-tools"
RDEPENDS_${PN}-tools = "perl perl-module-strict"
CVE_PRODUCT = "libgd"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-openembedded/meta-oe/recipes-support/hwdata/hwdata_git.bb b/meta-openembedded/meta-oe/recipes-support/hwdata/hwdata_git.bb
index 5f3e3f686..035a11c89 100644
--- a/meta-openembedded/meta-oe/recipes-support/hwdata/hwdata_git.bb
+++ b/meta-openembedded/meta-oe/recipes-support/hwdata/hwdata_git.bb
@@ -5,8 +5,8 @@ SECTION = "System/Base"
LICENSE = "GPL-2.0+"
LIC_FILES_CHKSUM = "file://LICENSE;md5=1556547711e8246992b999edd9445a57"
-PV = "0.333"
-SRCREV = "2de52be0d00015fa6cde70bb845fa9b86cf6f420"
+PV = "0.336"
+SRCREV = "e0e15bc7930f6d7befa4e7060fd03cc4935f6190"
SRC_URI = "git://github.com/vcrhonek/${BPN}.git"
S = "${WORKDIR}/git"
diff --git a/meta-openembedded/meta-oe/recipes-support/libgusb/libgusb/0001-generate-version-script-Don-t-hard-code-the-path-of-.patch b/meta-openembedded/meta-oe/recipes-support/libgusb/libgusb/0001-generate-version-script-Don-t-hard-code-the-path-of-.patch
new file mode 100644
index 000000000..41e64d7d8
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/libgusb/libgusb/0001-generate-version-script-Don-t-hard-code-the-path-of-.patch
@@ -0,0 +1,53 @@
+From 76c23503ed1002d3aad0118795006fe2128006ae Mon Sep 17 00:00:00 2001
+From: Ting-Wei Lan <lantw@src.gnome.org>
+Date: Sat, 21 Mar 2020 22:13:57 +0800
+Subject: [PATCH] generate-version-script: Don't hard-code the path of python3
+
+Python can be installed in different directories on different operating
+systems, so we can't hard-code the path of it. Instead, use meson to
+find it to avoid 'no such file or directory' error on the bad path.
+
+Upstream-Status: Backport [https://github.com/hughsie/libgusb/pull/36]
+Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
+---
+ contrib/generate-version-script.py | 1 -
+ gusb/meson.build | 4 ++++
+ 2 files changed, 4 insertions(+), 1 deletion(-)
+ mode change 100755 => 100644 contrib/generate-version-script.py
+
+diff --git a/contrib/generate-version-script.py b/contrib/generate-version-script.py
+old mode 100755
+new mode 100644
+index c4ee238ab0ab..0fe2b24e47e3
+--- a/contrib/generate-version-script.py
++++ b/contrib/generate-version-script.py
+@@ -1,4 +1,3 @@
+-#!/usr/bin/python3
+ # pylint: disable=invalid-name,missing-docstring
+ #
+ # Copyright (C) 2017 Richard Hughes <richard@hughsie.com>
+diff --git a/gusb/meson.build b/gusb/meson.build
+index 10a6f537a642..28ca3c63e595 100644
+--- a/gusb/meson.build
++++ b/gusb/meson.build
+@@ -142,6 +142,9 @@ libgusb_girtarget = gnome.generate_gir(gusb,
+ libgusb_gir = libgusb_girtarget[0]
+ libgusb_typelib = libgusb_girtarget[1]
+
++pymod = import('python')
++py_installation = pymod.find_installation('python3')
++
+ # Verify the map file is correct -- note we can't actually use the generated
+ # file for two reasons:
+ #
+@@ -154,6 +157,7 @@ mapfile_target = custom_target('gusb_mapfile',
+ input: libgusb_girtarget[0],
+ output: 'libgusb.ver',
+ command: [
++ py_installation,
+ join_paths(meson.source_root(), 'contrib', 'generate-version-script.py'),
+ 'LIBGUSB',
+ '@INPUT@',
+--
+2.17.1
+
diff --git a/meta-openembedded/meta-oe/recipes-support/libgusb/libgusb_git.bb b/meta-openembedded/meta-oe/recipes-support/libgusb/libgusb_0.3.4.bb
index e3c0bdd15..bd88c8ed4 100644
--- a/meta-openembedded/meta-oe/recipes-support/libgusb/libgusb_git.bb
+++ b/meta-openembedded/meta-oe/recipes-support/libgusb/libgusb_0.3.4.bb
@@ -6,7 +6,8 @@ DEPENDS = "glib-2.0 libusb"
inherit meson gobject-introspection gtk-doc gettext vala
-SRC_URI = "git://github.com/hughsie/libgusb.git"
-SRCREV = "636efc0624aa2a88174220fcabc9764c13d7febf"
-PV = "0.3.0+git${SRCPV}"
+SRC_URI = "git://github.com/hughsie/libgusb.git \
+ file://0001-generate-version-script-Don-t-hard-code-the-path-of-.patch \
+ "
+SRCREV = "377917fed85476d615f72279d0c97bc391d0f191"
S = "${WORKDIR}/git"
diff --git a/meta-openembedded/meta-oe/recipes-support/libiio/libiio_git.bb b/meta-openembedded/meta-oe/recipes-support/libiio/libiio_git.bb
index f83d9c922..d12fac633 100644
--- a/meta-openembedded/meta-oe/recipes-support/libiio/libiio_git.bb
+++ b/meta-openembedded/meta-oe/recipes-support/libiio/libiio_git.bb
@@ -4,8 +4,8 @@ SECTION = "libs"
LICENSE = "LGPLv2.1+"
LIC_FILES_CHKSUM = "file://COPYING.txt;md5=7c13b3376cea0ce68d2d2da0a1b3a72c"
-SRCREV = "5f5af2e417129ad8f4e05fc5c1b730f0694dca12"
-PV = "0.19+git${SRCPV}"
+SRCREV = "26c5be5ae37334abf3021b52d27f84aa6a6b1842"
+PV = "0.20+git${SRCPV}"
SRC_URI = "git://github.com/analogdevicesinc/libiio.git;protocol=https"
UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
diff --git a/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2_2.03.06.bb b/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2_2.03.06.bb
index e2b551bbc..bc86810ec 100644
--- a/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2_2.03.06.bb
+++ b/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2_2.03.06.bb
@@ -32,7 +32,7 @@ PACKAGE_BEFORE_PN = "${PN}-scripts ${PN}-udevrules"
SYSTEMD_PACKAGES = "${PN}"
SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'dmeventd', 'lvm2-monitor.service dm-event.socket dm-event.service', '', d)} \
- blk-availability.service lvm2-pvscan@.service"
+ blk-availability.service"
SYSTEMD_AUTO_ENABLE = "disable"
TARGET_CC_ARCH += "${LDFLAGS}"
@@ -52,7 +52,11 @@ FILES_libdevmapper = " \
${sbindir}/dmstats \
"
-FILES_${PN} += "${libdir}/device-mapper/*.so"
+FILES_${PN} += " \
+ ${libdir}/device-mapper/*.so \
+ ${systemd_system_unitdir}/lvm2-pvscan@.service \
+"
+
FILES_${PN}-scripts = " \
${sbindir}/blkdeactivate \
${sbindir}/fsadm \
diff --git a/meta-openembedded/meta-oe/recipes-support/mscgen/mscgen_0.20.bb b/meta-openembedded/meta-oe/recipes-support/mscgen/mscgen_0.20.bb
index 276ad201f..49899edd7 100644
--- a/meta-openembedded/meta-oe/recipes-support/mscgen/mscgen_0.20.bb
+++ b/meta-openembedded/meta-oe/recipes-support/mscgen/mscgen_0.20.bb
@@ -16,3 +16,5 @@ inherit autotools gettext
do_configure_prepend() {
sed -i "s#AC_PATH_PROG(GDLIB_CONFIG,gdlib-config)#AC_PATH_PROG([GDLIB_CONFIG],[gdlib-config], ,[${STAGING_BINDIR_CROSS}])#" ${S}/configure.ac
}
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-openembedded/meta-oe/recipes-support/multipath-tools/files/0001-fix-boolean-value-with-json-c-0.14.patch b/meta-openembedded/meta-oe/recipes-support/multipath-tools/files/0001-fix-boolean-value-with-json-c-0.14.patch
new file mode 100644
index 000000000..cf97b491e
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/multipath-tools/files/0001-fix-boolean-value-with-json-c-0.14.patch
@@ -0,0 +1,42 @@
+From 5ae81386a8cfea4180738c261cd3f7944a631199 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 3 Jun 2020 16:03:56 -0700
+Subject: [PATCH] fix boolean value with json-c 0.14
+
+Patch from Christian Hesse posted here
+https://www.spinics.net/lists/dm-devel/msg40646.html
+
+Upstream json-c 0.14+ removed the TRUE and FALSE defines in commit
+0992aac61f8b087efd7094e9ac2b84fa9c040fcd.
+
+Upstream-Status: Submitted [https://www.spinics.net/lists/dm-devel/msg40646.html]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ libdmmp/libdmmp_private.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/libdmmp/libdmmp_private.h b/libdmmp/libdmmp_private.h
+index ac85b63f..29400826 100644
+--- a/libdmmp/libdmmp_private.h
++++ b/libdmmp/libdmmp_private.h
+@@ -82,7 +82,7 @@ static out_type func_name(struct dmmp_context *ctx, const char *var_name) { \
+ do { \
+ json_type j_type = json_type_null; \
+ json_object *j_obj_tmp = NULL; \
+- if (json_object_object_get_ex(j_obj, key, &j_obj_tmp) != TRUE) { \
++ if (json_object_object_get_ex(j_obj, key, &j_obj_tmp) != 1) { \
+ _error(ctx, "Invalid JSON output from multipathd IPC: " \
+ "key '%s' not found", key); \
+ rc = DMMP_ERR_IPC_ERROR; \
+@@ -90,7 +90,7 @@ do { \
+ } \
+ if (j_obj_tmp == NULL) { \
+ _error(ctx, "BUG: Got NULL j_obj_tmp from " \
+- "json_object_object_get_ex() while it return TRUE"); \
++ "json_object_object_get_ex() while it return 1"); \
+ rc = DMMP_ERR_BUG; \
+ goto out; \
+ } \
+--
+2.27.0
+
diff --git a/meta-openembedded/meta-oe/recipes-support/multipath-tools/multipath-tools_0.8.4.bb b/meta-openembedded/meta-oe/recipes-support/multipath-tools/multipath-tools_0.8.4.bb
index af34a4b39..0d0319137 100644
--- a/meta-openembedded/meta-oe/recipes-support/multipath-tools/multipath-tools_0.8.4.bb
+++ b/meta-openembedded/meta-oe/recipes-support/multipath-tools/multipath-tools_0.8.4.bb
@@ -45,6 +45,7 @@ SRC_URI = "git://git.opensvc.com/multipath-tools/.git;protocol=http \
file://0031-Always-use-devmapper-for-kpartx.patch \
file://0001-fix-bug-of-do_compile-and-do_install.patch \
file://0001-add-explicit-dependency-on-libraries.patch \
+ file://0001-fix-boolean-value-with-json-c-0.14.patch \
"
LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
diff --git a/meta-openembedded/meta-oe/recipes-support/poppler/poppler_0.88.0.bb b/meta-openembedded/meta-oe/recipes-support/poppler/poppler_0.89.0.bb
index d6a27f923..f8b7c075a 100644
--- a/meta-openembedded/meta-oe/recipes-support/poppler/poppler_0.88.0.bb
+++ b/meta-openembedded/meta-oe/recipes-support/poppler/poppler_0.89.0.bb
@@ -7,8 +7,8 @@ SRC_URI = "http://poppler.freedesktop.org/${BP}.tar.xz \
file://0001-Do-not-overwrite-all-our-build-flags.patch \
file://basename-include.patch \
"
-SRC_URI[md5sum] = "d9aafddce4c079c9ebc7405e42ac25ba"
-SRC_URI[sha256sum] = "b4453804e9a5a519e6ceee0ac8f5efc229e3b0bf70419263c239124474d256c7"
+SRC_URI[md5sum] = "92ac57f60ae8c3a1f8bfe01c9530b7b5"
+SRC_URI[sha256sum] = "fba230364537782cc5d43b08d693ef69c36586286349683c7b127156a8ef9b5c"
DEPENDS = "fontconfig zlib cairo lcms glib-2.0"
diff --git a/meta-openembedded/meta-oe/recipes-support/uchardet/uchardet_0.0.7.bb b/meta-openembedded/meta-oe/recipes-support/uchardet/uchardet_0.0.7.bb
new file mode 100644
index 000000000..4a595e643
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/uchardet/uchardet_0.0.7.bb
@@ -0,0 +1,9 @@
+SUMMARY = "uchardet is an encoding detector library"
+LICENSE = "MPLv1.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6ecda54f6f525388d71d6b3cd92f7474"
+
+inherit cmake
+
+SRC_URI = "https://www.freedesktop.org/software/uchardet/releases/uchardet-0.0.7.tar.xz"
+SRC_URI[md5sum] = "623406dac5c5ad89e40eedd7f279efae"
+SRC_URI[sha256sum] = "3fc79408ae1d84b406922fa9319ce005631c95ca0f34b205fad867e8b30e45b1"
diff --git a/meta-openembedded/meta-oe/recipes-support/upower/upower_0.99.11.bb b/meta-openembedded/meta-oe/recipes-support/upower/upower_0.99.11.bb
index 640841792..d6c89a65d 100644
--- a/meta-openembedded/meta-oe/recipes-support/upower/upower_0.99.11.bb
+++ b/meta-openembedded/meta-oe/recipes-support/upower/upower_0.99.11.bb
@@ -10,7 +10,7 @@ SRC_URI = " \
SRC_URI[md5sum] = "abe6acb617f11f2e8dbd9846fcf86e24"
SRC_URI[sha256sum] = "64b5ffbfccd5bdb15d925777979a4dbee1a957f9eaeb158dc76175267eddbdef"
-inherit autotools pkgconfig gettext gobject-introspection systemd features_check
+inherit autotools pkgconfig gettext gobject-introspection systemd
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
PACKAGECONFIG[idevice] = "--with-idevice,--without-idevice,libimobiledevice libplist"
diff --git a/meta-openembedded/meta-oe/recipes-support/uriparser/uriparser_0.9.3.bb b/meta-openembedded/meta-oe/recipes-support/uriparser/uriparser_0.9.4.bb
index da52bb5a3..d02cf5de8 100644
--- a/meta-openembedded/meta-oe/recipes-support/uriparser/uriparser_0.9.3.bb
+++ b/meta-openembedded/meta-oe/recipes-support/uriparser/uriparser_0.9.4.bb
@@ -2,11 +2,10 @@ SUMMARY = "RFC 3986 compliant URI parsing library"
HOMEPAGE = "https://uriparser.github.io"
LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://COPYING;md5=fc3bbde670fc6e95392a0e23bf57bda0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fcc5a53146c2401f4b4f6a3bdf3f0168"
SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${BP}/${BP}.tar.gz"
-SRC_URI[md5sum] = "9874b64f6f4ff656f3f69598e38f12b7"
-SRC_URI[sha256sum] = "6cef39d6eaf1a48504ee0264ce85f078758057dafb1edd0a898183b55ff76014"
+SRC_URI[sha256sum] = "095e8a358a9ccbbef9d1f10d40495ca0fcb3d4490a948ba6449b213a66e08ef0"
UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases"
diff --git a/meta-openembedded/meta-oe/recipes-support/zchunk/zchunk/0001-zck.h-fix-build-on-musl.patch b/meta-openembedded/meta-oe/recipes-support/zchunk/zchunk/0001-zck.h-fix-build-on-musl.patch
deleted file mode 100644
index 64e0e8ed6..000000000
--- a/meta-openembedded/meta-oe/recipes-support/zchunk/zchunk/0001-zck.h-fix-build-on-musl.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 78247d478cec254bad27f4ed97b532f4f54bf1b0 Mon Sep 17 00:00:00 2001
-From: Pierre-Jean Texier <pjtexier@koncepto.io>
-Date: Thu, 23 Jan 2020 19:14:40 +0100
-Subject: [PATCH 1/2] zck.h: fix build on musl
-
-The ssize_t type requires the <sys/types.h> header. This fixes build with musl
-libc:
-
-include/zck.h:68:1: error: unknown type name 'ssize_t'; did you mean 'size_t'?
- 68 | ssize_t zck_read(zckCtx *zck, char *dst, size_t dst_size)
- | ^~~~~~~
- | size_t
-include/zck.h:81:1: error: unknown type name 'ssize_t'; did you mean 'size_t'?
- 81 | ssize_t zck_write(zckCtx *zck, const char *src, const size_t src_size)
- | ^~~~~~~
- | size_t
-
-Upstream-Status: Submitted [https://github.com/zchunk/zchunk/pull/23]
-
-Signed-off-by: Pierre-Jean Texier <pjtexier@koncepto.io>
----
- include/zck.h.in | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/include/zck.h.in b/include/zck.h.in
-index 91d2557..b847576 100644
---- a/include/zck.h.in
-+++ b/include/zck.h.in
-@@ -5,6 +5,7 @@
-
- #include <stdlib.h>
- #include <stdbool.h>
-+#include <sys/types.h>
-
- typedef enum zck_hash {
- ZCK_HASH_SHA1,
---
-2.7.4
-
diff --git a/meta-openembedded/meta-oe/recipes-support/zchunk/zchunk/0002-unzck-fix-build-with-musl-libc.patch b/meta-openembedded/meta-oe/recipes-support/zchunk/zchunk/0002-unzck-fix-build-with-musl-libc.patch
deleted file mode 100644
index a1c95bf36..000000000
--- a/meta-openembedded/meta-oe/recipes-support/zchunk/zchunk/0002-unzck-fix-build-with-musl-libc.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From 72c55e3da59eccdfea3778d11f83862b58af723d Mon Sep 17 00:00:00 2001
-From: Pierre-Jean Texier <pjtexier@koncepto.io>
-Date: Thu, 23 Jan 2020 22:42:40 +0100
-Subject: [PATCH 2/2] unzck: fix build with musl libc
-
-On musl libc "stdout" is a preprocessor macro whose expansion leads to
-compilation errors.
-
-Fixes:
-
-| In file included from ../git/src/unzck.c:31:
-| ../git/src/unzck.c: In function 'parse_opt':
-| ../git/src/unzck.c:78:24: error: expected identifier before '(' token
-| 78 | arguments->stdout = true;
-| | ^~~~~~
-| ../git/src/unzck.c: In function 'main':
-| ../git/src/unzck.c:141:20: error: expected identifier before '(' token
-| 141 | if(!(arguments.stdout)) {
-| | ^~~~~~
-
-Upstream-Status: Submitted [https://github.com/zchunk/zchunk/pull/23]
-
-Signed-off-by: Pierre-Jean Texier <pjtexier@koncepto.io>
----
- src/unzck.c | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/unzck.c b/src/unzck.c
-index 8d6c62a..002492c 100644
---- a/src/unzck.c
-+++ b/src/unzck.c
-@@ -58,7 +58,7 @@ struct arguments {
- char *args[1];
- zck_log_type log_level;
- bool dict;
-- bool stdout;
-+ bool stdOut;
- bool exit;
- };
-
-@@ -75,7 +75,7 @@ static error_t parse_opt (int key, char *arg, struct argp_state *state) {
- arguments->log_level = ZCK_LOG_DDEBUG;
- break;
- case 'c':
-- arguments->stdout = true;
-+ arguments->stdOut = true;
- break;
- case 'V':
- version();
-@@ -138,7 +138,7 @@ int main (int argc, char *argv[]) {
- snprintf(out_name + strlen(base_name) - 4, 7, ".zdict");
-
- int dst_fd = STDOUT_FILENO;
-- if(!arguments.stdout) {
-+ if(!arguments.stdOut) {
- dst_fd = open(out_name, O_TRUNC | O_WRONLY | O_CREAT, 0666);
- if(dst_fd < 0) {
- dprintf(STDERR_FILENO, "Unable to open %s", out_name);
---
-2.7.4
-
diff --git a/meta-openembedded/meta-oe/recipes-support/zchunk/zchunk_1.1.5.bb b/meta-openembedded/meta-oe/recipes-support/zchunk/zchunk_1.1.6.bb
index f75412f49..e041132b1 100644
--- a/meta-openembedded/meta-oe/recipes-support/zchunk/zchunk_1.1.5.bb
+++ b/meta-openembedded/meta-oe/recipes-support/zchunk/zchunk_1.1.6.bb
@@ -4,13 +4,9 @@ AUTHOR = "Jonathan Dieter"
LICENSE = "BSD-2-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=cd6e590282010ce90a94ef25dd31410f"
-SRC_URI = " \
- git://github.com/zchunk/zchunk.git;protocol=https \
- file://0001-zck.h-fix-build-on-musl.patch \
- file://0002-unzck-fix-build-with-musl-libc.patch \
- "
+SRC_URI = "git://github.com/zchunk/zchunk.git;protocol=https"
-SRCREV = "c01bf12feede792982f165f52f4a6c573e3a8c17"
+SRCREV = "f5593aa11584faa691c81b4898f0aaded47f8bf7"
S = "${WORKDIR}/git"
DEPENDS = "\
diff --git a/meta-openembedded/meta-oe/recipes-support/zile/zile_2.4.14.bb b/meta-openembedded/meta-oe/recipes-support/zile/zile_2.4.14.bb
index 3b846c151..acd491498 100644
--- a/meta-openembedded/meta-oe/recipes-support/zile/zile_2.4.14.bb
+++ b/meta-openembedded/meta-oe/recipes-support/zile/zile_2.4.14.bb
@@ -20,6 +20,6 @@ do_install_append() {
}
PACKAGECONFIG ??= ""
-PACKAGECONFIG += "${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)}"
+PACKAGECONFIG_append = " ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)}"
PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"