summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/ccid/ccid/0001-Add-build-rule-for-README.patch22
-rw-r--r--meta-openembedded/meta-oe/recipes-support/ccid/ccid_1.4.31.bb (renamed from meta-openembedded/meta-oe/recipes-support/ccid/ccid_1.4.30.bb)5
-rw-r--r--meta-openembedded/meta-oe/recipes-support/libssh2/libssh2_1.9.0.bb (renamed from meta-openembedded/meta-oe/recipes-support/libssh2/libssh2_1.8.2.bb)8
-rw-r--r--meta-openembedded/meta-oe/recipes-support/lvm2/files/0001-configure-Fix-setting-of-CLDFLAGS-default.patch78
-rw-r--r--meta-openembedded/meta-oe/recipes-support/lvm2/libdevmapper_2.03.06.bb (renamed from meta-openembedded/meta-oe/recipes-support/lvm2/libdevmapper_2.03.05.bb)0
-rw-r--r--meta-openembedded/meta-oe/recipes-support/lvm2/lvm2.inc3
-rw-r--r--meta-openembedded/meta-oe/recipes-support/lvm2/lvm2/0001-activation-add-synchronization-point.patch82
-rw-r--r--meta-openembedded/meta-oe/recipes-support/lvm2/lvm2/0001-udev-remove-unsupported-OPTIONS-event_timeout-rule.patch39
-rw-r--r--meta-openembedded/meta-oe/recipes-support/lvm2/lvm2/0002-activation-extend-handling-of-pending_delete.patch124
-rw-r--r--meta-openembedded/meta-oe/recipes-support/lvm2/lvm2/0003-snapshot-always-activate.patch40
-rw-r--r--meta-openembedded/meta-oe/recipes-support/lvm2/lvm2_2.03.06.bb (renamed from meta-openembedded/meta-oe/recipes-support/lvm2/lvm2_2.03.05.bb)4
-rw-r--r--meta-openembedded/meta-oe/recipes-support/mcelog/mce-test_git.bb4
-rw-r--r--meta-openembedded/meta-oe/recipes-support/mcelog/mcelog_165.bb (renamed from meta-openembedded/meta-oe/recipes-support/mcelog/mcelog_164.bb)2
-rw-r--r--meta-openembedded/meta-oe/recipes-support/syslog-ng/files/0001-syslog-ng-fix-segment-fault-during-service-start.patch27
-rw-r--r--meta-openembedded/meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch44
-rw-r--r--meta-openembedded/meta-oe/recipes-support/syslog-ng/files/syslog-ng.service-the-syslog-ng-service.patch24
-rw-r--r--meta-openembedded/meta-oe/recipes-support/syslog-ng/syslog-ng.inc1
-rw-r--r--meta-openembedded/meta-oe/recipes-support/syslog-ng/syslog-ng_3.24.1.bb (renamed from meta-openembedded/meta-oe/recipes-support/syslog-ng/syslog-ng_3.19.1.bb)4
18 files changed, 83 insertions, 428 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/ccid/ccid/0001-Add-build-rule-for-README.patch b/meta-openembedded/meta-oe/recipes-support/ccid/ccid/0001-Add-build-rule-for-README.patch
new file mode 100644
index 000000000..586ff18c3
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/ccid/ccid/0001-Add-build-rule-for-README.patch
@@ -0,0 +1,22 @@
+Subject: [PATCH] Add build rule for README.
+
+fix do_configure error:
+Makefile.am: required file `./README' not found
+
+Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
+---
+ Makefile.am | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.am b/Makefile.am
+index 49574a3..a5a7c2a 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -26,3 +26,4 @@ libtool: $(LIBTOOL_DEPS)
+ ChangeLog:
+ git log --stat --decorate=short > $@
+
++README: README.md
+--
+2.7.4
+
diff --git a/meta-openembedded/meta-oe/recipes-support/ccid/ccid_1.4.30.bb b/meta-openembedded/meta-oe/recipes-support/ccid/ccid_1.4.31.bb
index 95a41d2f7..de07bfd23 100644
--- a/meta-openembedded/meta-oe/recipes-support/ccid/ccid_1.4.30.bb
+++ b/meta-openembedded/meta-oe/recipes-support/ccid/ccid_1.4.31.bb
@@ -8,10 +8,11 @@ RDEPENDS_${PN} = "pcsc-lite"
SRC_URI = "https://ccid.apdu.fr/files/ccid-${PV}.tar.bz2 \
file://no-dep-on-libfl.patch \
+ file://0001-Add-build-rule-for-README.patch \
"
-SRC_URI[md5sum] = "817abceef715e02cb47617621fe192e0"
-SRC_URI[sha256sum] = "ac17087be08880a0cdf99a8a2799a4ef004dc6ffa08b4d9b0ad995f39a53ff7c"
+SRC_URI[md5sum] = "e4690f3362f95adb2332fd47a2b08212"
+SRC_URI[sha256sum] = "6b48d7b6e4390e038d25630f8664fe81618ab00f232d6efbe0e3cc6df28ce8f7"
inherit autotools pkgconfig
diff --git a/meta-openembedded/meta-oe/recipes-support/libssh2/libssh2_1.8.2.bb b/meta-openembedded/meta-oe/recipes-support/libssh2/libssh2_1.9.0.bb
index 6428958f9..25e0af3ff 100644
--- a/meta-openembedded/meta-oe/recipes-support/libssh2/libssh2_1.8.2.bb
+++ b/meta-openembedded/meta-oe/recipes-support/libssh2/libssh2_1.9.0.bb
@@ -9,8 +9,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=c5cf34fc0acb44b082ef50ef5e4354ca"
SRC_URI = "http://www.libssh2.org/download/${BP}.tar.gz"
-SRC_URI[md5sum] = "616efd99af3d9ef731a26bed6cee9593"
-SRC_URI[sha256sum] = "088307d9f6b6c4b8c13f34602e8ff65d21c2dc4d55284dfe15d502c4ee190d67"
+SRC_URI[md5sum] = "1beefafe8963982adc84b408b2959927"
+SRC_URI[sha256sum] = "d5fb8bd563305fd1074dda90bd053fb2d29fc4bce048d182f96eaa466dfadafd"
inherit autotools pkgconfig
@@ -21,7 +21,7 @@ EXTRA_OECONF += "\
# only one of openssl and gcrypt could be set
PACKAGECONFIG ??= "openssl"
-PACKAGECONFIG[openssl] = "--with-openssl --with-libssl-prefix=${STAGING_LIBDIR},--without-openssl,openssl"
-PACKAGECONFIG[gcrypt] = "--with-libgcrypt --with-libgcrypt-prefix=${STAGING_EXECPREFIXDIR},--without-libgcrypt,libgcrypt"
+PACKAGECONFIG[openssl] = "--with-crypto=openssl --with-libssl-prefix=${STAGING_LIBDIR}, , openssl"
+PACKAGECONFIG[gcrypt] = "--with-crypto=libgcrypt --with-libgcrypt-prefix=${STAGING_EXECPREFIXDIR}, , libgcrypt"
BBCLASSEXTEND = "native"
diff --git a/meta-openembedded/meta-oe/recipes-support/lvm2/files/0001-configure-Fix-setting-of-CLDFLAGS-default.patch b/meta-openembedded/meta-oe/recipes-support/lvm2/files/0001-configure-Fix-setting-of-CLDFLAGS-default.patch
deleted file mode 100644
index 07cb88ffb..000000000
--- a/meta-openembedded/meta-oe/recipes-support/lvm2/files/0001-configure-Fix-setting-of-CLDFLAGS-default.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-From 4a3e707402032788e09282e0f54fdf82c8a0f8fc Mon Sep 17 00:00:00 2001
-From: Marian Csontos <mcsontos@redhat.com>
-Date: Mon, 19 Aug 2019 14:54:43 +0200
-Subject: [PATCH] configure: Fix setting of CLDFLAGS default
-
----
- configure | 6 +++---
- configure.ac | 6 +++---
- 2 files changed, 6 insertions(+), 6 deletions(-)
-
-Upstream-Status: Backport [https://sourceware.org/git/?p=lvm2.git;a=commit;h=4a3e707402032788e09282e0f54fdf82c8a0f8fc]
-Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
-
-diff --git a/configure b/configure
-index ff3a59b6b..4c8476502 100755
---- a/configure
-+++ b/configure
-@@ -3077,7 +3077,7 @@ if test -z "$CFLAGS"; then :
- fi
- case "$host_os" in
- linux*)
-- CLDFLAGS="${CLDFLAGS:"$LDFLAGS"} -Wl,--version-script,.export.sym"
-+ CLDFLAGS="${CLDFLAGS-"$LDFLAGS"} -Wl,--version-script,.export.sym"
- # equivalent to -rdynamic
- ELDFLAGS="-Wl,--export-dynamic"
- # FIXME Generate list and use --dynamic-list=.dlopen.sym
-@@ -3098,7 +3098,7 @@ case "$host_os" in
- ;;
- darwin*)
- CFLAGS="$CFLAGS -no-cpp-precomp -fno-common"
-- CLDFLAGS="${CLDFLAGS:"$LDFLAGS"}"
-+ CLDFLAGS="${CLDFLAGS-"$LDFLAGS"}"
- ELDFLAGS=
- CLDWHOLEARCHIVE="-all_load"
- CLDNOWHOLEARCHIVE=
-@@ -3111,7 +3111,7 @@ case "$host_os" in
- BLKDEACTIVATE=no
- ;;
- *)
-- CLDFLAGS="${CLDFLAGS:"$LDFLAGS"}"
-+ CLDFLAGS="${CLDFLAGS-"$LDFLAGS"}"
- ;;
- esac
-
-diff --git a/configure.ac b/configure.ac
-index 5da694631..830edb8da 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -30,7 +30,7 @@ AC_CANONICAL_TARGET([])
- AS_IF([test -z "$CFLAGS"], [COPTIMISE_FLAG="-O2"])
- case "$host_os" in
- linux*)
-- CLDFLAGS="${CLDFLAGS:"$LDFLAGS"} -Wl,--version-script,.export.sym"
-+ CLDFLAGS="${CLDFLAGS-"$LDFLAGS"} -Wl,--version-script,.export.sym"
- # equivalent to -rdynamic
- ELDFLAGS="-Wl,--export-dynamic"
- # FIXME Generate list and use --dynamic-list=.dlopen.sym
-@@ -51,7 +51,7 @@ case "$host_os" in
- ;;
- darwin*)
- CFLAGS="$CFLAGS -no-cpp-precomp -fno-common"
-- CLDFLAGS="${CLDFLAGS:"$LDFLAGS"}"
-+ CLDFLAGS="${CLDFLAGS-"$LDFLAGS"}"
- ELDFLAGS=
- CLDWHOLEARCHIVE="-all_load"
- CLDNOWHOLEARCHIVE=
-@@ -64,7 +64,7 @@ case "$host_os" in
- BLKDEACTIVATE=no
- ;;
- *)
-- CLDFLAGS="${CLDFLAGS:"$LDFLAGS"}"
-+ CLDFLAGS="${CLDFLAGS-"$LDFLAGS"}"
- ;;
- esac
-
---
-2.21.0
-
diff --git a/meta-openembedded/meta-oe/recipes-support/lvm2/libdevmapper_2.03.05.bb b/meta-openembedded/meta-oe/recipes-support/lvm2/libdevmapper_2.03.06.bb
index be558ce1d..be558ce1d 100644
--- a/meta-openembedded/meta-oe/recipes-support/lvm2/libdevmapper_2.03.05.bb
+++ b/meta-openembedded/meta-oe/recipes-support/lvm2/libdevmapper_2.03.06.bb
diff --git a/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2.inc b/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2.inc
index 41bf78a3f..01c9df45c 100644
--- a/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2.inc
+++ b/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2.inc
@@ -15,9 +15,8 @@ SRC_URI = "git://sourceware.org/git/lvm2.git \
file://0001-Avoid-bashisms-in-init-scripts.patch \
file://0005-do-not-build-manual.patch \
file://0006-start-lvm2-monitor.service-after-tmp.mount.patch \
- file://0001-configure-Fix-setting-of-CLDFLAGS-default.patch \
"
-SRCREV = "60bd9e8406ac28a04aa5e8165149f7a5d4f3265a"
+SRCREV = "b9391b1b9f0b73303fa21f8f92574d17ce4c2b02"
S = "${WORKDIR}/git"
inherit autotools-brokensep pkgconfig systemd license
diff --git a/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2/0001-activation-add-synchronization-point.patch b/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2/0001-activation-add-synchronization-point.patch
deleted file mode 100644
index a864f1e21..000000000
--- a/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2/0001-activation-add-synchronization-point.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-From f8466749dd73f5b0ccf4fc86c8a7585c4140b3f9 Mon Sep 17 00:00:00 2001
-From: Zdenek Kabelac <zkabelac@redhat.com>
-Date: Fri, 16 Aug 2019 23:49:59 +0200
-Subject: [PATCH 1/3] activation: add synchronization point
-
-Resuming of 'error' table entry followed with it's dirrect removal
-is now troublesame with latest udev as it may skip processing of
-udev rules for already 'dropped' device nodes.
-
-As we cannot 'synchronize' with udev while we know we have devices
-in suspended state - rework 'cleanup' so it collects nodes
-for removal into pending_delete list and process the list with
-synchronization once we are without any suspended nodes.
-
-Upstream-Status: Backport
-Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
----
- WHATS_NEW | 9 +++++++++
- lib/activate/dev_manager.c | 20 ++++++++++++--------
- 2 files changed, 21 insertions(+), 8 deletions(-)
-
-diff --git a/WHATS_NEW b/WHATS_NEW
-index 3a58de5f9..0b48e032b 100644
---- a/WHATS_NEW
-+++ b/WHATS_NEW
-@@ -1,3 +1,12 @@
-+Version 2.03.06 -
-+================================
-+ Synchronize with udev when dropping snapshot.
-+ Add missing device synchronization point before removing pvmove node.
-+ Correctly set read_ahead for LVs when pvmove is finished.
-+ Remove unsupported OPTIONS+="event_timeout" udev rule from 11-dm-lvm.rules.
-+ Prevent creating VGs with PVs with different logical block sizes.
-+ Fix metadata writes from corrupting with large physical block size.
-+
- Version 2.03.05 - 15th June 2019
- ================================
- Fix command definition for pvchange -a.
-diff --git a/lib/activate/dev_manager.c b/lib/activate/dev_manager.c
-index 981f4674a..7101ffa12 100644
---- a/lib/activate/dev_manager.c
-+++ b/lib/activate/dev_manager.c
-@@ -3558,13 +3558,6 @@ static int _clean_tree(struct dev_manager *dm, struct dm_tree_node *root, const
- const char *name, *uuid;
- struct dm_str_list *dl;
-
-- /* Deactivate any tracked pending delete nodes */
-- dm_list_iterate_items(dl, &dm->pending_delete) {
-- log_debug_activation("Deleting tracked UUID %s.", dl->str);
-- if (!dm_tree_deactivate_children(root, dl->str, strlen(dl->str)))
-- return_0;
-- }
--
- while ((child = dm_tree_next_child(&handle, root, 0))) {
- if (!(name = dm_tree_node_get_name(child)))
- continue;
-@@ -3585,10 +3578,21 @@ static int _clean_tree(struct dev_manager *dm, struct dm_tree_node *root, const
- if (non_toplevel_tree_dlid && !strcmp(non_toplevel_tree_dlid, uuid))
- continue;
-
-- if (!dm_tree_deactivate_children(root, uuid, strlen(uuid)))
-+ if (!str_list_add(dm->mem, &dm->pending_delete, uuid))
- return_0;
- }
-
-+ /* Deactivate any tracked pending delete nodes */
-+ if (!dm_list_empty(&dm->pending_delete) && !dm_get_suspended_counter()) {
-+ fs_unlock();
-+ dm_tree_set_cookie(root, fs_get_cookie());
-+ dm_list_iterate_items(dl, &dm->pending_delete) {
-+ log_debug_activation("Deleting tracked UUID %s.", dl->str);
-+ if (!dm_tree_deactivate_children(root, dl->str, strlen(dl->str)))
-+ return_0;
-+ }
-+ }
-+
- return 1;
- }
-
---
-2.21.0
-
diff --git a/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2/0001-udev-remove-unsupported-OPTIONS-event_timeout-rule.patch b/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2/0001-udev-remove-unsupported-OPTIONS-event_timeout-rule.patch
deleted file mode 100644
index 5a6db4b88..000000000
--- a/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2/0001-udev-remove-unsupported-OPTIONS-event_timeout-rule.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From e48f8328f9d35f23a24e5b27237e8ebf1dbfa269 Mon Sep 17 00:00:00 2001
-From: Hongxu Jia <hongxu.jia@windriver.com>
-Date: Thu, 10 Oct 2019 22:38:00 -0400
-Subject: [PATCH] udev: remove unsupported OPTIONS+="event_timeout" rule
-
-The OPTIONS+="event_timeout" is Unsupported since systemd/udev version 216,
-that is ~5 years ago.
-
-Since systemd/udev version 243, there's a new message printed if unsupported
-OPTIONS value is used:
-
- Invalid value for OPTIONS key, ignoring: 'event_timeout=180'
-
-Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1740666
-
-Signed-off-by: Peter Rajnoha <prajnoha@redhat.com>
-
-Upstream-Status: Backport [https://github.com/lvmteam/lvm2/commit/125f27ac37bc9b93cc96f64052b9681b3d479ee1]
-Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
----
- udev/11-dm-lvm.rules.in | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/udev/11-dm-lvm.rules.in b/udev/11-dm-lvm.rules.in
-index 91cb991..7c58994 100644
---- a/udev/11-dm-lvm.rules.in
-+++ b/udev/11-dm-lvm.rules.in
-@@ -37,8 +37,6 @@ ENV{DM_SUBSYSTEM_UDEV_FLAG0}!="1", ENV{DM_NOSCAN}=="1", ENV{DM_UDEV_DISABLE_OTHE
-
- ENV{DM_UDEV_DISABLE_SUBSYSTEM_RULES_FLAG}=="1", GOTO="lvm_end"
-
--OPTIONS+="event_timeout=180"
--
- # Do not create symlinks for inappropriate subdevices.
- ENV{DM_LV_NAME}=="pvmove?*|?*_vorigin", GOTO="lvm_disable"
- ENV{DM_LV_LAYER}=="?*", GOTO="lvm_disable"
---
-2.23.0
-
diff --git a/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2/0002-activation-extend-handling-of-pending_delete.patch b/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2/0002-activation-extend-handling-of-pending_delete.patch
deleted file mode 100644
index e30731593..000000000
--- a/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2/0002-activation-extend-handling-of-pending_delete.patch
+++ /dev/null
@@ -1,124 +0,0 @@
-From d06ad77b47f4dfd25bc3da88c0621ac073ad8ce5 Mon Sep 17 00:00:00 2001
-From: Zdenek Kabelac <zkabelac@redhat.com>
-Date: Fri, 23 Aug 2019 13:08:34 +0200
-Subject: [PATCH 2/3] activation: extend handling of pending_delete
-
-With previous patch 30a98e4d6710a543692d40d11428ae4baea11b7b we
-started to put devices one pending_delete list instead
-of directly scheduling their removal.
-
-However we have operations like 'snapshot merge' where we are
-resuming device tree in 2 subsequent activation calls - so
-1st such call will still have suspened devices and no chance
-to push 'remove' ioctl.
-
-Since we curently cannot easily solve this by doing just single
-activation call (which would be preferred solution) - we introduce
-a preservation of pending_delete via command structure and
-then restore it on next activation call.
-
-This way we keep to remove devices later - although it might be
-not the best moment - this may need futher tunning.
-
-Also we don't keep the list of operation in 1 trasaction
-(unless we do verify udev symlinks) - this could probably
-also make it more correct in terms of which 'remove' can
-be combined we already running 'resume'.
-
-Upstream-Status: Backport
-Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
----
- lib/activate/dev_manager.c | 24 +++++++++++-------------
- lib/commands/toolcontext.c | 8 ++++++++
- lib/commands/toolcontext.h | 1 +
- 3 files changed, 20 insertions(+), 13 deletions(-)
-
-diff --git a/lib/activate/dev_manager.c b/lib/activate/dev_manager.c
-index 7101ffa12..7a7689291 100644
---- a/lib/activate/dev_manager.c
-+++ b/lib/activate/dev_manager.c
-@@ -3591,6 +3591,7 @@ static int _clean_tree(struct dev_manager *dm, struct dm_tree_node *root, const
- if (!dm_tree_deactivate_children(root, dl->str, strlen(dl->str)))
- return_0;
- }
-+ dm_list_init(&dm->pending_delete);
- }
-
- return 1;
-@@ -3717,25 +3718,22 @@ out_no_root:
- int dev_manager_activate(struct dev_manager *dm, const struct logical_volume *lv,
- struct lv_activate_opts *laopts)
- {
-+ dm_list_splice(&dm->pending_delete, &lv->vg->cmd->pending_delete);
-+
- if (!_tree_action(dm, lv, laopts, ACTIVATE))
- return_0;
-
-- /*
-- * When lvm2 resumes a device and shortly after that it removes it,
-- * udevd rule will try to blindly call 'dmsetup info' on already removed
-- * device leaving the trace inside syslog about failing operation.
-- *
-- * TODO: It's not completely clear this call here is the best fix.
-- * Maybe there can be a better sequence, but ATM we do usually resume
-- * error device i.e. on cache deletion and remove it.
-- * TODO2: there could be more similar cases!
-- */
-- if (!dm_list_empty(&dm->pending_delete))
-- fs_unlock();
--
- if (!_tree_action(dm, lv, laopts, CLEAN))
- return_0;
-
-+ if (!dm_list_empty(&dm->pending_delete)) {
-+ log_debug("Preserving %d device(s) for removal while being suspended.",
-+ dm_list_size(&dm->pending_delete));
-+ if (!(str_list_dup(lv->vg->cmd->mem, &lv->vg->cmd->pending_delete,
-+ &dm->pending_delete)))
-+ return_0;
-+ }
-+
- return 1;
- }
-
-diff --git a/lib/commands/toolcontext.c b/lib/commands/toolcontext.c
-index 1e03ea235..0a9355361 100644
---- a/lib/commands/toolcontext.c
-+++ b/lib/commands/toolcontext.c
-@@ -1734,6 +1734,8 @@ struct cmd_context *create_toolcontext(unsigned is_clvmd,
- cmd->current_settings = cmd->default_settings;
-
- cmd->initialized.config = 1;
-+
-+ dm_list_init(&cmd->pending_delete);
- out:
- if (!cmd->initialized.config) {
- destroy_toolcontext(cmd);
-@@ -1922,6 +1924,12 @@ int refresh_toolcontext(struct cmd_context *cmd)
-
- cmd->initialized.config = 1;
-
-+ if (!dm_list_empty(&cmd->pending_delete)) {
-+ log_debug(INTERNAL_ERROR "Unprocessed pending delete for %d devices.",
-+ dm_list_size(&cmd->pending_delete));
-+ dm_list_init(&cmd->pending_delete);
-+ }
-+
- if (cmd->initialized.connections && !init_connections(cmd))
- return_0;
-
-diff --git a/lib/commands/toolcontext.h b/lib/commands/toolcontext.h
-index 6e4530c8a..54ddec320 100644
---- a/lib/commands/toolcontext.h
-+++ b/lib/commands/toolcontext.h
-@@ -237,6 +237,7 @@ struct cmd_context {
- const char *report_list_item_separator;
- const char *time_format;
- unsigned rand_seed;
-+ struct dm_list pending_delete; /* list of LVs for removal */
- };
-
- /*
---
-2.21.0
-
diff --git a/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2/0003-snapshot-always-activate.patch b/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2/0003-snapshot-always-activate.patch
deleted file mode 100644
index 953e4ad65..000000000
--- a/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2/0003-snapshot-always-activate.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 9143445478871b47ba28b41f5e88d4c415f8205b Mon Sep 17 00:00:00 2001
-From: Zdenek Kabelac <zkabelac@redhat.com>
-Date: Mon, 26 Aug 2019 15:13:55 +0200
-Subject: [PATCH 3/3] snapshot: always activate
-
-Drop the 'cluster-only' optimization so we do resume ALL device
-before we try to wait on cookie before 'removal' operation.
-
-It's more correct order of operation - alhtough possibly slightly
-less efficient - but until we have correct list of operations
-'in-progress' we can't do anything better.
-
-Upstream-Status: Backport
-Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
----
- lib/metadata/snapshot_manip.c | 8 +-------
- 1 file changed, 1 insertion(+), 7 deletions(-)
-
-diff --git a/lib/metadata/snapshot_manip.c b/lib/metadata/snapshot_manip.c
-index 5ccf251c7..65d8dbd13 100644
---- a/lib/metadata/snapshot_manip.c
-+++ b/lib/metadata/snapshot_manip.c
-@@ -361,13 +361,7 @@ int vg_remove_snapshot(struct logical_volume *cow)
- return 0;
- }
-
-- /*
-- * For merged snapshot and clustered VG activate cow LV so
-- * the following call to deactivate_lv() can clean-up table
-- * entries. For this clustered lock need to be held.
-- */
-- if (vg_is_clustered(cow->vg) &&
-- merging_snapshot && !activate_lv(cow->vg->cmd, cow)) {
-+ if (merging_snapshot && !activate_lv(cow->vg->cmd, cow)) {
- log_error("Failed to activate %s.", cow->name);
- return 0;
- }
---
-2.21.0
-
diff --git a/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2_2.03.05.bb b/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2_2.03.06.bb
index b80f1fd4b..e2b551bbc 100644
--- a/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2_2.03.05.bb
+++ b/meta-openembedded/meta-oe/recipes-support/lvm2/lvm2_2.03.06.bb
@@ -3,10 +3,6 @@ require lvm2.inc
SRC_URI += " \
file://0001-dev-hdc-open-failed-No-medium-found-will-print-out-i.patch \
file://0001-fix-command-bin-findmnt-bin-lsblk-bin-sort-not-found.patch \
- file://0001-udev-remove-unsupported-OPTIONS-event_timeout-rule.patch \
- file://0001-activation-add-synchronization-point.patch \
- file://0002-activation-extend-handling-of-pending_delete.patch \
- file://0003-snapshot-always-activate.patch \
"
DEPENDS += "autoconf-archive-native"
diff --git a/meta-openembedded/meta-oe/recipes-support/mcelog/mce-test_git.bb b/meta-openembedded/meta-oe/recipes-support/mcelog/mce-test_git.bb
index 888c729b3..007b3944a 100644
--- a/meta-openembedded/meta-oe/recipes-support/mcelog/mce-test_git.bb
+++ b/meta-openembedded/meta-oe/recipes-support/mcelog/mce-test_git.bb
@@ -13,8 +13,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mce-test.git;protocol=git \
file://makefile-remove-ldflags.patch \
"
-SRCREV = "74bffd8b0aa27051aeaa1983a7b23975ca8d8726"
-PV = "20171030+git${SRCPV}"
+SRCREV = "7643baf6c3919b3d727e6ba6c2e545dc6a653307"
+PV = "20190917+git${SRCPV}"
RDEPENDS_${PN} = "mcelog mce-inject dialog bash"
diff --git a/meta-openembedded/meta-oe/recipes-support/mcelog/mcelog_164.bb b/meta-openembedded/meta-oe/recipes-support/mcelog/mcelog_165.bb
index af309d1c6..8af919fea 100644
--- a/meta-openembedded/meta-oe/recipes-support/mcelog/mcelog_164.bb
+++ b/meta-openembedded/meta-oe/recipes-support/mcelog/mcelog_165.bb
@@ -9,7 +9,7 @@ SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http;
file://run-ptest \
"
-SRCREV = "e53631f84a181be371c08e0b961180bff77fd2ab"
+SRCREV = "6b6a8a571b5b0967cadbee770bf444f4e8634cca"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://README.md;md5=74bb47b9a68850cb398665cf78b31de6"
diff --git a/meta-openembedded/meta-oe/recipes-support/syslog-ng/files/0001-syslog-ng-fix-segment-fault-during-service-start.patch b/meta-openembedded/meta-oe/recipes-support/syslog-ng/files/0001-syslog-ng-fix-segment-fault-during-service-start.patch
index 0fc40be4a..b5bfcd025 100644
--- a/meta-openembedded/meta-oe/recipes-support/syslog-ng/files/0001-syslog-ng-fix-segment-fault-during-service-start.patch
+++ b/meta-openembedded/meta-oe/recipes-support/syslog-ng/files/0001-syslog-ng-fix-segment-fault-during-service-start.patch
@@ -1,6 +1,3 @@
-From caeccb7bec45f65bc89efa8195b3853368328361 Mon Sep 17 00:00:00 2001
-From: Changqing Li <changqing.li@windriver.com>
-Date: Mon, 17 Sep 2018 12:49:36 +0800
Subject: [PATCH] syslog-ng: fix segment fault during service start on arm64
service start failed since segment fault on arch arm64,
@@ -17,12 +14,15 @@ https://github.com/buytenh/ivykis/issues/15
Upstream-Status: Pending
Signed-off-by: Changqing Li <changqing.li@windriver.com>
+
+Update for 3.24.1.
+Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
---
- lib/ivykis/src/pthr.h | 24 ++++++++++++------------
- 1 file changed, 12 insertions(+), 12 deletions(-)
+ lib/ivykis/src/pthr.h | 23 ++++++++++++-----------
+ 1 file changed, 12 insertions(+), 11 deletions(-)
diff --git a/lib/ivykis/src/pthr.h b/lib/ivykis/src/pthr.h
-index a41eaf3..72c5190 100644
+index 29e4be7..5d29096 100644
--- a/lib/ivykis/src/pthr.h
+++ b/lib/ivykis/src/pthr.h
@@ -24,6 +24,16 @@
@@ -47,12 +47,12 @@ index a41eaf3..72c5190 100644
#ifdef HAVE_PRAGMA_WEAK
-/*
-- * On Linux, pthread_atfork() is defined in libpthread_nonshared.a,
-- * a static library, and we want to avoid "#pragma weak" for that
-- * symbol because that causes it to be undefined even if you link
-- * libpthread_nonshared.a in explicitly.
+- * On Linux, pthread_atfork() is defined in libc_nonshared.a (for
+- * glibc >= 2.28) or libpthread_nonshared.a (for glibc <= 2.27), and
+- * we want to avoid "#pragma weak" for that symbol because that causes
+- * it to be undefined even if you link lib*_nonshared.a in explicitly.
- */
--#ifndef HAVE_LIBPTHREAD_NONSHARED
+-#if !defined(HAVE_LIBC_NONSHARED) && !defined(HAVE_LIBPTHREAD_NONSHARED)
-#pragma weak pthread_atfork
-#endif
-
@@ -60,16 +60,15 @@ index a41eaf3..72c5190 100644
#pragma weak pthread_create
#pragma weak pthread_detach
#pragma weak pthread_getspecific
-@@ -73,8 +74,7 @@ static inline int
+@@ -73,7 +74,7 @@ static inline int
pthr_atfork(void (*prepare)(void), void (*parent)(void), void (*child)(void))
{
if (pthreads_available())
- return pthread_atfork(prepare, parent, child);
--
+ return __register_atfork(prepare, parent, child, __dso_handle);
+
return ENOSYS;
}
-
--
2.7.4
diff --git a/meta-openembedded/meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch b/meta-openembedded/meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch
index 553f4a517..4ad0afa95 100644
--- a/meta-openembedded/meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch
+++ b/meta-openembedded/meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch
@@ -6,25 +6,28 @@ This would avoid a implicit auto-detecting result.
Signed-off-by: Ming Liu <ming.liu@windriver.com>
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
+
+Update for 3.24.1.
+Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
---
- configure.ac | 27 +++++++++++++++++----------
- 1 files changed, 17 insertions(+), 10 deletions(-)
+ configure.ac | 28 ++++++++++++++++------------
+ 1 file changed, 16 insertions(+), 12 deletions(-)
-Index: syslog-ng-3.8.1/configure.ac
-===================================================================
---- syslog-ng-3.8.1.orig/configure.ac
-+++ syslog-ng-3.8.1/configure.ac
-@@ -104,6 +104,9 @@ AC_CONFIG_HEADERS(config.h)
+diff --git a/configure.ac b/configure.ac
+index 00eb566..e7d5ac1 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -143,6 +143,9 @@ AC_CONFIG_HEADERS(config.h)
dnl ***************************************************************************
dnl Arguments
-+AC_ARG_ENABLE(libnet,
++AC_ARG_ENABLE(libnet,
+ [ --enable-libnet Enable libnet support.],, enable_libnet="no")
+
AC_ARG_WITH(libnet,
[ --with-libnet=path use path to libnet-config script],
,
-@@ -893,22 +896,26 @@ dnl ************************************
+@@ -1047,19 +1050,20 @@ dnl ***************************************************************************
dnl libnet headers/libraries
dnl ***************************************************************************
AC_MSG_CHECKING(for LIBNET)
@@ -39,7 +42,14 @@ Index: syslog-ng-3.8.1/configure.ac
+ else
+ LIBNET_CONFIG="$with_libnet/libnet-config"
+ fi
-+
+
+-if test -n "$LIBNET_CONFIG" -a -x "$LIBNET_CONFIG"; then
+- LIBNET_CFLAGS="`$LIBNET_CONFIG --defines`"
+- LIBNET_LIBS="`$LIBNET_CONFIG --libs`"
+- AC_MSG_RESULT(yes)
+-dnl libnet-config does not provide the _DEFAULT_SOURCE define, that can cause warning during build
+-dnl as upstream libnet-config does uses _DEFAULT_SOURCE this is just a fix till
+- LIBNET_CFLAGS="$LIBNET_CFLAGS -D_DEFAULT_SOURCE"
+ if test -n "$LIBNET_CONFIG" -a -x "$LIBNET_CONFIG"; then
+ LIBNET_CFLAGS="`$LIBNET_CONFIG --defines`"
+ LIBNET_LIBS="`$LIBNET_CONFIG --libs`"
@@ -48,16 +58,8 @@ Index: syslog-ng-3.8.1/configure.ac
+ AC_MSG_ERROR([Could not find libnet, and libnet support was explicitly enabled.])
+ fi
--if test -n "$LIBNET_CONFIG" -a -x "$LIBNET_CONFIG"; then
-- LIBNET_CFLAGS="`$LIBNET_CONFIG --defines`"
-- LIBNET_LIBS="`$LIBNET_CONFIG --libs`"
-- AC_MSG_RESULT(yes)
else
LIBNET_LIBS=
- AC_MSG_RESULT(no)
- fi
-
--
- if test "x$enable_spoof_source" = "xauto"; then
- AC_MSG_CHECKING(whether to enable spoof source support)
- if test "x$LIBNET_LIBS" != "x"; then
+--
+2.7.4
+
diff --git a/meta-openembedded/meta-oe/recipes-support/syslog-ng/files/syslog-ng.service-the-syslog-ng-service.patch b/meta-openembedded/meta-oe/recipes-support/syslog-ng/files/syslog-ng.service-the-syslog-ng-service.patch
index 39c3f59ce..0e1d09492 100644
--- a/meta-openembedded/meta-oe/recipes-support/syslog-ng/files/syslog-ng.service-the-syslog-ng-service.patch
+++ b/meta-openembedded/meta-oe/recipes-support/syslog-ng/files/syslog-ng.service-the-syslog-ng-service.patch
@@ -1,16 +1,17 @@
-From 0be9c08dd3f825e92fa02d4a08d8aff743109e61 Mon Sep 17 00:00:00 2001
-From: Li xin <lixin.fnst@cn.fujitsu.com>
-Date: Wed, 17 Jun 2015 14:46:30 +0900
-Subject: [PATCH] syslog-ng.service: the syslog-ng service can not start
+Subject: [PATCH] syslog-ng.service: the syslog-ng service can not start
successfully,so modify it.
Upstream-Status: pending
Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com>
Updated-by: Andrej Valek <andrej.valek@siemens.com>
+
+Update for 3.24.1
+Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
---
- contrib/systemd/syslog-ng.service | 5 ++---
- 1 file changed, 2 insertion(+), 3 deletions(-)
+ contrib/systemd/syslog-ng@.service | 4 ++--
+ contrib/systemd/syslog-ng@default | 6 +++---
+ 2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/contrib/systemd/syslog-ng@.service b/contrib/systemd/syslog-ng@.service
index a28640e..93aec94 100644
@@ -28,19 +29,18 @@ index a28640e..93aec94 100644
StandardError=journal
Restart=on-failure
diff --git a/contrib/systemd/syslog-ng@default b/contrib/systemd/syslog-ng@default
-index 02da288..3a8215d 100644
+index 0ccc2b9..7f08c0e 100644
--- a/contrib/systemd/syslog-ng@default
+++ b/contrib/systemd/syslog-ng@default
@@ -1,5 +1,5 @@
--CONFIG_FILE=/etc/syslog-ng.conf
+ CONFIG_FILE=/etc/syslog-ng/syslog-ng.conf
-PERSIST_FILE=/var/lib/syslog-ng/syslog-ng.persist
--CONTROL_FILE=/var/lib/syslog-ng/syslog-ng.ctl
+-CONTROL_FILE=/var/run/syslog-ng.ctl
-PID_FILE=/var/run/syslog-ng.pid
-+CONFIG_FILE=/etc/syslog-ng/syslog-ng.conf
+PERSIST_FILE=@LOCALSTATEDIR@/lib/syslog-ng/syslog-ng.persist
+CONTROL_FILE=@LOCALSTATEDIR@/lib/syslog-ng/syslog-ng.ctl
+PID_FILE=@LOCALSTATEDIR@/run/syslog-ng.pid
OTHER_OPTIONS="--enable-core"
-
--
-1.8.4.2
+2.7.4
+
diff --git a/meta-openembedded/meta-oe/recipes-support/syslog-ng/syslog-ng.inc b/meta-openembedded/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
index 4c22d4b0f..3aba4473d 100644
--- a/meta-openembedded/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
+++ b/meta-openembedded/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
@@ -92,7 +92,6 @@ do_install_append() {
install -d ${D}${systemd_unitdir}/system/
install -m 0644 ${S}/contrib/systemd/${BPN}@.service ${D}${systemd_unitdir}/system/${BPN}@.service
- install -m 0644 ${S}/${BPN}.service ${D}${systemd_unitdir}/system/${BPN}.service
install -m 0644 ${S}/contrib/systemd/${BPN}@default ${D}${sysconfdir}/default/${BPN}@default
sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/${BPN}@.service ${D}${sysconfdir}/default/${BPN}@default
diff --git a/meta-openembedded/meta-oe/recipes-support/syslog-ng/syslog-ng_3.19.1.bb b/meta-openembedded/meta-oe/recipes-support/syslog-ng/syslog-ng_3.24.1.bb
index 852343c23..01ed76765 100644
--- a/meta-openembedded/meta-oe/recipes-support/syslog-ng/syslog-ng_3.19.1.bb
+++ b/meta-openembedded/meta-oe/recipes-support/syslog-ng/syslog-ng_3.24.1.bb
@@ -10,5 +10,5 @@ SRC_URI += " \
file://syslog-ng-tmp.conf \
"
-SRC_URI[md5sum] = "aa79bc13d9fd925aa5fb9516e87aacd3"
-SRC_URI[sha256sum] = "5cf931a9d7bead0e6d9a2c65eee8f6005a005878f59aa280f3c4294257ed5178"
+SRC_URI[md5sum] = "ef9de066793f7358af7312b964ac0450"
+SRC_URI[sha256sum] = "d4d0a0357b452be96b69d6f741129275530d8f0451e35adc408ad5635059fa3d"