summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-test/bats/bats_1.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-test/bats/bats_1.3.0.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-test/bats/bats_1.3.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-test/bats/bats_1.3.0.bb b/meta-openembedded/meta-oe/recipes-test/bats/bats_1.3.0.bb
new file mode 100644
index 000000000..8190a5e3a
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-test/bats/bats_1.3.0.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Bash Automated Testing System"
+DESCRIPTION = "Bats is a TAP-compliant testing framework for Bash. It \
+provides a simple way to verify that the UNIX programs you write behave as expected."
+AUTHOR = "Sam Stephenson & bats-core organization"
+HOMEPAGE = "https://github.com/bats-core/bats-core"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=2970203aedf9e829edb96a137a4fe81b"
+
+SRC_URI = "git://github.com/bats-core/bats-core.git \
+ "
+# v1.3.0
+SRCREV = "9086c47854652f2731861b40385689c85f12103f"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ # Just a bunch of bash scripts to install
+ ${S}/install.sh ${D}${prefix}
+}
+
+RDEPENDS_${PN} = "bash"
+FILES_${PN} += "${libdir}/bats-core/*"
+
+PACKAGECONFIG ??= "pretty"
+PACKAGECONFIG[pretty] = ",,,ncurses"