summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-test
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-test')
-rw-r--r--meta-openembedded/meta-oe/recipes-test/bats/bats_1.4.1.bb (renamed from meta-openembedded/meta-oe/recipes-test/bats/bats_1.3.0.bb)8
-rw-r--r--meta-openembedded/meta-oe/recipes-test/catch2/catch2_2.13.6.bb6
-rw-r--r--meta-openembedded/meta-oe/recipes-test/cmocka/cmocka_1.1.5.bb6
-rw-r--r--meta-openembedded/meta-oe/recipes-test/cpputest/cpputest_4.0.bb2
-rw-r--r--meta-openembedded/meta-oe/recipes-test/cunit/cunit_2.1-3.bb4
-rw-r--r--meta-openembedded/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb2
-rw-r--r--meta-openembedded/meta-oe/recipes-test/evtest/evtest/0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch2
-rw-r--r--meta-openembedded/meta-oe/recipes-test/fwts/fwts_21.06.00.bb12
-rw-r--r--meta-openembedded/meta-oe/recipes-test/googletest/googletest_git.bb8
-rw-r--r--meta-openembedded/meta-oe/recipes-test/pm-qa/pm-qa_git.bb7
10 files changed, 29 insertions, 28 deletions
diff --git a/meta-openembedded/meta-oe/recipes-test/bats/bats_1.3.0.bb b/meta-openembedded/meta-oe/recipes-test/bats/bats_1.4.1.bb
index 39a02733f..b30055549 100644
--- a/meta-openembedded/meta-oe/recipes-test/bats/bats_1.3.0.bb
+++ b/meta-openembedded/meta-oe/recipes-test/bats/bats_1.4.1.bb
@@ -9,8 +9,8 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=2970203aedf9e829edb96a137a4fe81b"
SRC_URI = "git://github.com/bats-core/bats-core.git \
file://0001-install.sh-consider-multilib.patch \
"
-# v1.3.0
-SRCREV = "9086c47854652f2731861b40385689c85f12103f"
+# v1.4.1
+SRCREV = "54e965fa9d269c2b3ff9036d81f32bac3df0edea"
S = "${WORKDIR}/git"
@@ -19,8 +19,8 @@ do_install() {
${S}/install.sh ${D}${prefix} ${baselib}
}
-RDEPENDS_${PN} = "bash"
-FILES_${PN} += "${libdir}/bats-core/*"
+RDEPENDS:${PN} = "bash"
+FILES:${PN} += "${libdir}/bats-core/*"
PACKAGECONFIG ??= "pretty"
PACKAGECONFIG[pretty] = ",,,ncurses"
diff --git a/meta-openembedded/meta-oe/recipes-test/catch2/catch2_2.13.6.bb b/meta-openembedded/meta-oe/recipes-test/catch2/catch2_2.13.6.bb
index fd677a3e3..adfc03a16 100644
--- a/meta-openembedded/meta-oe/recipes-test/catch2/catch2_2.13.6.bb
+++ b/meta-openembedded/meta-oe/recipes-test/catch2/catch2_2.13.6.bb
@@ -12,11 +12,11 @@ S = "${WORKDIR}/git"
inherit cmake python3native
-do_install_append() {
+do_install:append() {
rm ${D}${datadir}/Catch2/lldbinit
rm ${D}${datadir}/Catch2/gdbinit
rmdir ${D}${datadir}/Catch2/
}
# Header-only library
-RDEPENDS_${PN}-dev = ""
-RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"
+RDEPENDS:${PN}-dev = ""
+RRECOMMENDS:${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"
diff --git a/meta-openembedded/meta-oe/recipes-test/cmocka/cmocka_1.1.5.bb b/meta-openembedded/meta-oe/recipes-test/cmocka/cmocka_1.1.5.bb
index e4afa43e9..59626df07 100644
--- a/meta-openembedded/meta-oe/recipes-test/cmocka/cmocka_1.1.5.bb
+++ b/meta-openembedded/meta-oe/recipes-test/cmocka/cmocka_1.1.5.bb
@@ -20,7 +20,7 @@ EXTRA_OECMAKE += "${@bb.utils.contains('PTEST_ENABLED', '1', '-DCMAKE_BUILD_TYPE
# Use -Wl,wrap linker flag, which does not work with LTO
LTO = ""
-do_install_append () {
+do_install:append () {
install -d ${D}${datadir}/${BPN}/example
install -d ${D}${datadir}/${BPN}/example/mock/chef_wrap
install -d ${D}${datadir}/${BPN}/example/mock/uptime
@@ -39,5 +39,5 @@ do_install_ptest () {
PACKAGE_BEFORE_PN += "${PN}-examples"
-FILES_${PN}-examples = "${datadir}/${BPN}/example"
-INSANE_SKIP_${PN}-examples = "libdir"
+FILES:${PN}-examples = "${datadir}/${BPN}/example"
+INSANE_SKIP:${PN}-examples = "libdir"
diff --git a/meta-openembedded/meta-oe/recipes-test/cpputest/cpputest_4.0.bb b/meta-openembedded/meta-oe/recipes-test/cpputest/cpputest_4.0.bb
index a17c0658c..e84e03cdb 100644
--- a/meta-openembedded/meta-oe/recipes-test/cpputest/cpputest_4.0.bb
+++ b/meta-openembedded/meta-oe/recipes-test/cpputest/cpputest_4.0.bb
@@ -18,4 +18,4 @@ EXTRA_OECMAKE = "-DLONGLONG=ON \
-DEXTENSIONS=OFF \
"
-FILES_${PN}-dev += "${libdir}/CppUTest/cmake/*"
+FILES:${PN}-dev += "${libdir}/CppUTest/cmake/*"
diff --git a/meta-openembedded/meta-oe/recipes-test/cunit/cunit_2.1-3.bb b/meta-openembedded/meta-oe/recipes-test/cunit/cunit_2.1-3.bb
index c877d3bf1..c71744e3c 100644
--- a/meta-openembedded/meta-oe/recipes-test/cunit/cunit_2.1-3.bb
+++ b/meta-openembedded/meta-oe/recipes-test/cunit/cunit_2.1-3.bb
@@ -31,7 +31,7 @@ do_install_ptest() {
install -m 0755 ${S}${TESTBIN} ${D}${PTEST_PATH}/tests/
}
-FILES_${PN}-dev += "${datadir}/CUnit"
-FILES_${PN}-doc += "${docdir}"
+FILES:${PN}-dev += "${datadir}/CUnit"
+FILES:${PN}-doc += "${docdir}"
BBCLASSEXTEND = "native"
diff --git a/meta-openembedded/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb b/meta-openembedded/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb
index 252eea366..b76069065 100644
--- a/meta-openembedded/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb
+++ b/meta-openembedded/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb
@@ -12,7 +12,7 @@ S = "${WORKDIR}/cxxtest-${PV}/python"
inherit distutils3
-do_install_append() {
+do_install:append() {
install -d ${D}${includedir}
cp -a ../cxxtest ${D}${includedir}
sed '1c\
diff --git a/meta-openembedded/meta-oe/recipes-test/evtest/evtest/0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch b/meta-openembedded/meta-oe/recipes-test/evtest/evtest/0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch
index 706322d56..aa49a0629 100644
--- a/meta-openembedded/meta-oe/recipes-test/evtest/evtest/0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch
+++ b/meta-openembedded/meta-oe/recipes-test/evtest/evtest/0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch
@@ -35,7 +35,7 @@ index 548c203..93063cd 100644
code = ev[i].code;
- printf("Event: time %ld.%06ld, ", ev[i].time.tv_sec, ev[i].time.tv_usec);
-+ printf("Event: time %ld.%06ld, ", ev[i].input_event_sec, ev[i].input_event_sec);
++ printf("Event: time %ld.%06ld, ", ev[i].input_event_sec, ev[i].input_event_usec);
if (type == EV_SYN) {
if (code == SYN_MT_REPORT)
diff --git a/meta-openembedded/meta-oe/recipes-test/fwts/fwts_21.06.00.bb b/meta-openembedded/meta-oe/recipes-test/fwts/fwts_21.06.00.bb
index 21d256351..d33000b8b 100644
--- a/meta-openembedded/meta-oe/recipes-test/fwts/fwts_21.06.00.bb
+++ b/meta-openembedded/meta-oe/recipes-test/fwts/fwts_21.06.00.bb
@@ -18,15 +18,15 @@ SRC_URI[sha256sum] = "ca43439707976f6664fe3f6eb7f356a51ac7d7f8a4e246ef4d1b16305e
COMPATIBLE_HOST = "(i.86|x86_64|aarch64|powerpc64).*-linux"
DEPENDS = "libpcre glib-2.0 dtc bison-native libbsd"
-DEPENDS_append_libc-musl = " libexecinfo"
+DEPENDS:append:libc-musl = " libexecinfo"
# Use brokensep for now (https://github.com/ColinIanKing/fwts/issues/2)
inherit autotools-brokensep bash-completion pkgconfig
-LDFLAGS_append_libc-musl = " -lexecinfo"
+LDFLAGS:append:libc-musl = " -lexecinfo"
-FILES_${PN} += "${libdir}/fwts/lib*${SOLIBS}"
-FILES_${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la"
-FILES_${PN}-staticdev += "${libdir}/fwts/lib*a"
+FILES:${PN} += "${libdir}/fwts/lib*${SOLIBS}"
+FILES:${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la"
+FILES:${PN}-staticdev += "${libdir}/fwts/lib*a"
-RDEPENDS_${PN} += "dtc"
+RDEPENDS:${PN} += "dtc"
diff --git a/meta-openembedded/meta-oe/recipes-test/googletest/googletest_git.bb b/meta-openembedded/meta-oe/recipes-test/googletest/googletest_git.bb
index 3e1fc4ff8..ff8cecc5b 100644
--- a/meta-openembedded/meta-oe/recipes-test/googletest/googletest_git.bb
+++ b/meta-openembedded/meta-oe/recipes-test/googletest/googletest_git.bb
@@ -14,14 +14,14 @@ SRC_URI = "git://github.com/google/googletest.git"
inherit cmake
-ALLOW_EMPTY_${PN} = "1"
-ALLOW_EMPTY_${PN}-dbg = "1"
+ALLOW_EMPTY:${PN} = "1"
+ALLOW_EMPTY:${PN}-dbg = "1"
-RDEPENDS_${PN}-dev += "${PN}-staticdev"
+RDEPENDS:${PN}-dev += "${PN}-staticdev"
BBCLASSEXTEND = "native nativesdk"
-do_configure_prepend() {
+do_configure:prepend() {
# explicitly use python3
# the scripts are already python3 compatible since https://github.com/google/googletest/commit/d404af0d987a9c38cafce82a7e26ec8468c88361 and other fixes like this
# but since this oe-core change http://git.openembedded.org/openembedded-core/commit/?id=5f8f16b17f66966ae91aeabc23e97de5ecd17447
diff --git a/meta-openembedded/meta-oe/recipes-test/pm-qa/pm-qa_git.bb b/meta-openembedded/meta-oe/recipes-test/pm-qa/pm-qa_git.bb
index 7e9971ea4..18ef371e3 100644
--- a/meta-openembedded/meta-oe/recipes-test/pm-qa/pm-qa_git.bb
+++ b/meta-openembedded/meta-oe/recipes-test/pm-qa/pm-qa_git.bb
@@ -42,6 +42,7 @@ do_install () {
do
# Remove hardcoded relative paths
sed -i -e 's#..\/utils\/##' ${script}
+ sed -i -e 's#. ..\/Switches#${bindir}#g' ${script}
script_basename=`basename ${script}`
install -m 0755 $script ${D}${libdir}/${BPN}/${script_basename}
@@ -54,7 +55,7 @@ do_install () {
# if the script includes any helper scripts from the $libdir
# directory then change the source path to the absolute path
# to reflect the install location of the helper scripts.
- sed -i -e "s#source ../include#source ${libdir}/${BPN}#g" ${script}
+ sed -i -e "s#. ../include#. ${libdir}/${BPN}#g" ${script}
# Remove hardcoded relative paths
sed -i -e 's#..\/utils\/##' ${script}
@@ -62,7 +63,7 @@ do_install () {
install -m 0755 $script ${D}${bindir}/${script_basename}
done
}
-RDEPENDS_${PN} +="bash"
+RDEPENDS:${PN} +="bash"
# http://errors.yoctoproject.org/Errors/Details/186956/
-COMPATIBLE_HOST_libc-musl = 'null'
+COMPATIBLE_HOST:libc-musl = 'null'