summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-test
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-test')
-rw-r--r--meta-openembedded/meta-oe/recipes-test/bats/bats_1.3.0.bb3
-rw-r--r--meta-openembedded/meta-oe/recipes-test/bats/files/0001-install.sh-consider-multilib.patch43
-rw-r--r--meta-openembedded/meta-oe/recipes-test/cpputest/cpputest_4.0.bb21
-rw-r--r--meta-openembedded/meta-oe/recipes-test/fwts/fwts/0003-Remove-Werror-from-build.patch24
-rw-r--r--meta-openembedded/meta-oe/recipes-test/fwts/fwts_21.06.00.bb (renamed from meta-openembedded/meta-oe/recipes-test/fwts/fwts_21.03.00.bb)2
-rw-r--r--meta-openembedded/meta-oe/recipes-test/googletest/googletest_git.bb4
6 files changed, 81 insertions, 16 deletions
diff --git a/meta-openembedded/meta-oe/recipes-test/bats/bats_1.3.0.bb b/meta-openembedded/meta-oe/recipes-test/bats/bats_1.3.0.bb
index 8190a5e3a..39a02733f 100644
--- a/meta-openembedded/meta-oe/recipes-test/bats/bats_1.3.0.bb
+++ b/meta-openembedded/meta-oe/recipes-test/bats/bats_1.3.0.bb
@@ -7,6 +7,7 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.md;md5=2970203aedf9e829edb96a137a4fe81b"
SRC_URI = "git://github.com/bats-core/bats-core.git \
+ file://0001-install.sh-consider-multilib.patch \
"
# v1.3.0
SRCREV = "9086c47854652f2731861b40385689c85f12103f"
@@ -15,7 +16,7 @@ S = "${WORKDIR}/git"
do_install() {
# Just a bunch of bash scripts to install
- ${S}/install.sh ${D}${prefix}
+ ${S}/install.sh ${D}${prefix} ${baselib}
}
RDEPENDS_${PN} = "bash"
diff --git a/meta-openembedded/meta-oe/recipes-test/bats/files/0001-install.sh-consider-multilib.patch b/meta-openembedded/meta-oe/recipes-test/bats/files/0001-install.sh-consider-multilib.patch
new file mode 100644
index 000000000..c7393ca2e
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-test/bats/files/0001-install.sh-consider-multilib.patch
@@ -0,0 +1,43 @@
+From 6e3d01f1ff199383b78a7504858c374fbce05f4e Mon Sep 17 00:00:00 2001
+From: Kai Kang <kai.kang@windriver.com>
+Date: Thu, 10 Jun 2021 11:11:07 +0800
+Subject: [PATCH] install.sh: consider multilib
+
+It may install files to /usr/lib64 when multilib is enabled. Add an
+optional parameter for install.sh to support it.
+
+Upstream-Status: Submitted [https://github.com/bats-core/bats-core/pull/452]
+
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
+---
+ install.sh | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/install.sh b/install.sh
+index e660866..d91159e 100755
+--- a/install.sh
++++ b/install.sh
+@@ -4,6 +4,7 @@ set -e
+
+ BATS_ROOT="${0%/*}"
+ PREFIX="$1"
++BASELIB="${2:-lib}"
+
+ if [[ -z "$PREFIX" ]]; then
+ printf '%s\n' \
+@@ -12,10 +13,10 @@ if [[ -z "$PREFIX" ]]; then
+ exit 1
+ fi
+
+-install -d -m 755 "$PREFIX"/{bin,libexec/bats-core,lib/bats-core,share/man/man{1,7}}
++install -d -m 755 "$PREFIX"/{bin,libexec/bats-core,${BASELIB}/bats-core,share/man/man{1,7}}
+ install -m 755 "$BATS_ROOT/bin"/* "$PREFIX/bin"
+ install -m 755 "$BATS_ROOT/libexec/bats-core"/* "$PREFIX/libexec/bats-core"
+-install -m 755 "$BATS_ROOT/lib/bats-core"/* "$PREFIX/lib/bats-core"
++install -m 755 "$BATS_ROOT/lib/bats-core"/* "$PREFIX/${BASELIB}/bats-core"
+ install -m 644 "$BATS_ROOT/man/bats.1" "$PREFIX/share/man/man1"
+ install -m 644 "$BATS_ROOT/man/bats.7" "$PREFIX/share/man/man7"
+
+--
+2.17.1
+
diff --git a/meta-openembedded/meta-oe/recipes-test/cpputest/cpputest_4.0.bb b/meta-openembedded/meta-oe/recipes-test/cpputest/cpputest_4.0.bb
new file mode 100644
index 000000000..a17c0658c
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-test/cpputest/cpputest_4.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "CppUTest unit testing and mocking framework for C/C++"
+HOMEPAGE = "http://cpputest.github.io/"
+SECTION = "devel"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=ce5d5f1fe02bcd1343ced64a06fd4177"
+
+SRC_URI = "git://github.com/cpputest/cpputest.git;protocol=https"
+SRCREV = "67d2dfd41e13f09ff218aa08e2d35f1c32f032a1"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE = "-DLONGLONG=ON \
+ -DC++11=ON \
+ -DTESTS=OFF \
+ -DEXTENSIONS=OFF \
+ "
+
+FILES_${PN}-dev += "${libdir}/CppUTest/cmake/*"
diff --git a/meta-openembedded/meta-oe/recipes-test/fwts/fwts/0003-Remove-Werror-from-build.patch b/meta-openembedded/meta-oe/recipes-test/fwts/fwts/0003-Remove-Werror-from-build.patch
index 906ec99a9..5ccd461d9 100644
--- a/meta-openembedded/meta-oe/recipes-test/fwts/fwts/0003-Remove-Werror-from-build.patch
+++ b/meta-openembedded/meta-oe/recipes-test/fwts/fwts/0003-Remove-Werror-from-build.patch
@@ -11,12 +11,12 @@ Upstream-Status: Pending
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/Makefile.am b/src/Makefile.am
-index a26a197b..70a28174 100644
+index f8066af..6b979f8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
-@@ -14,7 +14,7 @@ AM_CPPFLAGS = \
- `pkg-config --silence-errors --cflags json` \
- `pkg-config --silence-errors --cflags json-c` \
+@@ -12,7 +12,7 @@ AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/acpica/source/compiler \
+ -I$(top_srcdir)/efi_runtime \
-pthread `pkg-config --cflags glib-2.0 gio-2.0` \
- -Wall -Werror -Wextra \
+ -Wall -Wextra \
@@ -24,7 +24,7 @@ index a26a197b..70a28174 100644
-Wfloat-equal -Wmissing-declarations \
-Wno-long-long -Wredundant-decls -Wshadow \
diff --git a/src/lib/src/Makefile.am b/src/lib/src/Makefile.am
-index 55c52b41..b85d0101 100644
+index 55c52b4..50efa97 100644
--- a/src/lib/src/Makefile.am
+++ b/src/lib/src/Makefile.am
@@ -25,7 +25,7 @@ AM_CPPFLAGS = \
@@ -32,23 +32,23 @@ index 55c52b41..b85d0101 100644
`pkg-config --cflags glib-2.0 gio-2.0` \
-DDATAROOTDIR=\"$(datarootdir)\" \
- -Wall -Werror -Wextra \
-+ -Wall -Wextra \
++ -Wall -Wextra \
-Wno-address-of-packed-member
pkglib_LTLIBRARIES = libfwts.la
diff --git a/src/utilities/Makefile.am b/src/utilities/Makefile.am
-index ecc25f0a..129c1036 100644
+index a7d9b9c..e1bf141 100644
--- a/src/utilities/Makefile.am
+++ b/src/utilities/Makefile.am
@@ -16,7 +16,7 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
#
--AM_CPPFLAGS = -Wall -Werror -Wextra -DDATAROOTDIR=\"$(datarootdir)\" \
-+AM_CPPFLAGS = -Wall -Wextra -DDATAROOTDIR=\"$(datarootdir)\" \
- `pkg-config --silence-errors --cflags json` \
- `pkg-config --silence-errors --cflags json-c` \
- -I../lib/include
+-AM_CPPFLAGS = -Wall -Werror -Wextra -DDATAROOTDIR=\"$(datarootdir)\" \
++AM_CPPFLAGS = -Wall -Wextra -DDATAROOTDIR=\"$(datarootdir)\" \
+ -I$(srcdir)/../lib/include
+
+ bin_PROGRAMS = kernelscan
--
2.25.1
diff --git a/meta-openembedded/meta-oe/recipes-test/fwts/fwts_21.03.00.bb b/meta-openembedded/meta-oe/recipes-test/fwts/fwts_21.06.00.bb
index aa7d422f7..21d256351 100644
--- a/meta-openembedded/meta-oe/recipes-test/fwts/fwts_21.03.00.bb
+++ b/meta-openembedded/meta-oe/recipes-test/fwts/fwts_21.06.00.bb
@@ -13,7 +13,7 @@ SRC_URI = "http://fwts.ubuntu.com/release/fwts-V${PV}.tar.gz;subdir=${BP} \
file://0005-Undefine-PAGE_SIZE.patch \
file://0006-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch \
"
-SRC_URI[sha256sum] = "c22dcba2572e4237bf2fe9ab579e195cf051d3a99b2c07ab58f757cae02d24fb"
+SRC_URI[sha256sum] = "ca43439707976f6664fe3f6eb7f356a51ac7d7f8a4e246ef4d1b16305e066909"
COMPATIBLE_HOST = "(i.86|x86_64|aarch64|powerpc64).*-linux"
diff --git a/meta-openembedded/meta-oe/recipes-test/googletest/googletest_git.bb b/meta-openembedded/meta-oe/recipes-test/googletest/googletest_git.bb
index 2e0fecf7a..3e1fc4ff8 100644
--- a/meta-openembedded/meta-oe/recipes-test/googletest/googletest_git.bb
+++ b/meta-openembedded/meta-oe/recipes-test/googletest/googletest_git.bb
@@ -4,12 +4,12 @@ SECTION = "libs"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=cbbd27594afd089daa160d3a16dd515a"
-PV = "1.10.0+git${SRCPV}"
+PV = "1.11.0+git${SRCPV}"
PROVIDES += "gmock gtest"
S = "${WORKDIR}/git"
-SRCREV = "662fe38e44900c007eccb65a5d2ea19df7bd520e"
+SRCREV = "e2239ee6043f73722e7aa812a459f54a28552929"
SRC_URI = "git://github.com/google/googletest.git"
inherit cmake