summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-connectivity
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-connectivity')
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-h2/python-h2.inc10
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-h2/python-h2_3.1.1.bb3
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-h2/python3-h2_3.1.1.bb3
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-hpack/python-hpack.inc10
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-hpack/python-hpack_3.0.0.bb3
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-hpack/python3-hpack_3.0.0.bb3
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-hyperframe/python-hyperframe.inc10
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-hyperframe/python-hyperframe_5.2.0.bb3
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-hyperframe/python3-hyperframe_5.2.0.bb3
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-priority/python-priority.inc10
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-priority/python-priority_1.3.0.bb3
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-priority/python3-priority_1.3.0.bb3
12 files changed, 64 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-h2/python-h2.inc b/meta-openembedded/meta-python/recipes-connectivity/python-h2/python-h2.inc
new file mode 100644
index 000000000..42629c261
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-connectivity/python-h2/python-h2.inc
@@ -0,0 +1,10 @@
+DESCRIPTION = "HTTP/2 State-Machine based protocol implementation"
+HOMEPAGE = "https://github.com/python-hyper/hyper-h2"
+LICENSE = "MIT"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b6b2f6bbe76528af543242d606c14851"
+
+SRC_URI[md5sum] = "950b5a62a2a608dc4547a01edf99aa8f"
+SRC_URI[sha256sum] = "b8a32bd282594424c0ac55845377eea13fa54fe4a8db012f3a198ed923dc3ab4"
+
+inherit pypi
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-h2/python-h2_3.1.1.bb b/meta-openembedded/meta-python/recipes-connectivity/python-h2/python-h2_3.1.1.bb
new file mode 100644
index 000000000..b84129742
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-connectivity/python-h2/python-h2_3.1.1.bb
@@ -0,0 +1,3 @@
+require python-h2.inc
+
+inherit setuptools
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-h2/python3-h2_3.1.1.bb b/meta-openembedded/meta-python/recipes-connectivity/python-h2/python3-h2_3.1.1.bb
new file mode 100644
index 000000000..7230a27e8
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-connectivity/python-h2/python3-h2_3.1.1.bb
@@ -0,0 +1,3 @@
+require python-h2.inc
+
+inherit setuptools3
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-hpack/python-hpack.inc b/meta-openembedded/meta-python/recipes-connectivity/python-hpack/python-hpack.inc
new file mode 100644
index 000000000..eccfa8c56
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-connectivity/python-hpack/python-hpack.inc
@@ -0,0 +1,10 @@
+DESCRIPTION = "Pure-Python HPACK header compression"
+HOMEPAGE = "https://github.com/python-hyper/hpack"
+LICENSE = "MIT"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5bf1c68e73fbaec2b1687b7e71514393"
+
+SRC_URI[md5sum] = "556b0ae66180f54c2ce8029a0952088b"
+SRC_URI[sha256sum] = "8eec9c1f4bfae3408a3f30500261f7e6a65912dc138526ea054f9ad98892e9d2"
+
+inherit pypi
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-hpack/python-hpack_3.0.0.bb b/meta-openembedded/meta-python/recipes-connectivity/python-hpack/python-hpack_3.0.0.bb
new file mode 100644
index 000000000..faaeb8555
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-connectivity/python-hpack/python-hpack_3.0.0.bb
@@ -0,0 +1,3 @@
+require python-hpack.inc
+
+inherit setuptools
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-hpack/python3-hpack_3.0.0.bb b/meta-openembedded/meta-python/recipes-connectivity/python-hpack/python3-hpack_3.0.0.bb
new file mode 100644
index 000000000..e196c55b3
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-connectivity/python-hpack/python3-hpack_3.0.0.bb
@@ -0,0 +1,3 @@
+require python-hpack.inc
+
+inherit setuptools3
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-hyperframe/python-hyperframe.inc b/meta-openembedded/meta-python/recipes-connectivity/python-hyperframe/python-hyperframe.inc
new file mode 100644
index 000000000..0066bf8e6
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-connectivity/python-hyperframe/python-hyperframe.inc
@@ -0,0 +1,10 @@
+DESCRIPTION = "HTTP/2 framing layer for Python"
+HOMEPAGE = "https://github.com/python-hyper/hyperframe"
+LICENSE = "MIT"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5bf1c68e73fbaec2b1687b7e71514393"
+
+SRC_URI[md5sum] = "6919183242feb26d8bce3b4cba81defd"
+SRC_URI[sha256sum] = "a9f5c17f2cc3c719b917c4f33ed1c61bd1f8dfac4b1bd23b7c80b3400971b41f"
+
+inherit pypi
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-hyperframe/python-hyperframe_5.2.0.bb b/meta-openembedded/meta-python/recipes-connectivity/python-hyperframe/python-hyperframe_5.2.0.bb
new file mode 100644
index 000000000..4f0c9977a
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-connectivity/python-hyperframe/python-hyperframe_5.2.0.bb
@@ -0,0 +1,3 @@
+require python-hyperframe.inc
+
+inherit setuptools
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-hyperframe/python3-hyperframe_5.2.0.bb b/meta-openembedded/meta-python/recipes-connectivity/python-hyperframe/python3-hyperframe_5.2.0.bb
new file mode 100644
index 000000000..f10fb6df1
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-connectivity/python-hyperframe/python3-hyperframe_5.2.0.bb
@@ -0,0 +1,3 @@
+require python-hyperframe.inc
+
+inherit setuptools3
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-priority/python-priority.inc b/meta-openembedded/meta-python/recipes-connectivity/python-priority/python-priority.inc
new file mode 100644
index 000000000..aa93819bc
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-connectivity/python-priority/python-priority.inc
@@ -0,0 +1,10 @@
+DESCRIPTION = "A pure-Python implementation of the HTTP/2 priority tree"
+HOMEPAGE = "https://github.com/python-hyper/priority"
+LICENSE = "MIT"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae57d8a09fc8b6b164d7357339619045"
+
+SRC_URI[md5sum] = "4f1ff52f7fa448e9d9cb46337ae86d1e"
+SRC_URI[sha256sum] = "6bc1961a6d7fcacbfc337769f1a382c8e746566aaa365e78047abe9f66b2ffbe"
+
+inherit pypi
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-priority/python-priority_1.3.0.bb b/meta-openembedded/meta-python/recipes-connectivity/python-priority/python-priority_1.3.0.bb
new file mode 100644
index 000000000..cbe262576
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-connectivity/python-priority/python-priority_1.3.0.bb
@@ -0,0 +1,3 @@
+require python-priority.inc
+
+inherit setuptools
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-priority/python3-priority_1.3.0.bb b/meta-openembedded/meta-python/recipes-connectivity/python-priority/python3-priority_1.3.0.bb
new file mode 100644
index 000000000..fe756b56b
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-connectivity/python-priority/python3-priority_1.3.0.bb
@@ -0,0 +1,3 @@
+require python-priority.inc
+
+inherit setuptools3