summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-connectivity
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-connectivity')
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/gateone/gateone_git.bb85
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.6.bb2
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-h2/python-h2.inc2
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-h2/python-h2_3.1.1.bb3
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-hpack/python-hpack_3.0.0.bb3
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-hyperframe/python-hyperframe_5.2.0.bb3
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-mprpc/python-mprpc_0.1.17.bb2
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-priority/python-priority_1.3.0.bb3
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman_0.2.0.bb5
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-pyro4/python3-pyro4_4.77.bb (renamed from meta-openembedded/meta-python/recipes-connectivity/python-pyro4/python-pyro4_4.77.bb)4
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-pytun/python-pytun_2.3.0.bb2
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-thrift/python3-thrift_0.13.0.bb (renamed from meta-openembedded/meta-python/recipes-connectivity/python-thrift/python-thrift_0.13.0.bb)2
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb (renamed from meta-openembedded/meta-python/recipes-connectivity/python-txws/python-txws_0.9.1.bb)4
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/parallel_make.patch (renamed from meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python-0.15.19/parallel_make.patch)0
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/remove_duplicate_install.patch (renamed from meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python-0.15.19/remove_duplicate_install.patch)0
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/telepathy-python_fix_for_automake_1.12.patch (renamed from meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python-0.15.19/telepathy-python_fix_for_automake_1.12.patch)0
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python3_0.15.19.bb (renamed from meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb)16
17 files changed, 15 insertions, 121 deletions
diff --git a/meta-openembedded/meta-python/recipes-connectivity/gateone/gateone_git.bb b/meta-openembedded/meta-python/recipes-connectivity/gateone/gateone_git.bb
deleted file mode 100644
index 5d2ca00ef..000000000
--- a/meta-openembedded/meta-python/recipes-connectivity/gateone/gateone_git.bb
+++ /dev/null
@@ -1,85 +0,0 @@
-SUMMARY = "HTML5 (plugin-free) web-based terminal emulator and SSH client"
-LICENSE = "AGPL-3.0"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=834cbc6995db88433db17cdf8953a428"
-HOMEPAGE = "http://liftoffsoftware.com/Products/GateOne"
-
-PV = "1.2+git${SRCPV}"
-SRCREV = "f7a9be46cb90f57459ebd363d24702de0e651034"
-SRC_URI = "git://github.com/liftoff/GateOne.git;branch=master \
- file://gateone-avahi.service \
- file://80oe.conf.in \
- file://gateone.service.in \
- file://gateone-init.in \
-"
-
-S = "${WORKDIR}/git"
-
-inherit setuptools python-dir systemd update-rc.d
-
-DISTUTILS_INSTALL_ARGS += " \
- --install-data=${PYTHON_SITEPACKAGES_DIR} \
- --install-scripts=${bindir} \
- --skip_init_scripts"
-
-do_install_append() {
-
- # fix up hardcoded paths
- for file in gateone.service gateone-init 80oe.conf; do
- sed -e s:@bindir@:${bindir}:g \
- -e s:@localstate@:${localstatedir}:g \
- < ${WORKDIR}/$file.in \
- > ${WORKDIR}/$file
- done
-
- install -d ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/gateone.service ${D}${systemd_unitdir}/system
-
- install -d ${D}${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/gateone-init ${D}${sysconfdir}/init.d/gateone
-
- install -m 0755 -d ${D}${sysconfdir}/avahi/services/
- install -m 0644 ${WORKDIR}/gateone-avahi.service ${D}${sysconfdir}/avahi/services/
-
- install -m 0755 -d ${D}${sysconfdir}/gateone/conf.d/
- install -m 0644 ${WORKDIR}/80oe.conf ${D}${sysconfdir}/gateone/conf.d/80oe.conf
-
- install -d ${D}${localstatedir}/lib/gateone
-}
-
-FILES_${PN} = "${localstatedir}/lib ${bindir} ${base_libdir} ${sysconfdir} ${PYTHON_SITEPACKAGES_DIR}"
-RDEPENDS_${PN} = "mime-support \
- openssh-ssh \
- python-compression \
- python-contextlib \
- python-crypt \
- python-datetime \
- python-email \
- python-fcntl \
- python-futures \
- python-html \
- python-imaging \
- python-io \
- python-json \
- python-logging \
- python-misc \
- python-multiprocessing \
- python-netclient \
- python-pkgutil \
- python-pyopenssl \
- python-re \
- python-setuptools \
- python-shell \
- python-simplejson \
- python-subprocess \
- python-syslog \
- python-terminal \
- python-textutils \
- python-tornado \
- python-unixadmin \
- python-xml \
- python-html5lib \
- bash \
-"
-
-SYSTEMD_SERVICE_${PN} = "gateone.service"
-INITSCRIPT_NAME = "gateone"
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.6.bb b/meta-openembedded/meta-python/recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.6.bb
deleted file mode 100644
index e96ad1ca1..000000000
--- a/meta-openembedded/meta-python/recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.6.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-require python-gsocketpool.inc
-inherit setuptools
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-h2/python-h2.inc b/meta-openembedded/meta-python/recipes-connectivity/python-h2/python-h2.inc
index 42629c261..c457836b7 100644
--- a/meta-openembedded/meta-python/recipes-connectivity/python-h2/python-h2.inc
+++ b/meta-openembedded/meta-python/recipes-connectivity/python-h2/python-h2.inc
@@ -8,3 +8,5 @@ SRC_URI[md5sum] = "950b5a62a2a608dc4547a01edf99aa8f"
SRC_URI[sha256sum] = "b8a32bd282594424c0ac55845377eea13fa54fe4a8db012f3a198ed923dc3ab4"
inherit pypi
+
+RDEPENDS_${PN} += "${PYTHON_PN}-hpack ${PYTHON_PN}-hyperframe"
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-h2/python-h2_3.1.1.bb b/meta-openembedded/meta-python/recipes-connectivity/python-h2/python-h2_3.1.1.bb
deleted file mode 100644
index b84129742..000000000
--- a/meta-openembedded/meta-python/recipes-connectivity/python-h2/python-h2_3.1.1.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require python-h2.inc
-
-inherit setuptools
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-hpack/python-hpack_3.0.0.bb b/meta-openembedded/meta-python/recipes-connectivity/python-hpack/python-hpack_3.0.0.bb
deleted file mode 100644
index faaeb8555..000000000
--- a/meta-openembedded/meta-python/recipes-connectivity/python-hpack/python-hpack_3.0.0.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require python-hpack.inc
-
-inherit setuptools
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-hyperframe/python-hyperframe_5.2.0.bb b/meta-openembedded/meta-python/recipes-connectivity/python-hyperframe/python-hyperframe_5.2.0.bb
deleted file mode 100644
index 4f0c9977a..000000000
--- a/meta-openembedded/meta-python/recipes-connectivity/python-hyperframe/python-hyperframe_5.2.0.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require python-hyperframe.inc
-
-inherit setuptools
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-mprpc/python-mprpc_0.1.17.bb b/meta-openembedded/meta-python/recipes-connectivity/python-mprpc/python-mprpc_0.1.17.bb
deleted file mode 100644
index 6b2ea2193..000000000
--- a/meta-openembedded/meta-python/recipes-connectivity/python-mprpc/python-mprpc_0.1.17.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-require python-mprpc.inc
-inherit setuptools
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-priority/python-priority_1.3.0.bb b/meta-openembedded/meta-python/recipes-connectivity/python-priority/python-priority_1.3.0.bb
deleted file mode 100644
index cbe262576..000000000
--- a/meta-openembedded/meta-python/recipes-connectivity/python-priority/python-priority_1.3.0.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require python-priority.inc
-
-inherit setuptools
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman_0.2.0.bb b/meta-openembedded/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman_0.2.0.bb
deleted file mode 100644
index 3c12db944..000000000
--- a/meta-openembedded/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman_0.2.0.bb
+++ /dev/null
@@ -1,5 +0,0 @@
-require python-pyconnman.inc
-
-inherit setuptools
-
-RDEPENDS_${PN} += "python-dbus python-pprint"
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-pyro4/python-pyro4_4.77.bb b/meta-openembedded/meta-python/recipes-connectivity/python-pyro4/python3-pyro4_4.77.bb
index 738cf8677..ffe58ee9c 100644
--- a/meta-openembedded/meta-python/recipes-connectivity/python-pyro4/python-pyro4_4.77.bb
+++ b/meta-openembedded/meta-python/recipes-connectivity/python-pyro4/python3-pyro4_4.77.bb
@@ -7,12 +7,10 @@ SRC_URI[sha256sum] = "2bfe12a22f396474b0e57c898c7e2c561a8f850bf2055d8cf0f7119f0c
PYPI_PACKAGE = "Pyro4"
-inherit pypi setuptools
+inherit pypi setuptools3
RDEPENDS_${PN} += " \
${PYTHON_PN}-logging \
- ${PYTHON_PN}-selectors34 \
${PYTHON_PN}-serpent \
${PYTHON_PN}-threading \
- ${PYTHON_PN}-zlib \
"
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-pytun/python-pytun_2.3.0.bb b/meta-openembedded/meta-python/recipes-connectivity/python-pytun/python-pytun_2.3.0.bb
deleted file mode 100644
index 3fc587f3a..000000000
--- a/meta-openembedded/meta-python/recipes-connectivity/python-pytun/python-pytun_2.3.0.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-require python-pytun.inc
-inherit setuptools
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-thrift/python-thrift_0.13.0.bb b/meta-openembedded/meta-python/recipes-connectivity/python-thrift/python3-thrift_0.13.0.bb
index 2d51619d4..80f1a5017 100644
--- a/meta-openembedded/meta-python/recipes-connectivity/python-thrift/python-thrift_0.13.0.bb
+++ b/meta-openembedded/meta-python/recipes-connectivity/python-thrift/python3-thrift_0.13.0.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://PKG-INFO;md5=e95cd2f17c70d3180a2b361332319fe0"
SRC_URI[md5sum] = "c3bc8d9a910d2c9ce26f2ad1f7c96762"
SRC_URI[sha256sum] = "9af1c86bf73433afc6010ed376a6c6aca2b54099cc0d61895f640870a9ae7d89"
-inherit pypi setuptools
+inherit pypi setuptools3
# Use different filename to prevent conflicts with thrift itself
PYPI_SRC_URI_append = ";downloadfilename=${BP}.${PYPI_PACKAGE_EXT}"
diff --git a/meta-openembedded/meta-python/recipes-connectivity/python-txws/python-txws_0.9.1.bb b/meta-openembedded/meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb
index f3631cda3..e235682cf 100644
--- a/meta-openembedded/meta-python/recipes-connectivity/python-txws/python-txws_0.9.1.bb
+++ b/meta-openembedded/meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb
@@ -4,12 +4,12 @@ HOMEPAGE = "https://github.com/MostAwesomeDude/txWS"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=76699830db7fa9e897f6a1ad05f98ec8"
-DEPENDS = "python-twisted python-six python-vcversioner python-six-native python-vcversioner-native"
+DEPENDS = "python3-twisted python3-six python3-vcversioner python3-six-native python3-vcversioner-native"
SRC_URI = "git://github.com/MostAwesomeDude/txWS.git"
SRCREV= "88cf6d9b9b685ffa1720644bd53c742afb10a414"
S = "${WORKDIR}/git"
-inherit setuptools
+inherit setuptools3
diff --git a/meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python-0.15.19/parallel_make.patch b/meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/parallel_make.patch
index 248824606..248824606 100644
--- a/meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python-0.15.19/parallel_make.patch
+++ b/meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/parallel_make.patch
diff --git a/meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python-0.15.19/remove_duplicate_install.patch b/meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/remove_duplicate_install.patch
index df95a4c13..df95a4c13 100644
--- a/meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python-0.15.19/remove_duplicate_install.patch
+++ b/meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/remove_duplicate_install.patch
diff --git a/meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python-0.15.19/telepathy-python_fix_for_automake_1.12.patch b/meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/telepathy-python_fix_for_automake_1.12.patch
index f613fdce4..f613fdce4 100644
--- a/meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python-0.15.19/telepathy-python_fix_for_automake_1.12.patch
+++ b/meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/telepathy-python_fix_for_automake_1.12.patch
diff --git a/meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb b/meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python3_0.15.19.bb
index b7aea24a7..d92e6577a 100644
--- a/meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb
+++ b/meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python3_0.15.19.bb
@@ -5,16 +5,17 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1 \
file://src/utils.py;beginline=1;endline=17;md5=9a07d1a9791a7429a14e7b25c6c86822"
DEPENDS = "libxslt-native"
-RDEPENDS_${PN} += "python-dbus"
-SRC_URI = "http://telepathy.freedesktop.org/releases/${BPN}/${BPN}-${PV}.tar.gz \
+SRC_URI = "http://telepathy.freedesktop.org/releases/telepathy-python/telepathy-python-${PV}.tar.gz \
file://parallel_make.patch \
file://remove_duplicate_install.patch \
file://telepathy-python_fix_for_automake_1.12.patch"
PR = "r6"
-inherit autotools pythonnative
+S = "${WORKDIR}/telepathy-python-${PV}"
+
+inherit autotools python3native
SRC_URI[md5sum] = "f7ca25ab3c88874015b7e9728f7f3017"
SRC_URI[sha256sum] = "244c0e1bf4bbd78ae298ea659fe10bf3a73738db550156767cc2477aedf72376"
@@ -25,8 +26,9 @@ FILES_${PN} += "\
"
do_install_append () {
- rm -f ${D}${libdir}/python*/site-packages/telepathy/*.pyc
- rm -f ${D}${libdir}/python*/site-packages/telepathy/*.pyo
- rm -f ${D}${libdir}/python*/site-packages/telepathy/*/*.pyc
- rm -f ${D}${libdir}/python*/site-packages/telepathy/*/*.pyo
+ rm -fr ${D}${libdir}/python*/site-packages/telepathy/__pycache__
+ rm -fr ${D}${libdir}/python*/site-packages/telepathy/__pycache__
+ rm -fr ${D}${libdir}/python*/site-packages/telepathy/*/__pycache__
+ rm -fr ${D}${libdir}/python*/site-packages/telepathy/*/__pycache__
}
+RDEPENDS_${PN} += "python3-dbus"