summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/gyp/gyp_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/gyp/gyp_git.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/gyp/gyp_git.bb15
1 files changed, 14 insertions, 1 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/gyp/gyp_git.bb b/meta-openembedded/meta-python/recipes-devtools/gyp/gyp_git.bb
index 8e48a27fa..d668d1ca1 100644
--- a/meta-openembedded/meta-python/recipes-devtools/gyp/gyp_git.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/gyp/gyp_git.bb
@@ -1,2 +1,15 @@
+DESCRIPTION = "GYP is a Meta-Build system: a build system that generates other build systems."
+HOMEPAGE = "https://gyp.gsrc.io/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ab828cb8ce4c62ee82945a11247b6bbd"
+SECTION = "devel"
+
+SRC_URI = "git://chromium.googlesource.com/external/gyp;protocol=https"
+SRCREV = "caa60026e223fc501e8b337fd5086ece4028b1c6"
+
+S = "${WORKDIR}/git"
+PV = "0.1+git${SRCPV}"
+
inherit setuptools3
-require gyp.inc
+
+BBCLASSEXTEND = "native nativesdk"