summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/gyp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/gyp')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/gyp/gyp-py2_git.bb2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/gyp/gyp.inc13
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/gyp/gyp_git.bb15
3 files changed, 16 insertions, 14 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/gyp/gyp-py2_git.bb b/meta-openembedded/meta-python/recipes-devtools/gyp/gyp-py2_git.bb
new file mode 100644
index 000000000..d69b92ce6
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/gyp/gyp-py2_git.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require gyp.inc
diff --git a/meta-openembedded/meta-python/recipes-devtools/gyp/gyp.inc b/meta-openembedded/meta-python/recipes-devtools/gyp/gyp.inc
new file mode 100644
index 000000000..98ed42cc9
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/gyp/gyp.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "GYP is a Meta-Build system: a build system that generates other build systems."
+HOMEPAGE = "https://gyp.gsrc.io/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ab828cb8ce4c62ee82945a11247b6bbd"
+SECTION = "devel"
+
+SRC_URI = "git://chromium.googlesource.com/external/gyp;protocol=https"
+SRCREV = "fcd686f1880fa52a1ee78d3e98af1b88cb334528"
+
+S = "${WORKDIR}/git"
+PV = "0.1+git${SRCPV}"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-openembedded/meta-python/recipes-devtools/gyp/gyp_git.bb b/meta-openembedded/meta-python/recipes-devtools/gyp/gyp_git.bb
index 2b3f3fb2b..8e48a27fa 100644
--- a/meta-openembedded/meta-python/recipes-devtools/gyp/gyp_git.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/gyp/gyp_git.bb
@@ -1,15 +1,2 @@
-DESCRIPTION = "GYP is a Meta-Build system: a build system that generates other build systems."
-HOMEPAGE = "https://gyp.gsrc.io/"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ab828cb8ce4c62ee82945a11247b6bbd"
-SECTION = "devel"
-
-SRC_URI = "git://chromium.googlesource.com/external/gyp;protocol=https"
-SRCREV = "8bee09f4a57807136593ddc906b0b213c21f9014"
-
-S = "${WORKDIR}/git"
-PV = "0.1+git${SRCPV}"
-
inherit setuptools3
-
-BBCLASSEXTEND = "native nativesdk"
+require gyp.inc