summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python-m2crypto
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python-m2crypto')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch35
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch33
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-m2crypto/m2crypto-0.26.4-gcc_macros.patch35
3 files changed, 0 insertions, 103 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch b/meta-openembedded/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
deleted file mode 100644
index b339d93f7..000000000
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From dfb83a41aaeae326e9b6f02b233af375bc7b8815 Mon Sep 17 00:00:00 2001
-From: Koen Kooi <koen@dominion.thruhere.net>
-Date: Fri, 29 Mar 2013 15:17:17 +0100
-Subject: [PATCH] setup.py: link in sysroot, not in host directories
-
-Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-
-Upstream-status: Unknown
----
- setup.py | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-Index: M2Crypto-0.30.1/setup.py
-===================================================================
---- M2Crypto-0.30.1.orig/setup.py
-+++ M2Crypto-0.30.1/setup.py
-@@ -130,6 +130,7 @@ class _M2CryptoBuildExt(build_ext.build_
- self.set_undefined_options('build', ('bundledlls', 'bundledlls'))
-
- self.libraries = ['ssl', 'crypto']
-+ self.openssl = os.environ.get( "STAGING_DIR" )
- if sys.platform == 'win32':
- self.libraries = ['ssleay32', 'libeay32']
- if self.openssl and openssl_version(self.openssl, 0x10100000, True):
-@@ -150,8 +151,8 @@ class _M2CryptoBuildExt(build_ext.build_
-
- if self.openssl is not None:
- log.debug('self.openssl = %s', self.openssl)
-- openssl_library_dir = os.path.join(self.openssl, 'lib')
-- openssl_include_dir = os.path.join(self.openssl, 'include')
-+ openssl_library_dir = os.environ.get( "STAGING_LIBDIR" )
-+ openssl_include_dir = os.environ.get( "STAGING_INCDIR" )
-
- self.library_dirs.append(openssl_library_dir)
- self.include_dirs.append(openssl_include_dir)
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch b/meta-openembedded/meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch
deleted file mode 100644
index 4b64f4613..000000000
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Do not compute platform, this does not work in cross compile environment
-since it pokes at the system for getting architecture values
-
-Upstream-Status: Inappropriate
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-Index: M2Crypto-0.30.1/setup.py
-===================================================================
---- M2Crypto-0.30.1.orig/setup.py
-+++ M2Crypto-0.30.1/setup.py
-@@ -160,22 +160,6 @@ class _M2CryptoBuildExt(build_ext.build_
- log.debug('self.include_dirs = %s', self.include_dirs)
- log.debug('self.library_dirs = %s', self.library_dirs)
-
-- if platform.system() == "Linux":
-- # For RedHat-based distros, the '-D__{arch}__' option for
-- # Swig needs to be normalized, particularly on i386.
-- mach = platform.machine().lower()
-- if mach in ('i386', 'i486', 'i586', 'i686'):
-- arch = '__i386__'
-- elif mach in ('ppc64', 'powerpc64', 'ppc64le', 'ppc64el'):
-- arch = '__powerpc64__'
-- elif mach in ('ppc', 'powerpc'):
-- arch = '__powerpc__'
-- else:
-- arch = '__%s__' % mach
-- self.swig_opts.append('-D%s' % arch)
-- if mach in ('ppc64le', 'ppc64el'):
-- self.swig_opts.append('-D_CALL_ELF=2')
--
- self.swig_opts.extend(['-I%s' % i for i in self.include_dirs])
-
- # Some Linux distributor has added the following line in
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-m2crypto/m2crypto-0.26.4-gcc_macros.patch b/meta-openembedded/meta-python/recipes-devtools/python/python-m2crypto/m2crypto-0.26.4-gcc_macros.patch
deleted file mode 100644
index 7f6dd29f8..000000000
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-m2crypto/m2crypto-0.26.4-gcc_macros.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Imported from Fedora
-
-Index: M2Crypto-0.30.1/SWIG/_m2crypto.i
-===================================================================
---- M2Crypto-0.30.1.orig/SWIG/_m2crypto.i
-+++ M2Crypto-0.30.1/SWIG/_m2crypto.i
-@@ -8,6 +8,11 @@
- *
- */
-
-+%import "gcc_macros.h"
-+
-+%ignore WCHAR_MAX;
-+%ignore WCHAR_MIN;
-+
- %module(threads=1) m2crypto
- /* We really don't need threadblock (PyGILState_Ensure() etc.) anywhere.
- Disable threadallow as well, only enable it for operations likely to
-@@ -15,11 +20,6 @@
- %nothreadblock;
- %nothreadallow;
-
--#if SWIG_VERSION >= 0x030000
--#define __WCHAR_MAX__ __WCHAR_MAX
--#define __WCHAR_MIN__ __WCHAR_MIN
--#endif
--
- %{
- #ifdef _WIN32
- #define _WINSOCKAPI_
-@@ -95,4 +95,3 @@ static PyObject *x509_store_verify_cb_fu
- %constant int encrypt = 1;
- %constant int decrypt = 0;
- #endif
--