summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-aiohttp_3.7.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-aiohttp_3.7.3.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-aiohttp_3.7.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-aiohttp_3.7.3.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-aiohttp_3.7.3.bb
new file mode 100644
index 000000000..bccbd4b0e
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-aiohttp_3.7.3.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Async http client/server framework"
+DESCRIPTION = "Asynchronous HTTP client/server framework for asyncio and Python"
+HOMEPAGE = "https://github.com/aio-libs/aiohttp"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3bf3d48554bdca1ea7fdb48de378c2ca"
+
+SRC_URI[sha256sum] = "9c1a81af067e72261c9cbe33ea792893e83bc6aa987bfbd6fdc1e5e7b22777c4"
+
+PYPI_PACKAGE = "aiohttp"
+inherit setuptools3 pypi
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-async-timeout \
+ ${PYTHON_PN}-attrs \
+ ${PYTHON_PN}-chardet \
+ ${PYTHON_PN}-html \
+ ${PYTHON_PN}-idna-ssl \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-misc \
+ ${PYTHON_PN}-multidict \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-yarl \
+"