summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-ansicolors_1.1.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-ansicolors_1.1.8.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-ansicolors_1.1.8.bb14
1 files changed, 13 insertions, 1 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-ansicolors_1.1.8.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-ansicolors_1.1.8.bb
index 9ba710cb7..a9ebebeef 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-ansicolors_1.1.8.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-ansicolors_1.1.8.bb
@@ -7,6 +7,18 @@ SRC_URI[sha256sum] = "99f94f5e3348a0bcd43c82e5fc4414013ccc19d70bd939ad71e0133ce9
PYPI_PACKAGE_EXT = "zip"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ cp -f ${S}/test/test.py ${D}${PTEST_PATH}/
+}
BBCLASSEXTEND = "native nativesdk"