summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-asn1crypto_1.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-asn1crypto_1.3.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-asn1crypto_1.3.0.bb23
1 files changed, 21 insertions, 2 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-asn1crypto_1.3.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-asn1crypto_1.3.0.bb
index cfbe57520..0d38da989 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-asn1crypto_1.3.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-asn1crypto_1.3.0.bb
@@ -1,6 +1,25 @@
-inherit setuptools3
-require python-asn1crypto.inc
+DESCRIPTION = "A fast, pure Python library for parsing and serializing ASN.1 structures"
+HOMEPAGE = "https://github.com/wbond/asn1crypto"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7439e38f5e04ff62fae436184786b7ca"
+
+PYPI_PACKAGE = "asn1crypto"
+
+SRC_URI[md5sum] = "daad112940181917e3ff169b47b9bd9a"
+SRC_URI[sha256sum] = "5a215cb8dc12f892244e3a113fe05397ee23c5c4ca7a69cd6e69811755efc42d"
+
+inherit pypi setuptools3
RDEPENDS_${PN}_class-target += " \
+ ${PYTHON_PN}-codecs \
+ ${PYTHON_PN}-crypt \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-numbers \
${PYTHON_PN}-shell \
"
+
+BBCLASSEXTEND = "native nativesdk"