summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-bandit_1.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-bandit_1.7.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-bandit_1.7.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-bandit_1.7.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-bandit_1.7.0.bb
new file mode 100644
index 000000000..2ef956e07
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-bandit_1.7.0.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Security oriented static analyser for python code."
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
+
+SRC_URI[md5sum] = "24965f102dc62129d3fafe4fe596a3b8"
+SRC_URI[sha256sum] = "8a4c7415254d75df8ff3c3b15cfe9042ecee628a1e40b44c15a98890fbfc2608"
+
+DEPENDS = "python3-pbr-native python3-git python3-pbr python3-pyyaml python3-six python3-stevedore"
+
+inherit setuptools3 pypi
+
+RDEPENDS_${PN} += "python3-modules python3-git python3-pbr python3-pyyaml python3-six python3-stevedore"
+
+BBCLASSEXTEND = "native"