summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-bitstring_3.1.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-bitstring_3.1.7.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-bitstring_3.1.7.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-bitstring_3.1.7.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-bitstring_3.1.7.bb
new file mode 100644
index 000000000..eae8275d6
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-bitstring_3.1.7.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Simple construction, analysis and modification of binary data."
+HOMEPAGE = "https://github.com/scott-griffiths/bitstring"
+AUTHOR = "Scott Griffiths <dr.scottgriffiths@gmail.com>"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d973e8e0c311da41424357236b7b8908"
+
+SRC_URI[md5sum] = "18661a3e5c47c59bd926dd0fefae0baa"
+SRC_URI[sha256sum] = "fdf3eb72b229d2864fb507f8f42b1b2c57af7ce5fec035972f9566de440a864a"
+
+PYPI_PACKAGE = "bitstring"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-mmap \
+"
+
+BBCLASSEXTEND = "native nativesdk"