summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-bitstring_3.1.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-bitstring_3.1.9.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-bitstring_3.1.9.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-bitstring_3.1.9.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-bitstring_3.1.9.bb
new file mode 100644
index 000000000..94dbae2af
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-bitstring_3.1.9.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Simple construction, analysis and modification of binary data."
+HOMEPAGE = "https://github.com/scott-griffiths/bitstring"
+AUTHOR = "Scott Griffiths <dr.scottgriffiths@gmail.com>"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f7f2fd3f1cd52b5ccd39d76fb3568d3f"
+
+SRC_URI[sha256sum] = "a5848a3f63111785224dca8bb4c0a75b62ecdef56a042c8d6be74b16f7e860e7"
+
+PYPI_PACKAGE = "bitstring"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} = "\
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-mmap \
+"
+
+BBCLASSEXTEND = "native nativesdk"