summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb16
1 files changed, 14 insertions, 2 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb
index 5f8602d18..ebf7ba4e7 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb
@@ -1,2 +1,14 @@
-inherit setuptools3
-require python-booleanpy.inc
+SUMMARY = "Define boolean algebras, create and parse boolean expressions and create custom boolean DSL"
+HOMEPAGE = "https://github.com/bastikr/boolean.py"
+
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e319747a5eb94cddf646037c01ddba47"
+
+SRC_URI[md5sum] = "1189d115a38f84f5df743014926a9159"
+SRC_URI[sha256sum] = "bd19b412435611ecc712603d0fd7d0e280e24698e7a6e3d5f610473870c5dd1e"
+
+PYPI_PACKAGE = "boolean.py"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"