summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-can_3.3.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-can_3.3.3.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-can_3.3.3.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-can_3.3.3.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-can_3.3.3.bb
new file mode 100644
index 000000000..4da233959
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-can_3.3.3.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Controller Area Network (CAN) interface module for Python"
+SECTION = "devel/python"
+LICENSE = "LGPLv3"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e6a600fd5e1d9cbde2d983680233ad02"
+
+SRC_URI[md5sum] = "1310da316799e4b12944a6c1dcb017a9"
+SRC_URI[sha256sum] = "ecd69cf6b2f0235345ebe607a15325cf1384c85b24ffbe1d68c3754357f87488"
+
+PYPI_PACKAGE="python-can"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-aenum \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-codecs \
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-fcntl \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-misc \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-sqlite3 \
+ ${PYTHON_PN}-wrapt \
+"
+
+BBCLASSEXTEND = "native nativesdk"