summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_0.9.23.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_0.9.23.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_0.9.23.bb20
1 files changed, 16 insertions, 4 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_0.9.23.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_0.9.23.bb
index f5c5c7e1a..a2bf0c45e 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_0.9.23.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_0.9.23.bb
@@ -1,9 +1,21 @@
-inherit setuptools3
-require python-cmd2.inc
+SUMMARY = "Extra features for standard library's cmd module"
+HOMEPAGE = "http://packages.python.org/cmd2/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9791cd24ca7d1807388ccd55cd066def"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+SRC_URI[md5sum] = "6db66a06210d5f1edb44693b887ed62b"
+SRC_URI[sha256sum] = "8ad12ef3cc46d03073c545b6e80a3f84a5921f6653073a60e7d9a7ff3b352c9e"
+
+inherit pypi setuptools3
RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-attrs \
+ ${PYTHON_PN}-colorama \
${PYTHON_PN}-pyperclip \
${PYTHON_PN}-colorama \
- ${PYTHON_PN}-attrs \
${PYTHON_PN}-wcwidth \
- "
+"
+
+BBCLASSEXTEND = "native nativesdk"