summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-dnspython_1.16.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-dnspython_1.16.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-dnspython_1.16.0.bb15
1 files changed, 14 insertions, 1 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-dnspython_1.16.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-dnspython_1.16.0.bb
index cb255442f..66cd88363 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-dnspython_1.16.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-dnspython_1.16.0.bb
@@ -8,7 +8,20 @@ SRC_URI[sha256sum] = "36c5e8e38d4369a08b6780b7f27d790a292b2b08eea01607865bf0936c
PYPI_PACKAGE_EXT = "zip"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
RDEPENDS_${PN} += " \
${PYTHON_PN}-crypt \