summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-dominate_2.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-dominate_2.5.1.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-dominate_2.5.1.bb15
1 files changed, 14 insertions, 1 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-dominate_2.5.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-dominate_2.5.1.bb
index dd8c59603..75dd4ef9f 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-dominate_2.5.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-dominate_2.5.1.bb
@@ -5,7 +5,20 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b52f2d57d10c4f7ee67a7eb9615d5d24"
SRC_URI[md5sum] = "35eeb6b5587c8c9a51cd22c83e07ac49"
SRC_URI[sha256sum] = "9b05481605ea8c0afd0a98c0156a9fb78d9c406368d66b3e6fedf36920fb9d78"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
RDEPENDS_${PN} += "\
${PYTHON_PN}-numbers \