summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-ecdsa_0.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-ecdsa_0.15.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-ecdsa_0.15.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-ecdsa_0.15.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-ecdsa_0.15.bb
new file mode 100644
index 000000000..aba62f3ef
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-ecdsa_0.15.bb
@@ -0,0 +1,13 @@
+SUMMARY = "ECDSA cryptographic signature library (pure python)"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=66ffc5e30f76cbb5358fe54b645e5a1d"
+
+DEPENDS += "python3-pip python3-pbr"
+
+PYPI_PACKAGE = "ecdsa"
+SRC_URI[sha256sum] = "8f12ac317f8a1318efa75757ef0a651abe12e51fc1af8838fb91079445227277"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "python3-six python3-gmpy2 python3-pbr"